Jump to content


Photo

Issuses with Legacy of the Dragonborn LOD

lod dyndolod

  • Please log in to reply
17 replies to this topic

#1 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 10 December 2018 - 11:33 PM

Hi!

I heard that DynDOLOD had Legacy of the Dragonborn support, but it doesn't appear to be working quite properly.

I generated LOD properly, but the museum still isn't appearing quite right. The majority of it isn't visible at a distance.

 

Any help would be much appreciated!
 

20181210112452_1.jpg


  • 0

#2 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,890 posts

Posted 11 December 2018 - 03:57 AM

Hard to tell what went wrong without any information at all.


  • 0

#3 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 11 December 2018 - 08:05 AM

Hard to tell what went wrong without any information at all.


What information do you need exactly? Load order?
  • 0

#4 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,890 posts

Posted 11 December 2018 - 08:17 AM

Game version, version of Legacy of the Dragonborn, version of DynDOLOD, version of DynDOLOD Resources.


  • 0

#5 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 11 December 2018 - 08:53 AM

Game version, version of Legacy of the Dragonborn, version of DynDOLOD, version of DynDOLOD Resources.


Oh yes, of course. Apologises.

I'm running Skyrim: Special Edition with the most recent version and that of SKSE.

I just started a new playthrough last week so I just downloaded all the stuff a few days ago. I should have the most recent version of DynDOLOD and Legacy of the Dragonborn.
  • 0

#6 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,890 posts

Posted 11 December 2018 - 09:30 AM

Check if DynDOLOD\Edit Scripts\Export\LODGen_SSE_Tamriel.txt contains a line like

xxxxxxxx 00000000 -55314.347656 100706.976563 -8728.261719 0.0000 0.0000 135.0000 1.0 DBM_MuseumBuilding 00000000 -LargeRef meshes\dbm resources\architecture\museum.nif meshes\lod\dbm\museum_lod.nif meshes\lod\dbm\museum_lod_1.nif meshes\lod\dbm\museum_lod_2.nif

If not, then DynDOLOD Resources Core Files might not be fully installed, like an incomplete download or the archive was not fully extracted. Check the installed DynDOLOD Resources Core Files have meshes\lod\dbm\museum_lod.nif

 

If that seems fine check if DynDOLOD\Logs\LODGen_SSE_Tamriel_log.txt last line is Code: 0

The DynDOLOD\Logs\DynDOLOD_SSE_log.txt should have LODGenx64.exe for Tamriel completed successfully near the end.

 

If all that seems fine, make sure that all files from output folder are installed and none are overwritten by other mods.


  • 0

#7 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 11 December 2018 - 09:32 AM

Thanks a ton Shenson! I'll have a look as soon as i get home.

If it's an issue with the script files do I need to rerun the DynDOLOD generators?
 

If all that seems fine, make sure that all files from output folder are installed and none are overwritten by other mods.

Should Output be loaded last on ModOrganizer 2 in this case?
 


Edited by PierreDespereaux, 11 December 2018 - 09:37 AM.

  • 0

#8 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,890 posts

Posted 11 December 2018 - 09:48 AM

It is not an issue with script files.

 

This is all about static object LOD. If the static object LOD was not generated correctly because LOD assets were missing or the LODGen process did not complete without error, then static object LOD needs to be generated again.

 

If something should not be overwritten by anything it means it should load after those anything that conflicts. Something having the highest priority in MO loads last, so that will accomplish that,


  • 0

#9 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 11 December 2018 - 09:08 PM

Check if DynDOLOD\Edit Scripts\Export\LODGen_SSE_Tamriel.txt contains a line like

xxxxxxxx 00000000 -55314.347656 100706.976563 -8728.261719 0.0000 0.0000 135.0000 1.0 DBM_MuseumBuilding 00000000 -LargeRef meshes\dbm resources\architecture\museum.nif meshes\lod\dbm\museum_lod.nif meshes\lod\dbm\museum_lod_1.nif meshes\lod\dbm\museum_lod_2.nif

If not, then DynDOLOD Resources Core Files might not be fully installed, like an incomplete download or the archive was not fully extracted. Check the installed DynDOLOD Resources Core Files have meshes\lod\dbm\museum_lod.nif

 

If that seems fine check if DynDOLOD\Logs\LODGen_SSE_Tamriel_log.txt last line is Code: 0

The DynDOLOD\Logs\DynDOLOD_SSE_log.txt should have LODGenx64.exe for Tamriel completed successfully near the end.

 

If all that seems fine, make sure that all files from output folder are installed and none are overwritten by other mods.

Hi Shenson!

I checked the log file and I couldn't find anything like you quoted, so I checked the Resource Core. It appears to have the correct museum_lod,nif (2 and 3 also).

Code: 0 seems to be in order.

I'm going to try and move the mod priority (left pane) around a bit and see if that fixes anything. I think Skyrim Flora Overhaul and ELFX might be overwriting some things. I'll report back when I'm done testing.

Here are some more pictures I took of the issue:

https://imgur.com/a/c5YqVIn


Edited by PierreDespereaux, 11 December 2018 - 09:09 PM.

  • 0

#10 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 11 December 2018 - 11:38 PM

It is not an issue with script files.

 

This is all about static object LOD. If the static object LOD was not generated correctly because LOD assets were missing or the LODGen process did not complete without error, then static object LOD needs to be generated again.

 

If something should not be overwritten by anything it means it should load after those anything that conflicts. Something having the highest priority in MO loads last, so that will accomplish that,

I have DynDOLOD Output loaded last, but the issue still persists.

I was able to find this in LODGen_SSE_Tamriel.txt after further searching though;

3E004087    00000000    -55314.347656    100706.976563    -8728.261719    0.0000    0.0000    135.0000    1.0    DBM_MuseumBuilding    00000000    -LargeRef    meshes\dbm resources\architecture\museum.nif    meshes\lod\dbm\museum_lod.nif    meshes\lod\dbm\museum_lod_1.nif    meshes\lod\dbm\museum_lod_2.nif

Also here is my current load order, if that matters at all:

Capture.PNG


Edited by PierreDespereaux, 11 December 2018 - 11:43 PM.

  • 0

#11 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 11 December 2018 - 11:51 PM

Here's an interesting development:

If I toggle the DynDOLOD.esp off the LOD works fine.

 

20181211234912_1.jpg


  • 0

#12 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,890 posts

Posted 12 December 2018 - 05:12 AM

Here's an interesting development:

If I toggle the DynDOLOD.esp off the LOD works fine.

 

20181211234912_1.jpg

Those image links do not work. If you disable DynDOLOD the LOD is not working "fine". Then the full model of the museum defined by the Legacy of Dragonborn plugin is shown again. This is fully expected.

 

Since the museum is in the export file, now do the second check I already suggested that LODGen had no errors.

 

If LODGen had no errors, in MOs right window data tab, open meshes\terrain\Tamriel\Objects\Tamriel.4.-16.24.bto with nifskope and check if the museum can be seen.


  • 0

#13 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 12 December 2018 - 10:21 AM

Those image links do not work. If you disable DynDOLOD the LOD is not working "fine". Then the full model of the museum defined by the Legacy of Dragonborn plugin is shown again. This is fully expected.

 

Since the museum is in the export file, now do the second check I already suggested that LODGen had no errors.

 

If LODGen had no errors, in MOs right window data tab, open meshes\terrain\Tamriel\Objects\Tamriel.4.-16.24.bto with nifskope and check if the museum can be seen.

No, I cannot see the museum in Tamriel.4.-16.24.bto. It says the file is part of the "Overwrite" mod.

Would you like me to reupload my screenshots?


Edited by PierreDespereaux, 12 December 2018 - 10:24 AM.

  • 0

#14 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,890 posts

Posted 12 December 2018 - 10:40 AM

No, I cannot see the museum in Tamriel.4.-16.24.bto. It says the file is part of the "Overwrite" mod.

Would you like me to reupload my screenshots?

That means the output from DynDOLOD is overwritten by whatever files are in the MOs Overwrite folder. Probably from an earlier LOD generation with xLODGen without using the -o argument.

 

There should be really no files in MOs Overwrite folder. MO will put new files written to the "Data" folder by tools or mods into the Overwrite folder. Once they do they should be moved into a suitable mod folder.

 

Not a single file from the DynDOLOD output should be overwritten by anything.


Edited by sheson, 12 December 2018 - 10:41 AM.

  • 0

#15 PierreDespereaux

PierreDespereaux

    Prisoner

  • Members
  • 14 posts

Posted 12 December 2018 - 10:47 AM

That means the output from DynDOLOD is overwritten by whatever files are in the MOs Overwrite folder. Probably from an earlier LOD generation with xLODGen without using the -o argument.

 

There should be really no files in MOs Overwrite folder. MO will put new files written to the "Data" folder by tools or mods into the Overwrite folder. Once they do they should be moved into a suitable mod folder.

 

Not a single file from the DynDOLOD output should be overwritten by anything.

So it appears by creating Overwrite as a mod and loading it everything is fixed. Even smaller issues with my LOD are gone.

Am I safe to delete the loose files in Overwrite or should I just keep it as a mod? My Creation Club mods are also stored in Overwrite for some reason.


  • 0



Also tagged with one or more of these keywords: lod, dyndolod

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users