Jump to content


Photo

DynDOLODx64 SSE stops generating after DLC2ApocryphaWorld


  • Please log in to reply
30 replies to this topic

#16 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 30 January 2019 - 03:55 AM

Are there any plugins changing the world space?

 

If you do not select the problematic worldspace, does it hand on the next one?

 

Does only using vanilla trees and vanilla billboards make a difference?

 

Check if it hangs with latest MO 2.2 alpha or without using MO


Edited by sheson, 30 January 2019 - 03:56 AM.

  • 0

#17 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,621 posts

Posted 30 January 2019 - 08:07 AM

Are there any plugins changing the world space?

If you do not select the problematic worldspace, does it hand on the next one?

Does only using vanilla trees and vanilla billboards make a difference?

Check if it hangs with latest MO 2.2 alpha or without using MO

I don't think there are any plugins changing that worldspace. It's a very small worldspace, but I have to check to be positive.

I'd have to test it again but I want to say it does hang on the next one when you uncheck that world.

I don't understand what changing billboards would do because I can run Tree LOD all day with no problem unless I have that one specific combination of settings checked. So changing billboards doesn't make sense to me. But I can try I it if you insist.

I can test the alpha version of MO, but I will not go as far as testing outside of MO because that would mean moving all my mods into my data folder...I have nearly 300 mods in this setup. That would take days on my schedule....

#18 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 30 January 2019 - 09:03 AM

Test generation for the vanilla game with a couple mods in new MO profile.

 

What happens if you uncheck Create textures atlas only?


  • 0

#19 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,621 posts

Posted 30 January 2019 - 10:01 PM

Test generation for the vanilla game with a couple mods in new MO profile.

 

What happens if you uncheck Create textures atlas only?

Well, I'll left you know if I get it to freeze again. Magical fairies visited and sprinkled their fairy dust because now it's working like a charm with all settings...  :confusion:  Nothing changed in the setup, the computer hasn't been restarted since, and all the same programs are still running...  :crash:



#20 Project579

Project579

    Citizen

  • Members
  • Pip
  • 56 posts

Posted 05 February 2019 - 01:13 PM

Just so you know I'm getting this bug as well, can provide info if needed.


  • 0

#21 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 05 February 2019 - 02:42 PM

Well its easy then, just answer the questions/suggestions what to check from earlier posts.


  • 0

#22 dragonseth07

dragonseth07

    Prisoner

  • Members
  • 2 posts

Posted 11 February 2019 - 12:33 AM

Hello! Maybe I can provide some new info, since I'm having the exact same issue.

 

1. I can confirm that the issue isn't with MO, as I am using Vortex for my organization, and I'm running the executable totally independent of any organizer.

2. I can confirm that the issue is not with Skuldafn specifically. If that world is removed, the program instead hangs on the next available world, whatever it is. It always hangs after Apocrypha.

3. I was able to generate LOD's for everything BUT Apocrypha with no issue. It seems like Apocrypha, after it finishes, is causing the program to hang. If we could run all worlds and just have it do Apocrypha last, I suspect it would work.

4. I have the issue on both Medium and High settings. There is no difference.

5. Everything DID work when I tried on a light mod setup. Only the following were enabled:

-SKSE

-DynDOLOD Resources SE

-SSE Engine Fixes

-PapyrusUtil SE

-USSEP

-Enhanced Vanilla Trees (with Billboard file)

 

I'm now going through, enabling mods in small bunches to try and see where the problem starts, if it's with a particular mod, or what. I will report back with what I find.


  • 0

#23 dragonseth07

dragonseth07

    Prisoner

  • Members
  • 2 posts

Posted 11 February 2019 - 06:55 PM

I'm back with some mod testing, and I'm sorry to say that it's probably not very helpful.

 

I tested through, adding mods bit by bit. Eventually, it looked like Verdant - A Skyrim Grass Plugin, was the issue. Adding that in by itself made it stop, and reverting that made it work. To confirm, I re-enabled it and tried again, and it completely worked, with the same exact setup that made it hang prior. :/ I've tested some more setups, and it looks like there isn't a specific mod causing the issue. It looks like the more mods I have enabled, the higher and higher chance of hanging the program gets. It can work or not work with the exact same setup. With enough mods enabled, it hangs every time.

 

I'm not quite technical enough to know what kinds of mods are actually making the difference here (though graphics mods seem to be making a bigger impact, this is far from scientific). I can just tell that it's more consistently working with less mods added, and hanging once I have more than a few enabled.

 

Edit: Is it possible this is an issue of a user's computer simply not being able to handle it, with a lot of mods hanging around? The Task Manager says I'm maxing out my CPU while DynDOLOD is doing its thing.

 

For what it's worth, I was able to work around this prior to having many mods installed by running only some worlds, enabling it, then running the rest and merging per instructions in other threads. I tried to replicate this method with a full load order but it no longer works, as DynDOLOD throws up an error when running the second time. I'm trying to figure that particular bit out myself, at the moment.


Edited by dragonseth07, 11 February 2019 - 07:06 PM.

  • 0

#24 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 12 February 2019 - 03:43 AM

Thanks for all the testing it is very helpful. I suspect this to be some kind of problem with the atlas texture generation. I am doing updates to that which might help fixing it in the next version.


  • 0

#25 couldntthinkofaname

couldntthinkofaname

    Prisoner

  • Members
  • 5 posts

Posted 19 February 2019 - 07:18 AM

Apparently I found myself on same road as the rest here - on x86 Skyrim though (so basically a different .exe tool in use)

 

Now I for whatever reason after falling asleep doing reruns and reruns just ran Ancient tes5lodgen trees only and found a very, very interesting endline:

cannot fit (existing and found) b'board on atlas - not enough space (of course only after all worlds checked) 

 

Now this is a very specific line that I never seen in dyndolod, there it's usually just a random user access (or another of those) .pas error

 

Now question is, is that a Skyrim limitation at work or? Because the atlas (or atlases) actually have space

there's an amount of trees from left to right, but at bottom there are empty rows, it looks with eyes that half the DDS file is empty, like at least 50 trees more fit on that 


  • 0

#26 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 19 February 2019 - 07:36 AM

When this message shows not all billboard fit onto the tree LOD atlas.

 

Without knowing the entire list and resolutions of billboard textures it is impossible to know if there actually might have been enough space or not. Instead of assuming that there still might be unused space, assume there really isn't enough left for all the billboards.

 

It is possible that current version of DynDOLOD silently dies with that message. So I will test that scenario.


  • 0

#27 couldntthinkofaname

couldntthinkofaname

    Prisoner

  • Members
  • 5 posts

Posted 19 February 2019 - 09:50 AM

Finally I got a full tree run done!

 

An All Worlds checked and active Generate TreeLOD + Generate Atlas (which for whatever reason generated an ESP also - no skse data though as no object lod checked)

I think this esp is from custom line rules, selfmade rules and so on - like Permanent FullModel rules

 

And ZERO errors or missing or anything, just the occassional stutter (you'd need a NASA machine to not stutter during morrowind trees generation)

 

So, this is now my failsafe ALL esp to go back to (distant trees are way more important to me than distant objects) when the Generate Static and Generate Dynamic fail 

 

 

Oh uh, the Generate Atlas checkbox is only trees right? 

Not needed for Objects or do I grasp that wrong


  • 0

#28 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 19 February 2019 - 10:46 AM

Tree LOD does not work without creating a tree LOD atlas at the same time.

 

The Create texture atlas checkbox belongs to static object LOD generation.


Edited by sheson, 19 February 2019 - 10:46 AM.

  • 0

#29 couldntthinkofaname

couldntthinkofaname

    Prisoner

  • Members
  • 5 posts

Posted 19 February 2019 - 04:18 PM

I decided to go back to what I call armory-matching LOD

 

It's weird, but somehow dyndolod works perfectly fine with vanilla & landscape-only mods

 

But once I add mods where characters run around with their own shipped armory (shumer, cyrodiil, falskaar, all the "Some Assembly Required" bunch) on top of my already Morrowind enhanced "Morrorim" --

 

despite those mods not really caring about Skyrim/Solstheim

(because their own islands/worlds and whatever - even Cyrodiil-based mods have a seperator of sorts, you dont just run south and that's it, there is always loadingscreens, typically a cave or a gate triggering transition)

 

somehow Skyrim subworlds like Skuldafn and Apocrypha and whatnot crash the tool while having nothing to do with some island lightyears away

 

Oh well, my Morrorim is big enough without even more places anyway, I doubt I've even seen all the critters in Morrowind yet.

 

 

/////////

 

But technically - Why?

Why does for example my DLC2Solstheim trees crash dyndolod once I add Cyrodiil which is on other end of Tamriel - it makes no sense, it should then crash its own space, not a space it has nothing to do with.

(It's really only then that something happens for me)

 

\\\\\\\\

 

Conclusion:

The tool is amazing for simple Skyrim and even Morrorim. No doubt there.

But best to stay away from "Assembly Required"  :cool:


  • 0

#30 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,522 posts

Posted 20 February 2019 - 04:44 AM

If you generate the worldspaces seperatory, install and then generate run other wordspaces it should work fine.

It is some kind of a memory issue that I hope is fixed in the next version.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users