Jump to content


Photo

Major FPS drop/lock when looking at the center of any major city


  • Please log in to reply
14 replies to this topic

#1 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 06 January 2019 - 09:00 PM

Playing SkyrimVR and have yet to find a solution for this.. Basically if I use Dyndolod everywhere is fine except when facing the center of any of the 5 major holds.. basically if I teleport to (City)Origin location and look towards the center my FPS drops to 30 fps and locks there.. i look away in another direction and it's perfectly fine back up to 90. Without Dyndolod it's perfectly fine. I also tried the mod that disables outside LODs from Whiterun,Riften and Solitude and that also resolves the issue for those cities. 

 

The other strange thing is when i'm watching the oculus performance graph it says I have 40% extra headroom yet my FPS caps at 30 when this happens.. it obviously isn't any sort of Vsync since it only caps the fps when looking dead center of the city.. 

 

honestly the most bizarre issue I have ever had.. I tried with all my landscape/city overhauls/mods like skyrim sewers disable but still happpens with Dyndolod active.. figured i'd ask see if anyone has run into anything similar


  • 0

#2 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,776 posts

Posted 07 January 2019 - 04:28 AM

Is this with Open Cities?

 

Can you test what happens if just disable the meshes (the static object/tree LOD) from output?

 

What happens if you just disable dynamic LOD from MCM?


  • 0

#3 WDeranged

WDeranged

    Prisoner

  • Members
  • 40 posts

Posted 07 January 2019 - 07:52 AM

Could this be the Tree LOD Alpha Update Caching issue that SSE Engine Fixes has a patch for?


  • 0

#4 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 08 January 2019 - 11:28 PM

Is this with Open Cities?

 

Can you test what happens if just disable the meshes (the static object/tree LOD) from output?

 

What happens if you just disable dynamic LOD from MCM?

no i don't use open cities.. will try the others and let you know


Could this be the Tree LOD Alpha Update Caching issue that SSE Engine Fixes has a patch for?

sse engine fixes has no VR version currently just SSE Fixes


  • 0

#5 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 13 January 2019 - 01:39 AM

was out of town.. just got back and checked it's something with the meshes as it only happens when those are enabled


  • 0

#6 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,776 posts

Posted 13 January 2019 - 03:50 AM

So the next step would be to see if it can be narrowed down.

 

In the meshes you have object and tree LOD folders. Hide them each once so it falls back to the vanilla LOD and see if that makes a difference.


  • 0

#7 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 13 January 2019 - 11:43 AM

checking shortly ill let you know


  • 0

#8 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 13 January 2019 - 12:26 PM

ok so narrowed it down to the tree meshes.. for my tree mods i'm just using EVT with the billboards it provides.. i also use 3d landscapes which has some tree lods


Edited by AerowynX, 13 January 2019 - 12:28 PM.

  • 0

#9 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,776 posts

Posted 13 January 2019 - 12:52 PM

The tree LOD files in Meshes\Terrain\Tamriel\Trees\* are not true meshes though, they are rather a type of simple data files.

 

If they are the problem, then the issue is most likely the bug with many plugins causing FPS drops that is fixed by SSE Fixes/Engine Fixes.

 

Try lowering the tree LOD distance.

 

Install less billboards, so some groups of trees simply do not have LOD (like the vanilla game) so there is less LOD trees for the engine to deal with.

 

You could try resizing Textures\Terrain\Tamriel\Trees\TamrielTreeLod.dds to make it smaller, but I doubt that is going to help much.

 

Crazy idea would be to merge as many plugins as possible to reduce their number.

 

As an alternative to 2D tree LOD, use tree LOD in object LOD. You can set Billboards for every LOD level. Then it is just mostly like the 2D tree LOD, but with out that bug.

 

Not much else I can think of without a patch for VR and that bug.


  • 0

#10 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 13 January 2019 - 12:56 PM

i do use sse fixes which has the plugin fix.. ill try removing the 3d landscapes billboards and run it again and see.. do you have any thoughts as to why it only specifically happens in the major holds and only directly looking into the center of the town.. just so bizarre to me why it does that.. i can walk around the outskirts of whiterun with LODs all around and no problem but standing on the entry bridge thing in whiterun looking towards the center it locks my FPS just so strange


  • 0

#11 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,776 posts

Posted 13 January 2019 - 02:24 PM

It is possible that more odd things happen with tree LOD and that engine. It already had cell border issues in Skyrim.

 

It seems the best bet is to disable it and have trees done in object LOD to avoid any of these issues.


  • 0

#12 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 13 January 2019 - 02:39 PM

ill give that a shot.. to have trees done in object LOD is that just the ini setting TreeLOD=0 ? 


  • 0

#13 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,776 posts

Posted 13 January 2019 - 02:55 PM

Yes. And then make sure the  second to last "tree" mesh rule in the advanced options is set to Billboard for LOD4 in case you do not want to do 3D tree LOD - which would require much more resources obviously.


  • 0

#14 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 13 January 2019 - 02:59 PM

ok cool deal will try it out. Thanks :)


  • 0

#15 AerowynX

AerowynX

    Prisoner

  • Members
  • 9 posts

Posted 13 January 2019 - 06:00 PM

so oddly it was still happening after trees done in object LOD.. but then disabled Dyndolod completely and it now is still happening.. so guess it isn't just related to dyndolod but i have no idea why it went away when testing before with just disabling the tree meshes.. so now just gotta do the good old disable everything and narrow it down i guess.. 


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users