Jump to content


Photo

3d Tree LOD no branches


  • Please log in to reply
2 replies to this topic

#1 rilax

rilax

    Prisoner

  • Members
  • 2 posts

Posted 10 January 2019 - 06:19 PM

Hi, I usually don't really make forum posts but if i'm honest I have zero clue what to do right now. At first Dyndolod with the 3d trees worked perfectly fine, but after awhile I needed to update my lod again because of some new mods (which just add some extra buildings) and now my Aspen trees look like this. Nothing changed in my folder besides the new mods which only add some extra buildings here and there, just .esp and vanilla resources nothing custom.

 
4pxxs3j.jpg
 
I am using the EVT with RAT support for oldrim and only the Aspen trees have this problem. I have tried everything I could think of, re-generating the lod, checking the logs for errors, re-installing EVT and Billboard generator, checking the passthrough nifs in Nifskope to see if everything it setup up correctly texture wise, regenerating the .ini's, and doing a clean clean install of EVT, BBG, and D-LOD multiple times but nothing worked.
 
The weird part is there seems to be nothing wrong with the Dyndolod installation itself per se. The log gave me no critical errors about missing files and the trunks are there being loaded properly, but when I get close something weird happens. When I get close to the LOD trees in ''tfc'' the leaves actually show up when I'm 1 meter in front of them. It's like there is some sort of hidden distance setting which has been reset to 1 just for the leaves. Because this reminded me of how some .ini distance settings work I tried regenerating the .ini's as well but that didn't do anything sadly.
 
What is also weird is that the LOD trees far, far in the back are in fact being loaded properly. I don't know which LOD level you would call it but there seems to be a problem with the nearest LOD level, level 4? The required files are there, and they are not missing because they can be loaded. There is just something, some hidden setting somewhere which prevents the branches and leaves to be loaded from further away then 1 meter. Which actually also doesn't make much sense because you would think a setting like that would govern all the trees not just the Aspen ones.
 
It has been screwing my head the last couple of days so yeah I really hope I can be guided towards the light again.
 
Thanks in advance, really. Solo troubleshooting already makes me crazy I can't imagine how it must be to troubleshoot for a lot of people.

Edited by rilax, 10 January 2019 - 06:20 PM.

  • 0

#2 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,987 posts

Posted 11 January 2019 - 02:36 AM

https://forum.step-p...r-254/?p=230483


Edited by sheson, 20 February 2019 - 11:54 AM.

  • 0

#3 rilax

rilax

    Prisoner

  • Members
  • 2 posts

Posted 11 January 2019 - 07:51 AM

Thanks a bunch Sheson, I checked the link and I removed the mipmaps and recreated them as Indanger did with GIMP and it works perfectly!

 

wlckTGH.jpg

 

My eyes are happy, thanks again for making my trees nice again.  ::):


Edited by rilax, 11 January 2019 - 07:54 AM.

  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users