Jump to content


Photo

SSEEdit Fatal: Could not find ini---at wits end


  • Please log in to reply
4 replies to this topic

#1 Seeker17281

Seeker17281

    Prisoner

  • Members
  • 10 posts

Posted 25 January 2019 - 04:14 PM

I'm of what I would say "middling" experience with modding.  I've used TESV and TES4 a fair bit in the past with my most recent game of Oblivion seeing the most amount of use of the utility.  So basically I'm not completely ignorant and have some experience with how essential utilities such as Xedit, Wyre and mod organizers are.  Recently I upgraded my rig and was more or less forced into Win10 from Win7 (long story, not worth going into) and I'm constantly encountering little gotchas from Win10 with many of my programs with this possibly being another example. 

 

Anyway, here is the issue, after making the move from NMM to MO2 and deciding to give SkyrimSE a try I'm building a modded game following TUCO's guide.  Right off the bat, I'm running into issues because I can't clean the Beth esm's at all, in fact I can't clean anything with either TESV or SSEEdit for their respective games, I keep getting this error mesage.

 

 

SSEEdit 4.0.1 (40732B8C) starting session 2019-01-24 17:48:01

Using Skyrim Special Edition Data Path: E:\steam\steamapps\common\Skyrim Special Edition\Data\

Using Backup Path: E:\steam\steamapps\common\Skyrim Special Edition\Data\SSEEdit Backups\

Using Scripts Path: E:\MO2 SSE\SSEEdit 4.0.1\Edit Scripts\

Using Cache Path: E:\steam\steamapps\common\Skyrim Special Edition\Data\SSEEdit Cache\

Using ini: C:\Users\Fherrit Den\AppData\Local\Temp\My Games\Skyrim Special Edition\Skyrim.ini

Fatal: Could not find ini

 

 

In case the above isn't enough, below is my best recollection of this situation's evolution;

 

After comparing mod organizers I decided on MO2, downloaded the installer version, created a MO2 folder on my Game drive (E) and dropped the executable there.  Launched it and MO2 defaulted to install into my user/local/appdata drive.  Not too keen on it being on my system SSD, I like to keep my pc gaming all on a 2 TB HDD purposed for Steam and related utilities.  I hunted for a solution found Gamer Poet's series and followed it's suggestions closely.  From within xedit I told it to set the base directory to my Game drive  "E:\MO2 SSE", and based on my understanding of the video, left the rest at  %BASE_DIR%/Downloads, etc.

 

Then I extracted xedit 4.0.1 and dropped the extrracted folder into the same folder as MO2, meaning that xedit sits in it's own folder within the MO2 folder.  (GP's videos said it doesn't matter where you drop xedit so assuming that's not a issue).  I followed this up with launching the game from both the SkyrimLauncher and the Skyrim.exe based on previous experience of needing to generate ini's, set my display preferences and exited the game without playing it.  I checked the my games folder within my documents on my system drive and noted that both ini's were present.

 

Fired up MO2, configured it to access my Nexus account, opened up the modify executables tool and entered the following (my entry in italics):

 

Title: SSEEdit

Binary: E:\MO2 SSE\SSEEdit 4.0.1\SSEEdit.exe

Start in: E\MO2 SSE

Arguments: -SSE

 

That done I listened to the far more knowledgable than me and wanted to clean my Bethesda esms, unfortunately each time I get the above message.  During this past week of banging my head against this wall I've attempted the following:

 

  • When in doubt, uninstall/reinstall.  Uninstalled both SkyrimSE, MO2 and xedit.  Reinstalled everything with fresh downloads.  No change.
  • Dug deeper, uninstalled MO2 again, ripping all traces of it.  Downloaded and installed the archived version of MO2, set my folder structures as above, reinstalled xedit with the same configuration as detailed by GP and got the same error message.
  • Ripped out the archived version, made sure all traces of MO2 was gone from my system and reinstalled the executable version and left everything at default settings in my app data folder.  Xedit still failed to run.
  • Since leaving everything in appdata did nothing, I ripped MO2 out again, reinstalled to my original folder on my E drive, meticulously followed GP's guide again.  This time I gave the entire folder of "MO2 SSE" full control permission via the securities tab and set all child folders to have the same.  I then went into Win10's Defender and granted the folder exclusion status from the choices available  When that didn't change anything I specified SSEEdit.exe to the list of exclusions, again to no fixing the crash.

 

Finally, I looked at the file path the error code is pointing at (or what I believe it to be doing) and have to confess first off, annoyed that it's even looking at AppData since I specifically pointed MO2 at a folder of my choosing.  But looking inside it under Users\Fherrit Den\AppData\Local\Temp  there is no "My Games\Skyrim Special Edition\Skyrim.ini" to be found and I have no clue why it would expect such to be there.  However i can find those inis in  C:\Users\Fherrit Den\Documents\My Games\Skyrim Special Edition.  If it's going to the AppData\Temp by mistake, I have zero idea why or how to point it elsewhere.

 

So that's all i can think of that might be of use, if anyone could help I'd deeply appreciate it.


  • 0

#2 Seeker17281

Seeker17281

    Prisoner

  • Members
  • 10 posts

Posted 25 January 2019 - 05:19 PM

I realized I left out something in the above that may be of some relevance.  If I'm just reaching then someone more knowledgeable should feel free to correct me.

 

I upgraded my main PC after saving up for it during the year, buying a new mobo/gfx card/cpu/ram.  I'm pretty tech savvy when it comes to hardware and have been building my own computers for 30+ years now.  You'll note I didn't mention any hard drive upgrades, that's because I was going to use all my hard drives from my previous configuration, I have a 500gb SSD as my OS drive, a 2TB WD Black as my Steam-game-hobby drive, and 2 4TB HDDs for everything else.  Later this year I intend to upgrade the drives, but for now this is my storage from the previous rig's setup.

 

My rig ran on Win7 because when I opted into the free upgrade to Win10 I had nothing but problems and quickly grew disgusted with it, especially as I had to do a complete reformat of my OS drive to get back into Win7 and haven't looked back.  Unfortunately the Asus 390 prime mobo I was so proud of doesn't like Win7, I was caught unawares of the fact that the 370 gen boards require Win10 for full functionality, otherwise all those nifty usb ports are dead.  I spent a full week trying to get around this barrier doing all kinds of recommended fixes but nothing worked, eventually I caved and tried a upgrade install of Win 10 but that created a new set of problems that made the system fairly unstable.  I realized that my only sensible solution was to reformat my OS drive and do a clean install of Win10, that eliminated almost all of the problems I had encountered from attempting the upgrade option and I had to concede, Win10 didn't have the issues it once had.  (It has other "features" I dislike but that's another story).

 

Prior to the upgrade of my hardware, I had backed up all the contents of the "My Documents" folder and stored it on my game drive, thus when I had to do a clean install of Win10 once I was certain it was stable, I copied the contents of that My Documents folder into the user folder of my new Win 10 OS.

 

The point of mentioning this is I have great respect for the authors of these utilities, not just for the utility but the service they give the community.  I kept asking myself why is xedit looking in the AppData\Local\Temp folder?  All my game files are in the User\Document folder which is the default location I've been using for years now.  It occurred to me that this might be the new default of Win10 and that by dropping the My Games folder into the document folder, I'm not doing it the way Win10 intended.

 

Am I on to something here or is this just the lost ramblings of the ignorant?


  • 0

#3 Seeker17281

Seeker17281

    Prisoner

  • Members
  • 10 posts

Posted 25 January 2019 - 06:42 PM

Posting a follow up to this issue, a bit longish to read but I wanted to be thorough in case anyone else winds up having a problem similar to mine and this account is of some assistance.

 

I’m not one of these bright jewels that can look at programs and figure much out about them without a lot of research into tutorials or readmes, and if the particular issue isn’t warned about it’ll blindside me like it did here.  However after 20 some hours of googling up forum posts addressing all kinds of xedit issues I started to have this nagging feeling that my clue was in that last line of xedit’s error message.

 

Xedit was looking for inis in a place that didn’t correspond to where the “My Games” folder is on my system.  Why would it do that?  I’m assuming because the author told it to, and guessed that’s because its set up like this for most people, just not me.  Why?

 

So as of this writing, I have no idea where Win10 normally defaults the “My Games” folders to, but on my rig under the AppData\Local\Temp there wasn’t a “My Games” folder to be found.  The error code that Xedit kept tossing at me nagged me to try to do something to make it happy.   So I went into

 

  1. C:\Users\XXXX\Documents\My Games\Skyrim Special Edition and copied the Skyrim Special Edition folder containing the inis generated from launching the game,
  2. Then I went into C:\Users\XXXX\AppData\Local\Temp, created a folder named “My Games”, opened it and pasted the copy of “Skyrim Special Edition” from the other location. 
  3. Restarted my system

Loaded up MO2, started Xedit and suddenly the welcome screen says hi and is eager to get to work.

 

I don’t particularly like this and consider it a make shift patch to the problem, hopefully the team behind xedit will in the near future allow one to select where xedit will find the ini’s it’s looking for rather than making a assumption of where it should be.


  • 0

#4 Greg

Greg

    Dragonborn

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 1,941 posts

Posted 25 January 2019 - 07:15 PM

I think this is a makeshift solution, but you're on the right track that xEdit is looking in the wrong folder for the ini files. Normally all you really need to do is run the Skyrim or Skyrim SE launcher from Windows (do not do this from Mod Organizer) so the game creates the appropriate registry entries and the default ini files. Also ensure you have named xEdit.exe appropriately for the game you are using (TESVEdit.exe for Skyrim LE or SSEEdit.exe or Skyrim SE) so it knows which game you are using. I think for LOOT, you can add a -sse argument to tell it to use Skyrim SE.



#5 Seeker17281

Seeker17281

    Prisoner

  • Members
  • 10 posts

Posted 26 January 2019 - 02:42 AM

Hi Greg;

 

Thanks for the added suggestion for LOOT, I haven't seen anything yet to point that out, I'll be sure to make use of that.  I agree it's a temporary solution, so I'll be keeping an eye on xedit's development and see if anything pops up there.  For the time being I'm going to try to become more familiar with MO2's use and build a test run for a skyrim build for SSE, been a couple of years since I stomped through the snows of Skyrim.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users