Jump to content


Photo

DynDOLOD Beta for Skyrim Special Edition and Skyrim VR 2.74

dyndolod lod special edition sse

  • Please log in to reply
1766 replies to this topic

#1756 Oliver

Oliver

    Prisoner

  • Members
  • 33 posts

Posted 11 November 2019 - 01:21 AM

DynDOLOD\Docs\trees.ultra\DynDOLOD-Trees.html explains 3D tree LOD for LOD level 4 and billboards for the higher LOD levels.

 

LOD always starts beyond the loaded cells and this applies to near/far grid of dynamic LOD as explained in DynDOLOD_Manual.html.

The near/far grid are just identifiers how far away models show beyond the loaded cells.

 

For several reasons it makes no sense doing trees as dynamic LOD. One is the large amount of trees and another is the the limited distance.

I use hibryd 3D trees LODs, high rules (tree Static LOD4 | Billboard | Billboard), but I see always 3D LODs. 

3D trees LODs is feature with more hit to perfomance, I use EVT, 3D trees LODs hit down my FPS from 100 to 70. I think 3D tree LODs only for 0 level LOD will be better.

 

P.S. I'm sorry if I don't understand something, but english is foreign language for me.


  • 0

#1757 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,778 posts

Posted 11 November 2019 - 05:44 AM

I use hibryd 3D trees LODs, high rules (tree Static LOD4 | Billboard | Billboard), but I see always 3D LODs. 

3D trees LODs is feature with more hit to perfomance, I use EVT, 3D trees LODs hit down my FPS from 100 to 70. I think 3D tree LODs only for 0 level LOD will be better.

 

P.S. I'm sorry if I don't understand something, but english is foreign language for me.

If the setting is Static LOD4 for LOD level 4, Billboard for LOD level 8 and 16, then only the nearest LOD level will have 3D tree LOD and the two further levels use the simplified billboards.

The log tells you which LOD level uses what.


  • 1

#1758 Oliver

Oliver

    Prisoner

  • Members
  • 33 posts

Posted 11 November 2019 - 04:02 PM

DynDoLOD use textures from \Data\textures\DynDOLOD\lod\DynDOLOD_%WorldName%l.dds for hybrid 3D trees crowns, and billboards wich generated by DynDoLOD. But LOD Brightness not take affect to this. How I can tune this brigntness.

 

I manualy colored this texture atlas for visibility

YeJHaveOu0s.jpg

iicZno4MOPY.jpg


Edited by Oliver, 11 November 2019 - 04:03 PM.

  • 0

#1759 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,778 posts

Posted 11 November 2019 - 04:56 PM

DynDoLOD use textures from \Data\textures\DynDOLOD\lod\DynDOLOD_%WorldName%l.dds for hybrid 3D trees crowns, and billboards wich generated by DynDoLOD. But LOD Brightness not take affect to this. How I can tune this brigntness.

 

I manualy colored this texture atlas for visibility

 

 

https://forum.step-p...584#entry237584

https://forum.step-p...587#entry237587


  • 0

#1760 Oliver

Oliver

    Prisoner

  • Members
  • 33 posts

Posted 11 November 2019 - 10:35 PM

https://forum.step-p...584#entry237584
https://forum.step-p...587#entry237587

But tree LODs use your texture file. I can correct brightness for example DynDoLOD_Tamriel.dds in graphic editor after generation. Why I can't correct it in DynDoLOD before generation?

Edited by Oliver, 11 November 2019 - 10:36 PM.

  • 0

#1761 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,778 posts

Posted 12 November 2019 - 04:27 AM

But tree LODs use your texture file. I can correct brightness for example DynDoLOD_Tamriel.dds in graphic editor after generation. Why I can't correct it in DynDoLOD before generation?

Atlas textures are generated from the single textures defined in the LOD models.


  • 0

#1762 Oliver

Oliver

    Prisoner

  • Members
  • 33 posts

Posted 12 November 2019 - 10:20 AM

Atlas textures are generated from the single textures defined in the LOD models.

Will be fine if you release correcting atlas brightness feature.


  • 0

#1763 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,778 posts

Posted 12 November 2019 - 02:33 PM

Will be fine if you release correcting atlas brightness feature.

As already explained, there is no need to change brightness of object LOD textures which are used by LOD models that have normals, bi/tangents and normal map textures as they react properly to light and do not change wrongly/drastically based on weather/ENB settings like tree LOD billboards that do not have any of that.

 

As already explained, there is no distinction of shapes/textures in the LOD models to specifically target. Everything that is red in the screenshot and not a billboard would be equally affected by any such changes.

 

As already explained, if you want LOD models to use different textures, then you need to change the single LOD textures beforehand or modify the LOD models.


Edited by sheson, 12 November 2019 - 02:36 PM.

  • 1

#1764 Martimius

Martimius

    Prisoner

  • Members
  • 49 posts

Posted 03 December 2019 - 08:49 PM

Hey sheson, I've read the FAQ about ILS's and you recommended to use OSA Allocators and some ENBoost tweak for original Skyrim users. I know you said generally SSE users don't experience it, but I have been recently, and at least from the FAQ there wasn't any clear solutions to ILS's on SSE

 

It's a bit of a stretch still to see DynDOLOD as the culprit, but I'd like to ask for advice in tackling this issue in general. I suspect the issue probably has something to do with exterior worldspaces and perhaps LOD in general to some extent, as the ILSs don't occur in interior cells. 

 

I have updated from a previous DynDOLOD version on my current save (2.73-2.74) without any issues at first sight. I followed the instructions carefully and checked the logs for noticeable errors, to which I found none.


  • 0

#1765 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,778 posts

Posted 04 December 2019 - 03:20 AM

Hey sheson, I've read the FAQ about ILS's and you recommended to use OSA Allocators and some ENBoost tweak for original Skyrim users. I know you said generally SSE users don't experience it, but I have been recently, and at least from the FAQ there wasn't any clear solutions to ILS's on SSE

 

It's a bit of a stretch still to see DynDOLOD as the culprit, but I'd like to ask for advice in tackling this issue in general. I suspect the issue probably has something to do with exterior worldspaces and perhaps LOD in general to some extent, as the ILSs don't occur in interior cells. 

 

I have updated from a previous DynDOLOD version on my current save (2.73-2.74) without any issues at first sight. I followed the instructions carefully and checked the logs for noticeable errors, to which I found none.

I have no advice for ILS with SSE. There are no memory issues that stop the engine from loading AFAIK. I suggest to do the usual troubleshooting through elimination.


  • 0

#1766 Martimius

Martimius

    Prisoner

  • Members
  • 49 posts

Posted 04 December 2019 - 07:13 AM

Thanks for the reply.

 

The usual thing where I check every single plugin I got installed? That'll be a pain. The thing is, it'll be hard to troubleshoot since this ILS thing doesn't occur all the time, usually after a couple minutes or so into a play session or after some cell transitions. 

 

I tried testing on a test save and so far I haven't had any issues though. Seems to point towards save corruption but I don't know how that could be the case with no uninstalled mods. 


  • 0

#1767 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,778 posts

Posted 04 December 2019 - 02:47 PM

Thanks for the reply.

 

The usual thing where I check every single plugin I got installed? That'll be a pain. The thing is, it'll be hard to troubleshoot since this ILS thing doesn't occur all the time, usually after a couple minutes or so into a play session or after some cell transitions. 

 

I tried testing on a test save and so far I haven't had any issues though. Seems to point towards save corruption but I don't know how that could be the case with no uninstalled mods. 

The LOD mod generated by DynDOLOD is a very simple mod. It contains meshes and textures and very basic base records and references in the plugins. When needed it copies the winning overwrite records from other plugins in the load order. In Skyrim ILS is caused by the vanilla memory allocation when the game requires more memory. It's happens normally simply because of using mods mods or high INI settings. There is no such problem anymore in Skyrim Special Edition, though Engine Fixes still offers the alternative allocator but also much more important fixes.

 

Removing all or parts of the LOD mod is the quickest and more or less only way to determine any connection or cause to DynDOLOD. If there is no connection, then I can not really help with the troubleshooting.

 

Just because an existing save shows a different behavior than a new save does not mean it is "corrupted". Just like with ILS in Skyrim, it can mean a certain condition was reached that causes a deadlock in the engine.


  • 0



Also tagged with one or more of these keywords: dyndolod, lod, special edition, sse

4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users