Jump to content


Photo

DynDOLOD Beta for Skyrim Special Edition and Skyrim VR 2.84

dyndolod lod special edition sse

  • Please log in to reply
2056 replies to this topic

#1771 diskdevl

diskdevl

    Watcher

  • Citizen
  • 5 posts

Posted 18 December 2019 - 10:10 PM

Question about DynDOLOD v2.7.5.

 

The DynDOLOD_SSE.ini file now contains the section:

"

; !!! NO NEED TO COMMENT OUT ANYTHING FOR OPEN CITIES !!!
;
; Parent world name
[Skyrim Tamriel]

IgnoreIfPluginExists=OpenCities, Open Cities
"

But if you go along with that, I'm back to getting a pop-up when attempting generation:

"Found Open Cities Skyrim.esp. Do not load this mod when generating LOD. Restart and uncheck from Master/Plugin list."

 

So which is it ? =) Is there a step I'm missing somewhere that's new since v2.7.3 (the last time I ran this stuff) ?


  • 0

#1772 diskdevl

diskdevl

    Watcher

  • Citizen
  • 5 posts

Posted 18 December 2019 - 10:55 PM

Question about DynDOLOD v2.7.5.

 

The DynDOLOD_SSE.ini file now contains the section:

"

; !!! NO NEED TO COMMENT OUT ANYTHING FOR OPEN CITIES !!!
;
; Parent world name
[Skyrim Tamriel]

IgnoreIfPluginExists=OpenCities, Open Cities
"

But if you go along with that, I'm back to getting a pop-up when attempting generation:

"Found Open Cities Skyrim.esp. Do not load this mod when generating LOD. Restart and uncheck from Master/Plugin list."

 

So which is it ? =) Is there a step I'm missing somewhere that's new since v2.7.3 (the last time I ran this stuff) ?

Sorry for the reply to myself, I couldn't figure out how to edit the post.

 

Specifically, I was attempting the second step of generation with Open Cities per the docs :

"Now start DynDOLOD.exe with all mods and Open Cities Skyrim in the load order and start DynDOLOD.exe and click to the advanced options. Uncheck 'Generate static LOD', 'Create Atlas' and 'Generate tree LOD'. Check 'Generate DynDOLOD' and start the process."

 

It was a few seconds into the generation of the DynDOLOD skse/plugins that it gave me the error. Any help or pointers in the right direction would be appreciated.


  • 0

#1773 diskdevl

diskdevl

    Watcher

  • Citizen
  • 5 posts

Posted 18 December 2019 - 11:07 PM

Sorry for the reply to myself, I couldn't figure out how to edit the post.

 

Specifically, I was attempting the second step of generation with Open Cities per the docs :

"Now start DynDOLOD.exe with all mods and Open Cities Skyrim in the load order and start DynDOLOD.exe and click to the advanced options. Uncheck 'Generate static LOD', 'Create Atlas' and 'Generate tree LOD'. Check 'Generate DynDOLOD' and start the process."

 

It was a few seconds into the generation of the DynDOLOD skse/plugins that it gave me the error. Any help or pointers in the right direction would be appreciated.

Yay, another reply to myself ! =)

 

Looks like the "don't comment stuff out" comment doesn't mean you can skip the WarnModFileName line yet. Ah well. nm.


  • 0

#1774 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,430 posts

Posted 19 December 2019 - 05:53 AM

I'd barely call this a bug, but if you hit the close button right as Dyndolod starts to open it will crash with an access violation.
bugreport log: https://pastebin.com/uRjJTHk0
 
 
Other than that it's been working perfectly.


Do that with latest xEdit, report it, then maybe it gets fixed if important enough.
  • 0

#1775 Samphaa7

Samphaa7

    Citizen

  • Citizen
  • 20 posts

Posted 02 January 2020 - 04:53 PM

Hi Sheson,

 

I can appreciate this isn't a problem with Dyndolod per se, just after a bit of advice. I'm using the Skyrim LE version of EVT in SSE, along with ELOS Standalone Oaks and RAT. If I set TreeLOD=0 and TreeFullFallBack=0 all of my pine trees from EVT and the oaks from ELOS are full model at LOD4, this eventually leads to ILS after half hour or so of playtime. There is one model of Vurts snow trees included with EVT that is showing the correct 3D Hybrid LOD, RAT also has the 3D Hybrid LOD.

 

If I set TreeFullFallBack=1, all of my LOD4 pines now become 2D Billboards, apart from the 1 Vurt tree that stays as a Hybrid. RAT also stays as Hybrids, and the ELOS is still full model.

 

I suppose my question is, why are the Pine trees from EVT displaying as full model and not 3D Hybrids? I was under the impression that 3D Hybrid trees are included with EVT, and the SSE EVT version is botched in some way. Whats your suggestion? Thanks in advance.


  • 0

#1776 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,430 posts

Posted 02 January 2020 - 05:01 PM

Hi Sheson,

 

I can appreciate this isn't a problem with Dyndolod per se, just after a bit of advice. I'm using the Skyrim LE version of EVT in SSE, along with ELOS Standalone Oaks and RAT. If I set TreeLOD=0 and TreeFullFallBack=0 all of my pine trees from EVT and the oaks from ELOS are full model at LOD4, this eventually leads to ILS after half hour or so of playtime. There is one model of Vurts snow trees included with EVT that is showing the correct 3D Hybrid LOD, RAT also has the 3D Hybrid LOD.

 

If I set TreeFullFallBack=1, all of my LOD4 pines now become 2D Billboards, apart from the 1 Vurt tree that stays as a Hybrid. RAT also stays as Hybrids, and the ELOS is still full model.

 

I suppose my question is, why are the Pine trees from EVT displaying as full model and not 3D Hybrids? I was under the impression that 3D Hybrid trees are included with EVT, and the SSE EVT version is botched in some way. Whats your suggestion? Thanks in advance.

 

If LOD4 is set to static LOD, then TreeFullFallBack with only fall back to full model if no 3D LOD model is found. The log will tell you for which tree a 3D LOD model, billboard or full model is used. You did not post any logs.


  • 0

#1777 Samphaa7

Samphaa7

    Citizen

  • Citizen
  • 20 posts

Posted 02 January 2020 - 05:47 PM

Sorry, didn't expect you to reply so fast.

 

Here is part of the log, the file is too large to paste the entire thing. It appears some of the trees from EVT have 3D LOD and some don't, I'm just not sure why, I thought EVT included 3D LOD for all models of trees that come with it.

 

https://pastebin.com/7eLC780S


  • 0

#1778 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,430 posts

Posted 03 January 2020 - 06:06 AM

Sorry, didn't expect you to reply so fast.

 

Here is part of the log, the file is too large to paste the entire thing. It appears some of the trees from EVT have 3D LOD and some don't, I'm just not sure why, I thought EVT included 3D LOD for all models of trees that come with it.

 

https://pastebin.com/7eLC780S

OK, so indeed the log already shows and answers your question why some trees do not have 3D LOD models.

 

If a 3D LOD model is not found the billboard or full model is used as fallback depending on the fallback setting.

 

The log shows the expected file name for the 3D LOD model 3D LOD not found <srg_treepineforest02_5C16FEAC> fallback Billboard

 

You need to install or create the 3D LOD model.

If you use the Skyrim version of EVT in Skyrim Special Edition, do not convert/change the full models, only the ESP. Make sure to install files from the billboard generator with the exact same options.


  • 0

#1779 Samphaa7

Samphaa7

    Citizen

  • Citizen
  • 20 posts

Posted 03 January 2020 - 06:46 AM

OK, so indeed the log already shows and answers your question why some trees do not have 3D LOD models.
 
If a 3D LOD model is not found the billboard or full model is used as fallback depending on the fallback setting.
 
The log shows the expected file name for the 3D LOD model 3D LOD not found <srg_treepineforest02_5C16FEAC> fallback Billboard
 
You need to install or create the 3D LOD model.
If you use the Skyrim version of EVT in Skyrim Special Edition, do not convert/change the full models, only the ESP. Make sure to install files from the billboard generator with the exact same options.


I'll have another go when I get home from work. I'm pretty sure when I installed the mods I selected Lush trees in the Main installer and normal trees in the billboards, as the normal billboards seemed to match up better when using just 2D instead of 3D, this may be where the problem lies.

I am indeed using the LE version of EVT in SE. Can I get away with simply saving the mod in the CK to convert it to Form 44, or should I Copy the models from LE EVT into the SE folder and then install?

Thanks again for the help
  • 0

#1780 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,430 posts

Posted 03 January 2020 - 09:05 AM

I'll have another go when I get home from work. I'm pretty sure when I installed the mods I selected Lush trees in the Main installer and normal trees in the billboards, as the normal billboards seemed to match up better when using just 2D instead of 3D, this may be where the problem lies.

I am indeed using the LE version of EVT in SE. Can I get away with simply saving the mod in the CK to convert it to Form 44, or should I Copy the models from LE EVT into the SE folder and then install?

Thanks again for the help

Install the mod as usual. Only convert the esp in CK64. Do not modify any of the NIFs.


  • 0

#1781 Samphaa7

Samphaa7

    Citizen

  • Citizen
  • 20 posts

Posted 04 January 2020 - 08:27 AM

Install the mod as usual. Only convert the esp in CK64. Do not modify any of the NIFs.

It must have been a problem with my download. I reinstalled the mods selecting the same options in both and it didn't correct itself. Tried normal trees instead of the lush option, same again. Re-downloaded both files, installed as usual, ran texgen and dyndolod again and everything works perfect now, the trunks are all 2D instead of full model. 


  • 0

#1782 Indanger

Indanger

    Watcher

  • Citizen
  • 8 posts

Posted 08 January 2020 - 02:22 PM

Hey, I have a small problem regarding some ugly bushes/shrubs in the distance:

https://puu.sh/EXJie/ecb6720370.jpg

 

I was generating 3d tree LODs with Enhanced Landscapes + EVT and everything worked just fine except those plants circled in red.

 

While approaching them they completely change form and color. So I checked what those plants are:

https://puu.sh/EXJka/e62c6750bc.jpg - these are the ones that appear yellow in the distance

https://puu.sh/EXJjQ/47fc4299ec.jpg - these are the dark red ones from the first link

 

Afterwards I took at the look at my DynDOLOD logs:

https://puu.sh/EXJq4/797e6103fa.png

https://puu.sh/EXJqu/f5eb70849d.png

 

I have Billboards for those installed:

https://puu.sh/EXJs8/893bc9c3f2.png

 

so my question is: what can I do to fix it? Are my current Billboards just corrupted/broken/etc.? Even though the plants look completely different than their LODs, I do not have a mod installed that changes their meshes (so the issue cannot be missing Billboards from mod x/y that changed their appearence, right?).

 

Thanks in advance. It feels like my problem is simple but I fail to see the connections and cannot come up with a solution myself.


Edited by Indanger, 08 January 2020 - 02:23 PM.

  • 0

#1783 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,430 posts

Posted 08 January 2020 - 02:42 PM

Hey, I have a small problem regarding some ugly bushes/shrubs in the distance:

https://puu.sh/EXJie/ecb6720370.jpg

 

I was generating 3d tree LODs with Enhanced Landscapes + EVT and everything worked just fine except those plants circled in red.

 

While approaching them they completely change form and color. So I checked what those plants are:

https://puu.sh/EXJka/e62c6750bc.jpg - these are the ones that appear yellow in the distance

https://puu.sh/EXJjQ/47fc4299ec.jpg - these are the dark red ones from the first link

 

Afterwards I took at the look at my DynDOLOD logs:

https://puu.sh/EXJq4/797e6103fa.png

https://puu.sh/EXJqu/f5eb70849d.png

 

I have Billboards for those installed:

https://puu.sh/EXJs8/893bc9c3f2.png

 

so my question is: what can I do to fix it? Are my current Billboards just corrupted/broken/etc.? Even though the plants look completely different than their LODs, I do not have a mod installed that changes their meshes (so the issue cannot be missing Billboards from mod x/y that changed their appearence, right?).

 

Thanks in advance. It feels like my problem is simple but I fail to see the connections and cannot come up with a solution myself.

 

 

FAQ: Game: Tree LOD: LOD trees do not match close-up full model trees 
 
A: Find better matching billboards for the tree mods or create them. See this video
 
 
Honestly? Just remove the billboards and have no LOD for small bushes and shrubs. Best for performance.
Or you could try making optmized 3D LOD models for them.

Edited by sheson, 08 January 2020 - 02:43 PM.

  • 0

#1784 Indanger

Indanger

    Watcher

  • Citizen
  • 8 posts

Posted 08 January 2020 - 02:49 PM

 

FAQ: Game: Tree LOD: LOD trees do not match close-up full model trees 
 
A: Find better matching billboards for the tree mods or create them. See this video
 
 
Honestly? Just remove the billboards and have no LOD for small bushes and shrubs. Best for performance.
Or you could try making optmized 3D LOD models for them.

 

Wow, thanks for the fast response.

 

I did not expect that those shrubs count as "trees" ...

So my problems are just mismatches between actual models and their billboards, got it. Cheers!


  • 0

#1785 DarthVitrial

DarthVitrial

    Thane

  • Citizen
  • 76 posts

Posted 09 January 2020 - 10:21 PM

I'm not sure what I changed, but I just started getting this error:

[00:00:02.015]    Scanning 169 rules for reference FormIDs for selected worlds
[00:00:02.063]      Found reference 0A06312F  using base element 00018A02 TreePineForest02
[00:00:02.110]    
[00:00:02.110]    Exception in unit prepare line 581: Can not copy [REFR:0A06312F] (places TreePineForest02 [TREE:00018A02] in GRUP Cell Persistent Children of [CELL:00037EE6] (in SolitudeWorld "Solitude" [WRLD:00037EDF]) at -18,25) from Unofficial Skyrim Special Edition Patch.esp into DynDOLOD.esp Assertion failure (C:\Delphi\projects\DynDOLOD\wbImplementation.pas, line 14062)
[00:00:02.110]    
[00:00:02.110]    Check log lines above the exception for additional hints. Check the FAQ and search official forum http://forum.step-pr...ndolod-support/ for those errors.
[00:00:02.110]    
[00:00:02.110]    If problem persists, post error report with entire contents (not just the last couple lines) of ..\DynDOLOD\bugreport.txt and ..\DynDOLOD\logs\DynDOLOD_SSE_log.txt to official forum http://forum.step-pr...ndolod-support/
[00:00:02.112]    Error: Can not copy [REFR:0A06312F] (places TreePineForest02 [TREE:00018A02] in GRUP Cell Persistent Children of [CELL:00037EE6] (in SolitudeWorld "Solitude" [WRLD:00037EDF]) at -18,25) from Unofficial Skyrim Special Edition Patch.esp into DynDOLOD.esp Assertion failure (C:\Delphi\projects\DynDOLOD\wbImplementation.pas, line 14062)
 

 

Here's my bugreport.txt: https://pastebin.com/4xt7MGK1


  • 0



Also tagged with one or more of these keywords: dyndolod, lod, special edition, sse

15 user(s) are reading this topic

0 members, 15 guests, 0 anonymous users