Jump to content


Photo

Smashed patch repeatedly missing masters


  • Please log in to reply
2 replies to this topic

#1 Seeker17281

Seeker17281

    Prisoner

  • Members
  • 10 posts

Posted 14 February 2019 - 09:41 PM

I'm running into a strange issue that I'm sure is user error, but sadly I can't figure out where I'm going wrong.

 

I created a smashed patch for a profile that had great success, game was stable and only had a very rare CTD which a tweak to load order seems to have solved entirely.  Played for about 15 hours of content before deciding to add in a few more mods.  I usually only add in 5 or less new mods at a time to keep troubleshooting simple.  

 

In MO2 I had everything on the left checked prior to activating Matorsmash which included all the old mods along with the new ones I wanted to test out from within MO2.

 

Upon loading, Mator shows me my mod list, of which several are deactivated by default, based on what I've seen in tuts I activate all of them, then go through and manually deactivate the following:

  • FNIS
  • FNIS Spells
  • Dual Sheath Redux Patch
  • Dual SHeath Redux
  • Bashed Patch

After confirming my selection, in the next section I highlight everything, starting with Skyrim's esm based on reading a most recent reddit post that suggested I choose everything and then hit the green button, using the resulting patch.  I like to name my patches as per GP's videos so that I can keep track of when I'm testing a new mod collection.

 

I.E. I have smash-charactername-v1,v2, ect.  

 

On my first time adding a few new mods I went through the above process, tossed out the old smash-patch and replaced it with the new one containing the new mods and things were fine, no flags in MO2's Plugin panel.  Pretty much it was a choose all, unselect the above 5 mods, hit green button.  Now however I'm repeatedly getting a error message I can't seem to sort out why it's happening.

 

I've attempted this several times now, being careful with my choices, double checking as I go, yet each and every time the resulting smashpatch when it's activated as a mod and put into the plugin panel in MO2, gives me a caution flag that says masters are missing.  These are the same masters that when I started to build the patch initially, were deactivated by default and I had specifically manually activated.  When i check within the Mator utility to see specifically if those masters are present it says they are.  But wheni check the mod containing the smashpatch in MO2 I get the message that masters are missing. :confusion:

 

Then I thought ok fine, maybe these are deselected to avoid problems, and by choosing them I'm causing some reality breach that is preventing those masters from being included, so this time I don't choose the ones that load up deactivated, include the 5 mods mentioned above as deactive, hit build and the result is the same, MO2 says the patch is missing masters.  :crying:

 

In case this matters, currently there are two seperate "smash mods" in my mod folder, these are the 

 

  • Smashpatch 1 (the patch that doesn't have the new mods with it's smashing and is stable) and it is not checked.
  • Smashpatch 2 (the patch that does have the new mods added in being tested) and it is checked with files from the overwrite.

If I check Smashpatch 2, it has the exclamation flag, if I check both smashpatch 1 is fine, but smashpatch 2 shows the same flag.  I have run the game and tested the handful of new mods and everything works as it should, but that flag in MO2 keeps reminding me something's wrong.  I've run the game with just smashpatch 1, just smashpatch 2, and with smashpatch 1 & 2 at the same time, I am embarrased to say i see no difference.  All the mods are functional, but knowing how arcane Skyrim can be with save game corruption and whatnot, I've decided to come here and get myself straightened out by more knowledgeable folks than me.  Your time and help will be greatly appreciated, TIA.

 

 


  • 0

#2 Mator

Mator

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 625 posts

Posted 15 February 2019 - 12:16 AM

It sounds to me like your issue has almost nothing to do with Smash, and everything to do with how you're managing your load order.

Understand the following:
- Every plugin you load into Mator Smash will be a master of the smashed patch.

- If MO2 reports masters missing it means a plugin is not installed.

- It is not possible for the smashed patch to have a plugin as a master which is NOT loaded at the time the patch is built.

- It is not possible for the smashed patch to have a plugin as a master that ISN'T installed

 

The key detail here is that you have two smashed patches in MO2.  You can't do that if you're using the green quick patch button, as smash will just replace the existing plugin file in your MO2 mods folder.  Delete or backup your smashed patches (so they are no longer in your MO2 mods folder OR are named differently) and make a fresh one.  Your problem should disappear.


  • 0

#3 Seeker17281

Seeker17281

    Prisoner

  • Members
  • 10 posts

Posted 16 February 2019 - 04:05 PM

Hi Mator, thanks for the support and the great work you do on your tools.

 

I spent yesterday acting on your reply, your itemized points led me to a aha moment that in hindsight, I had no idea it was staring me right in the face.  Those masters were missing because they had been deactivated when I built a bashed patch and I completely overlooked checking them before running the smash utility.  

 

I also yanked out the other smashed patches and put them in a new folder to hold backup files, though I'm pretty sure that can be done away with in the future as I get better at adding/subtracting files from the patch.  Right now I prefer to have a backup in case I do something stupid or hasty.

 

As a side note, I ran most of yesterday with this new rebuilt smash patch and did not use a bashed patch at all, I didn't have a single CTD or hangup in a full 9 hour play session testing the patch and the new mods.  All the mods and the game performed as expected with leveled items and whatnot, never had a session run so well.  Next up is to tackle merging mods but from what I understand, I have to make my MO2 a portable install and since I'm only 89 mods I think I still got some time to figure that out.  

 

Again, thanks for the reply and all you do for us  :thumbsup:


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users