Jump to content


Photo

d3d9.dll instant CTD (Skyrim LE ENB v0.377)

d3d9.dll

  • Please log in to reply
4 replies to this topic

#1 Vaneglorious

Vaneglorious

    Citizen

  • Citizen
  • 13 posts

Posted 21 June 2019 - 01:23 PM

Hello.

 

I've a problem with the ENB in Skyrim LE - d3d9.dll causes instant ctd upon opening launcher, and (0xc000001d) error code upon launching the exe or skse_loader.

 

I've had this problem before, and installing older direct X libraries solved it before, but not this time. I've been googling for hours now, nothing seems to work. At one point I used to injector version, and that worked after a lot of trial and error, and then it just didn't after relaunching the game, and I didn't change anything. Tried admin rights, compatibility modes, all that stuff. Nothing worked.

 

This was all after reinstalling Windows 10 Pro and restoring a backup of Skyrim + mods (Mod Organizer), which has worked before, but not this time.

 

Any ideas would be appreciated.


Edited by Vaneglorious, 21 June 2019 - 01:25 PM.

  • 0

#2 Greg

Greg

    High King

  • Uber Moderator
  • PipPipPipPipPipPip
  • 2,217 posts

Posted 21 June 2019 - 06:49 PM

If you installed Windows 10 fresh, you need to install the June 2010 DirectX 9 runtime using the link in the "Install" section of the ENBoost guide:

https://wiki.step-project.com/ENBoost

 

You can also find some instructions for installing DirectX in the LOTD guide:

https://wiki.step-pr...n_Prerequisites

 

Check the properties of TESV.exe, SkyrimLauncher.exe and skse_loader.exe (File Explorer, select the file, right click, Properties) and disable Compatibility mode if it is enabled. Enabling compatibility mode for any of these three executables is known to cause a CTD with this error code so you need to ensure compatibility mode is disabled for all of them.



#3 Vaneglorious

Vaneglorious

    Citizen

  • Citizen
  • 13 posts

Posted 21 June 2019 - 07:19 PM

If you installed Windows 10 fresh, you need to install the June 2010 DirectX 9 runtime using the link in the "Install" section of the ENBoost guide:

https://wiki.step-project.com/ENBoost

 

You can also find some instructions for installing DirectX in the LOTD guide:

https://wiki.step-pr...n_Prerequisites

 

Check the properties of TESV.exe, SkyrimLauncher.exe and skse_loader.exe (File Explorer, select the file, right click, Properties) and disable Compatibility mode if it is enabled. Enabling compatibility mode for any of these three executables is known to cause a CTD with this error code so you need to ensure compatibility mode is disabled for all of them.

I did mention in my original post that I've already done all of that. It worked the last time, but not this time, and I've no idea why. Installed the DX9 runtime twice, rebooted, tried launcher, tesv and skse_loader exes with and without compatibility modes.


  • 0

#4 Vaneglorious

Vaneglorious

    Citizen

  • Citizen
  • 13 posts

Posted 23 June 2019 - 03:21 AM

Bump.


  • 0

#5 lubu15

lubu15

    Watcher

  • Watcher
  • 1 posts

Posted 21 August 2020 - 01:17 AM

Hey everyone, 

So with regards to this issue, I was experiencing it myself and nothing was working. 

 

I noticed somehow, that my computer wasn't picking up my AMD graphics card (at least for my monitor) 

 

Long story short ladies and gents, two days ago I changed out my HDMI to HDMI cable to a  VGA/HDMI 

 

when I did this, my computer treated it as if i was adding an ADDITIONAL monitor as opposed to just changing the cord and assigned this 'additional monitor' to my default intel graphics card 

 

As soon as i changed back to my previous cord (hdmi to hdmi) i was able to run skyrim again with the d3d9.dll file no problem 

 

so if you have changed the cords you are using to connect your monitors recently, change them back to what they were before. If your system allocates the monitor you are trying to play skyrim on to your systems default graphics card (in my case it was the Intel R core 4590) then skyrim will not be able to even get to the logo before crashing. 

 

You need to make sure that your monitor is registering your gaming graphics card. to do that check out this video https://www.youtube....h?v=FHCYoVB8P_Y at around 9:58 in

 

Someone far more tech savvy than I am may be able to fill you in on how to allocate your existing monitor to your gaming specific graphics card as opposed to whatever your system default is if this is the case 


  • 0



Also tagged with one or more of these keywords: d3d9.dll

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users