Jump to content


Photo

SKSE for SSE will not launch through MO2

mo2 skse crash

  • Please log in to reply
3 replies to this topic

#1 ValkyrieXRAY

ValkyrieXRAY

    Prisoner

  • Members
  • 2 posts

Posted 27 July 2019 - 09:05 PM

I recently reinstalled Skyrim Special Edition on my PC and decided to use MO2 after failing to use Vortex. Fell in love with how simple and easy it is, and I regret that I didn't use MO years ago or MO2 whenever it was released. I launched the game out of the SKSE 64 executable and realized that none of my plugins were loaded in so I did a quick google search and realized that I needed to launch SKSE out of MO2. When I tried, the game had a black screen for a second like it does right before it loads the intro screen, and then it just crashes. Back to MO2. I have tried tons of solutions online, but so far nothing has worked. I would really be thankful if someone could help me get this sorted out. Thanks.


Edited by ValkyrieXRAY, 27 July 2019 - 09:07 PM.

  • 0

#2 Greg

Greg

    Dragon Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,024 posts

Posted 28 July 2019 - 07:51 AM

There are a number of pitfalls that can prevent SKSE and the game from working correctly so I suggest using a vanilla profile with no mods installed to work through these:

 

Do not install Skyrim or Mod Organizer into C:\Program Files, C:\Program Files (x86) or any other UAC protected folder. Note that Windows 10 adds extra layers of protection on these folders that may prevent Mod Organizer's virtual file system from working.

 

Do not install Mod Organizer into the Steam or Skyrim folder because the virtual file system will not work correctly.

 

Using File Explorer, right click on ModOrganizer.exe and click Properties. If you see an Unblock button or checkbox, you need to click Unblock and click OK. If you are on Windows 10, you may need to repeat this for every DLL in the Mod Organizer folder and its subfolders. The recommended solution is to download Mod Organizer from Nexus, immediately unblock the file you downloaded, and then install or extract the files to the appropriate folder.

 

Run SkyrimSE.exe from Mod Organizer to verify you can run the base game without any issues.

 

Ensure you are using SKSE 2.0.16 and Skyrim SE 1.5.80. You can find the version number by right clicking SkyrimSE.exe, go to the details tab, and look at Product Version. If this is not 1.5.80, you'll need to run Steam and let it update Skyrim SE to the latest version.

 

In your vanilla profile (without any other mods installed and with a clean Data folder), install the SKSE scripts and try to run skse_loader.exe from Mod Organizer. You can do this my clicking install mod and select SKSE in the folder you downloaded it to. If you see a red "No game data", right click on the Data folder and click Set data folder.

 

 

When you install SKSE, you should copy only skse64_1_5_80.dll, skse64_loader.exe and skse64_steam_loader.dll to the Skyrim Special Edition folder (the folder containing SkyrimSE.exe). All of the scripts should be installed as a mod in Mod Organizer using the steps above.



#3 ValkyrieXRAY

ValkyrieXRAY

    Prisoner

  • Members
  • 2 posts

Posted 28 July 2019 - 09:52 AM

Thanks Greg. After disabling all my mods and installing the SKSE scripts through MO, SKSE will now run out of MO. Now I just got to fix my load order


  • 0

#4 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 28 July 2019 - 01:11 PM

Thanks Greg. After disabling all my mods and installing the SKSE scripts through MO, SKSE will now run out of MO. Now I just got to fix my load order

Also something to keep an eye out for are mods that aren't updated to the latest SKSE version. These mods can cause the game to not launch, so if you're having an issue with the game not launching with mods active this is one thing to check. Most authors are pretty good about updating their mods for new SKSE releases, though.





Also tagged with one or more of these keywords: mo2, skse, crash

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users