Jump to content


Photo

CTDs when going to new lands

ctd

  • Please log in to reply
1 reply to this topic

#1 OregonPete

OregonPete

    Prisoner

  • Members
  • 8 posts

Posted 01 September 2019 - 01:28 PM

Hi Sheson

 

I'm having a very strange problem. Until recently, everything was running just fine, but in the past month or so I've had this issue that I can't get into any new lands using DynDOLOD without causing a CTD. This means mods such as going to Kirkmore in the "Haafstad and Border to High Rock" mod, Wyrmstooth, Falskaar, and Beyond Reach. Interestingly, I can get to Solstheim, but I haven't tried the Dawnguard "Falmer Valley" since I'm not that far along in the quests yet. If, for whatever reason, I do make it to a new land (if even just briefly), the system CTDs shortly after, and if I attempt to load any saves created in that land, the system CTDs immediately. 

 

I'm using MO2, and I also have Open Cities and therefore use the two-step process when running DynDOLOD. I also have a huge load order with more than 400 plugins and over 500 mods. I also use the Ultra Trees setup so I'm using TreeFullFallBack=0. I've tried all the steps you've posted, including all the advice you gave Alastor in the "ctd, ils and impossible to load game when i using DynDOLOD" thread. I also deactivated DynDOLOD and tried getting into the new lands. That works, so it seems the cause needs to be with DynDOLOD somehow (very possibly through an error on my end). 

 

What I've done so far is the following (without success, I'm afraid):

 

  • Upgraded from DynDOLOD SSE 2.59 to 2.69
  • Uninstalled BS Bruma, Haafstad (i.e Kirkmore), Nyhus, Falskaar, Gray Cowl of Nocturnal, Beyond Reach, and Mirai, leaving "only" Wyrmstooth, Clockwork, Temple of Black Rock, and Secret of Dragon Head for test purposes. So far, Clockwork seems to work fine (as does Solstheim), but Wyrmstooth CTDs, as did both Falskaar and Beyond Reach in the end. I haven't tried Black Rock or Dragon Head yet. It seems those mods don't really use DynDOLOD much, though.
  • Started a completely new game and reran TexGen and DynDOLOD
  • Ran the count_loaded_refs_in_load_order script but only had a little over 300k references, and this with DynDOLOD installed
  • Ran DynDOLOD with Temporary=1, and again with Temporary=0, just in case
  • Ran DynDOLOD with TreeFullFallBack=0 and with TreeFullFallBack=1 (looks pretty horrible with TFFB=1, btw)
  • Checked everything for missing NIFs
  • Checked for Errors with SSEEdit
  • Installed the Net Script Framework, but couldn't see anything in the crash dumps (then again, not really sure how to read those, either)

 

It's very possible I missed something obvious, and I'd be glad to post any logs or dumps if it will help. Any advice is greatly appreciated.

 

 


  • 0

#2 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,776 posts

Posted 01 September 2019 - 01:37 PM

FAQ: Game: ILS or CTD
 
A: More LOD uses more memory and this can cause infinite loading screen (ILS) or crash to desktop (CTD) if the game is not setup correctly. This should generally not be a problem with Skyrim Special Edition or Skyrim VR, but for Skyrim double check heap memory usage (block 1) with Memory Blocks Log from https://www.nexusmod...rim/mods/50471/ and adjust SKSE or SSME memory settings. Or use the alternative OSAllocator from crash fixes with pre-loader. Remove satefy-load if it is used. Setup ENBoost correctly. Set ExpandSystemMemoryX64=false in enblocal.ini. 
 
A: Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 
 
A: If heap memory is not the cause of CTD see ..DynDOLOD\Docs\DynDOLOD-README.txt for checking if a missing or invalid nif model used for dynamic LOD is the cause. 
 
A: Large load orders with many plugins might surpass the reference handle cap. SSE Engine fixes prints a warning. See https://www.reddit.c...gnosing_one_of/ Setting Temporary=1 in ..DynDOLOD\Edit Scripts\DynDOLOD\DynDOLOD_[GameMode].ini may help in these situations, however converting large new land plugins to ESM is the preferred solution. 
 
 
 
If you didn't see a NIF name in Crash Fixes crash log, then it's probably not a corrupt mesh. Even so, still enable debug in the json/txt and then check the papyrus log for which NIF dynamic LOD enabled last.
 
If that doesn't reveal anything, see if hiding the meshes folder from the DynDOLOD output changes anything. I suspect not, but you never know.
 
Then hide the SKSE folder, ignore the expected error messages about data not being found in the json/txt files, just test if it CTDs or not.
 
If it still CTDs, test if it still crashes with only the DynDOLOD.esm
 
Report back on these tests.

  • 0



Also tagged with one or more of these keywords: ctd

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users