Jump to content


Photo

Can't Launch Creation Kit Through MO2


  • Please log in to reply
1 reply to this topic

#1 bweep

bweep

    Prisoner

  • Members
  • 1 posts

Posted 02 September 2019 - 03:45 AM

I've been troubleshooting this for two days now and I still cannot find the cause. Creation kit used to work fine, but at some point at the end of this week while I was installing mods for SSE, it decided it no longer wanted to cooperate. Whenever I try to run CK through MO2, it simply locks up for a bit before unlocking without any sort of error. During troubleshooting, I realized MO2 has the same issue with SSE and the SSE launcher. I

 

Things I've tried:

  • Reinstalling Skyrim SE twice, making sure the whole folder was wiped before reinstalling the second time. I've verified the integrity of the game files twice between these two times.
  • Reinstalling CK at least thrice, and even the bethnet launcher once (I made sure CK was installed in the SSE directory)
  • Reinstalling MO2 twice
  • Renaming MO2's SSE mod folder so the list would be not only entirely disabled but entirely empty. (SKSE is the only thing installed, and it's installed manually.). I'm willing to wipe the folder in its entirety if anyone thinks that might warrant a different result.
  • Restarting the computer
  • Making firewall and AV exceptions for MO2 and CK
  • Temporarily disabling firewall and AV entirely

Other details:

  • I am aware that installing in program files causes issues. I have steam installed in the D: drive in a self-made folder, but it is still titled D:\Program Files (x86). Could this possibly be insufficient?
  • Creation kit was not installed as a mod (not that I'd know how to install CK in particular as a mod) so it's not available in the left pane
  • SkyrimSELauncher.exe appears to be working at first but simply closes out with no follow-up or error when I hit play.
  • SKSE and xEdit run just fine. In-game SKSE w/o mods seems to run just fine.
  • Mod Organizer is not installed onto the steam or skyrim folders. It is in D:\Modding\MO2
  • The only thing I could think of that hasn't been affected by my troubleshooting was that there was a Windows 10 update between when CK last worked and now
  • SSE launches fine through Steam. CK runs just fine through the bethnet launcher and directly from the folder
  • SSE version 1.5.80, SKSE version 2.0.16, MO2 version, CK version 1.5.73 (but I've also used 1.5.3)
  • I don't see anything in the properties of the .dll files of MO2 indicating they're blocked, but I don't see anything indicating they aren't either.

I might be missing something, but I'll give an update if I recall any extra details. 


  • 0

#2 Greg

Greg

    Dragon Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,024 posts

Posted 02 September 2019 - 11:35 AM

Installing Steam and Skyrim in D:\Program Files (x86) should be fine provided you created the folder yourself. I've done pretty much the same thing on my system except I named it D:\Program Files. To be honest, I'm not see anything here that stands out as a possible issue other then the nagging Windows 10 update. I do remember some of the folks here ran into issues with Wrye Bash that required forcing an update to Windows 10 build 1809 or later, but I think this is an issue with Wrye Bash that's most likely unrelated to Creation Kit. (see https://forum.step-p...te#entry236549)

 

The only thing I can think of is to enable debug logging and to go through the log file to see if anything there stands out. To do this, delete everything in the Mod Organizer\Logs folder to start clean. Run Mod Organizer. Click Configure Settings and Workaround (the screwdriver/wrench icon a the top left), go into the Diagnostics tab and change Log Level to Debug. Click OK to close the dialog. Now run Creation Kit and wait for it to exit. Close Mod Organizer and upload mo_interface.log and usvfs-*.log to somewhere like PasteBin or a cloud drive and include a link to it here.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users