Jump to content


Photo

No matter what I do, I have horrible shadows in SSE!


  • Please log in to reply
4 replies to this topic

#1 lupus_hegemonia

lupus_hegemonia

    Thane

  • Citizen
  • 57 posts

Posted 26 November 2019 - 04:24 AM

Hello to you all.
You probably know me, I'm a textures mods' author - my site is www.lhmods.com

 

So, I'm keep dealing with Skyrim (SE) whatever new game arrives. I can't help it, this game (Skyrim) is my "drug".

I'm making new builds, testing (not actually playing), etc. Therefore, now, I made a new build (around 600 plugins, some merged, many esl - plus 400 meshes/textures mods)... No ENB, no ReShade, I'm just using the Imaginator mod and I'm very fine with the result, I don't care to use ENB/Reshades...

 

...I never had SUCH SERIOUS problem/issue with my shadows quality, like I do now. I have spend about a week (or more!) to solve this, but without luck. I followed every tutorial I found, everything I could dig out, but without luck. First, I simply deleted my ini files and re-created them via the launcher (by selecting the "Medium"). Then, I ran the BethINI tool and played with the settings. And after that, I made manually even more tweaks...

My goal, what I want to have, is this result:

 

https://prnt.sc/q12vgs

http://prntscr.com/q26lh0

http://prntscr.com/q26lzl

...But my result are these ULTRA HORRIBLE shadows, here:

 

https://prnt.sc/q1z0lh

https://prnt.sc/q1z0ss

 

VERY blury, VERY flickering (they're shaking like they are... alive!), they looks like they have 2-3 mirror images one on top the other... generally they SUPER SHUCKS! These are my ini settings in my SkyrimPref.ini:

[Display]
iSize H=1440
iSize W=2540
iMaxAnisotropy=0
iReflectionResolutionDivider=2
iBlurDeferredShadowMask=0
fInteriorShadowDistance=3000
fShadowDistance=8000
bTreesReceiveShadows=1
bDrawLandShadows=0
iShadowMapResolution=4096
fShadowBiasScale=1.0
iShadowMaskQuarter=4
bBorderless=1
bEnableImprovedSnow=0
bEnableProjecteUVDiffuseNormals=1
bFull Screen=0
bFXAAEnabled=1
bIBLFEnable=1
bIndEnable=0
bSAO_CS_Enable=0
bSAOEnable=1
bScreenSpaceReflectionEnabled=1
bToggleSparkles=0
bUse64bitsHDRRenderTarget=1
bUsePrecipitationOcclusion=1
bUseTAA=0
bVolumetricLightingEnable=0
fDynamicDOFBlurMultiplier=0.8
ffocusShadowMapDoubleEveryXUnit=450
fGamma=1.0000
fLeafAnimDampenDistEnd=4600
fLeafAnimDampenDistStart=3600
fLightLODStartFade=7000.0000
fMeshLODFadeBoundDefault=256
fMeshLODFadePercentDefault=1.2
fMeshLODLevel1FadeDist=10000000.0000
fMeshLODLevel1FadeTreeDistance=10000000.0000
fMeshLODLevel2FadeDist=10000000.0000
fMeshLODLevel2FadeTreeDistance=10000000.0000
fProjectedUVDiffuseNormalTilingScale=0.2
fProjectedUVNormalDetailTilingScale=0.8
fTreesMidLODSwitchDist=3584
iMaxDecalsPerFrame=400
iMaxSkinDecalsPerFrame=150
iNumFocusShadow=2
iSaveGameScreenShotHeight=192
iSaveGameScreenShotHeighWSt=192
iSaveGameScreenShotWidth=256
iSaveGameScreenShotWidthWS=320
iScreenShotIndex=0
iSize H=1440
iSize W=2560
iVolumetricLightingQuality=0
iVSyncPresentInterval=0

 

And these are my PC specs:

OS: Windows 8.1 64bit | CPU: Intel Core i7 7700K @ 4.20GHz | RAM: Corsair Vengeance 16,0GB DDR4 @ 3000MHz | MB: ATX MSI Z270 Gaming Pro | MONITOR: Dell U2515H 2560x1440 60Hz | GPU:Gigabyte nVIDIA GeForce GTX 1070 G1 8GB 1594 MHz | STORAGE: Crucial MX300 525GΒ SSD - Kingston SSDNow V300 120GB SSD - Seagate Barracuda 1TB SATA HDD - NAS Synology DS415+ - Hitachi DeskStar NAS 8TB | OPTICAL: Samsung SH-224FB | Watercooler: Hydro Series H60 | Soundcard: Xonar DX/XD | POWER: Corsair Builder Series CX750M 80Plus Bronze
 

Please... please... I need help, here.

I tried everything. Even these remarkable STEP ini tweaks. NO LUCK, my shadows are still HORRIBLE!


  • 0

#2 lupus_hegemonia

lupus_hegemonia

    Thane

  • Citizen
  • 57 posts

Posted 26 November 2019 - 02:18 PM

"Zig-zag" line, not straight line:

 

http://prntscr.com/q2gih1

 

"Zebra"-stripe shadows flickering on the ground:

 

http://prntscr.com/q2gj9l

 

Both of them, here:

 

http://prntscr.com/q2gjqa


  • 0

#3 DoubleYou

DoubleYou

    Wiki Stepper

  • Uber Moderator
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,791 posts

Posted 27 November 2019 - 09:43 PM

Skyrim Special Edition's shadow settings are insufficient to produce what you are desiring. You can only get the shadows you want reliably with original Skyrim. You cannot turn down the shadow filtering in Skyrim Special Edition, so the only way to increase the sharpness of the shadows is by increasing the shadow resolution, which tanks performance. For instance, you can increase the value of the shadow resolution to 16384, and the shadows will largely look the way you want, but there still will be the blurring you are seeing that makes it look like shadows are doubling. As for the constantly moving effect that shadows have outdoors, that is because the sun-shadow transitions have been "fixed" to move at direct speed, and since time passes by so fast in Skyrim, if you stop to look, you can see the shadows constantly moving. In original Skyrim, and earlier version of SSE, the sun-shadow transitions could be modified so that you would hardly notice, but that seems to have been "fixed" AKA broken.

 

My current shadow settings that I have grown to like (very performance-friendly, rather soft shadows)

 

Skyrim.ini

[Display]
fFirstSliceDistance=2800
fShadowDirectionalBiasScale=0.3

SkyrimPrefs.ini

[Display]
bDrawLandShadows=1
bTreesReceiveShadows=1
ffocusShadowMapDoubleEveryXUnit=450.0000
fInteriorShadowDistance=3000.0000
fShadowDistance=8000.0000
iNumFocusShadow=4
iNumSplits=2
iShadowMapResolution=2048
iShadowMaskQuarter=4

If you want sharper shadows, all you can really do is increase iShadowMapResolution.



#4 lupus_hegemonia

lupus_hegemonia

    Thane

  • Citizen
  • 57 posts

Posted 05 December 2019 - 04:21 AM

Thxs a lot.
So... the previous versions of SSE had BETTER SHADOWS (as I remember) than the "new fixed" ones, right?

"Lovely". Classic-Bethedsa policy, they ...destroying those they left untouched.


  • 0

#5 DoubleYou

DoubleYou

    Wiki Stepper

  • Uber Moderator
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,791 posts

Posted 25 January 2020 - 01:54 PM

After doing more testing on the INI files, I have found a setting that fixes the constantly moving shadow effect and re-enables the old form of controlling sun-shadow movement that we have been used to via the fSunShadowUpdateTime and fSunUpdateThreshold settings. It seems that setting bDisableShadowJumps under Display to 0 will return us to this former method, removing the constantly flickering method of shadows always in movement in relation to the sun. I think that this setting boils down to user preference than anything else.

 

With this new information, I recommend the user to set this according to your preference. The following settings controls sun-shadow movement in Skyrim Special Edition.

 

Skyrim.ini

[Display]
bDisableShadowJumps=1
fSunShadowUpdateTime=1
fSunUpdateThreshold=0.5

bDisableShadowJumps toggles whether or not sun-shadow movement is controlled dynamically outdoors, resulting in constantly moving and potentially flickering shadows in relation to the movement of the sun as time passes. Disabling this will result in sun-shadow movement being dictated by the fSunShadowUpdateTime and fSunUpdateThreshold settings, as utilized previously in the non-Special edition version of the game.

 

fSunShadowUpdateTime sets the speed of sun-shadow transitions in seconds. Setting this to 0 will cause the transition to be immediate, but jarring. bDisableShadowJumps must be set to 0 for this to have any effect in Skyrim Special Edition.

 

fSunUpdateThreshold sets the time between sun-shadow transitions. A value of 0.05 is equal to 1 second, so a value of 1 equals 20 seconds. Increasing this also increases the distance the shadows will move during the transition. Setting this to 0 will cause the shadows to constantly be moving outdoors with the sun (not recommended). bDisableShadowJumps must be set to 0 for this to have any effect in Skyrim Special Edition.

 

 

The following is the old STEP recommended settings for original Skyrim for sun-shadow transitions in case the user would like to use it:

 

Smooth sun-shadow transitions

fSunShadowUpdateTime sets the speed of sun-shadow transitions in seconds. It is recommended to be adjusted to minimize the transitions. The value here increases the speed of the transition from one second to a quarter second. fSunUpdateThreshold sets the time between sun-shadow transitions. A value of 0.05 is equal to 1 second, so a value of 1 equals 20 seconds. Increasing this also increases the distance the shadows will move during the transition. It is recommended to be adjusted to minimize the transitions. The tweak here increases the time between transitions from 10 to 30 seconds, causing the transition to move the shadows three times as far.

fSunShadowUpdateTime=0.25
fSunUpdateThreshold=1.5



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users