Jump to content


Photo

Issue with Blank Map and no Fast Travel in MO2 Oldrim instance

mo2 mo1 oldrim maps setup

  • Please log in to reply
3 replies to this topic

#1 sgensemer42

sgensemer42

    Noble

  • Citizen
  • 40 posts

Posted 26 January 2020 - 05:42 PM

Haven't played Skyrim for a while, and decided to try setting up Oldrim in MO2 for convenience. I am using MO 2.2.2.1.
 
Used Gamer Poet's guide to copy Oldrim from MO1 to MO2 in its own instance.()
 
Using INI files, Mods, etc. as-is copied from MO1.
 
After rerunning LOOT, Dual Sheath Redux, FNIS, Wrye Bash to make sure all still works, the game loads up fine, no issues. However:
 
Going into Map [M] key or by [Tab] > Map
On Entry - World Map scrolls (up or out - can't tell) really fast. I usually see clouds briefly. Screen is then blank. The active quest marker is in the far upper left corner. There is the Dawnguard 'castle' marker sort of visible in the upper left as well, and some other city marker in the lower left corner; but neither can be clicked on. Moving mouse cursor to the edges to scroll map has no effect. Neither does mouse wheel. Net result - cannot fast travel.
 
Local map seems to work fine.
 
This is a huge issue with no Fast Travel...
 
Profile used is based on STEP 2.2.9.1 (or 2.2.9.2, it's been a while, I can't recall which), and has worked fine up till now. The Mod List is pretty much strict STEP.
 
This issue is also a problem in another more personally customized version (profile). My Base/Vanilla versions do NOT have this issue. Maps work fine on those profiles. Strange.
 
Tried deleting all map info in [MAPS] section of Skyrim.ini. No change. Tried different combinations of [MAPS] settings. No change.
 
After pulling my hair out for a day, I went back to my MO1 setup (legacy version 1.4). Fired up Skyrim - Same Profile as used in MO2 - Same INI files - Same game saves - Map functions completely normally. WTF?
 
I'm inclined to think it is an issue in setting up MO2 to work with Oldrim, and not a mod issue, even though the base/vanilla profiles work fine. Mainly because I'm using the same saves/INI files in both versions of MO.
 
I can still play the game in MO1; but I'd rather play it in MO2 (If for no other reason than it's easier updating the Mods in MO2 as the feature seems to be locked out in MO1...
 
Anyone have any thoughts?

  • 0

#2 Greg

Greg

    High King

  • Uber Moderator
  • PipPipPipPipPipPip
  • 2,196 posts

Posted 26 January 2020 - 07:28 PM

I don't know if this is relevant to your specific issue but one potential difference is that Mod Organizer 1 allows assets overrides assets in lower-priority mods regardless of whether the assets are stored as loose files or stored in a BSA archive. With Mod Organizer 2, loose files always win the conflict.



#3 sgensemer42

sgensemer42

    Noble

  • Citizen
  • 40 posts

Posted 28 January 2020 - 02:47 PM

I'll have a look to see if I have any loose assets or not. I used to do that as it was recommended "long" ago; but I stopped doing that a while back. There may be some left overs...

 

I also forgot to mention that once the issue crops up - my frame rate drops to the single digits once you are out of the map.

 

I also ran more of my old toons, and found, actually, most of them had this issue on MO1. Only one or two do not. I even started a fresh toon with this MO profile active. Same odd map issue dang it. (I also noticed my visibility indoors to be waaaay too dark, so there might be something else going on.)

 

The map mods I have are really only texture and INI related, so I'm not sure what affect those would really have.

 

CURIOUS QUESTION:

When you consider the STEP mods from 2.2.9.1/2.2.9.2 era - what sort of, or which mods could affect the world map "positioning" (for lack of a better word)? (Keeping in mind the local map is just fine.) You guys know these mods way better than I do. Anything I could narrow in on?


  • 0

#4 sgensemer42

sgensemer42

    Noble

  • Citizen
  • 40 posts

Posted 28 January 2020 - 03:07 PM

Just occurred to me - Since I cannot fast travel with the map acting up:

 

Could I use the console COC command to travel around? (Wasn't necessarily designed for that; but...)

 

What would be the downside of using that method? (Aside from finding the area ID's...)

- Do followers & your horse follow you if you COC?

- Any accumulative save corruption possible?

- Any other downside?


  • 0



Also tagged with one or more of these keywords: mo2, mo1, oldrim, maps, setup

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users