Jump to content


Photo

Error when generating LODs with Cathedral Landscapes installed


  • Please log in to reply
14 replies to this topic

#1 Pawelekdabek

Pawelekdabek

    Citizen

  • Citizen
  • 23 posts

Posted 30 March 2020 - 11:25 PM

Hi,

 

So i have tried to generate LODs with Cathedral Landscapes mod installed but i keep getting same error over and over. I tried redownloading this mod from Nexus but it did not help. Of course I can exchange this mod for any other texture mod but this one is really pretty.

 

Bugreport:https://pastebin.com/qQGaKLKV

Tamriel_log:https://pastebin.com/Vv3wQudP

 

I know that this one mod is a problem because i ran multiple generations to find what was causing my problem, and without this mod i could generate with no errors. I tried swapping this mod for Serpentials Landscape Mod and also no errors (but they are awfull for my taste).


  • 0

#2 Pawelekdabek

Pawelekdabek

    Citizen

  • Citizen
  • 23 posts

Posted 30 March 2020 - 11:57 PM

I also ran generation with only essential mods and Debug=1

 

Bugreport:https://pastebin.com/3emQPfPv

Tamierl_log:https://pastebin.pl/view/f1b5551f (pastebin.pl bc it was too big for pastebin.com)

 

I was following step guide for 3D trees LODs so TreeFullFallback=0 and TreeLod=0 but i think it is okay as i was able to succesfully generate LODs with other texture mod.


Edited by Pawelekdabek, 31 March 2020 - 12:00 AM.

  • 0

#3 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 31 March 2020 - 04:17 AM

Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 

 

Did you clean Update.esm and the DLCs with the latest xEdit and autoclean method?

 

I have no error generating with Cathedral Landscapes installed.

 

There is an out of memory message in the bug report, so check if closing any unnecessary (background programs/services) helps.

Also leave the OS page file settings at default.

Test if closing the spawned LODGen command prompt window as soon as it spawn helps.


  • 1

#4 Pawelekdabek

Pawelekdabek

    Citizen

  • Citizen
  • 23 posts

Posted 31 March 2020 - 04:36 AM

Do not use the experimental TreeFullFallBack setting without understanding what it does and what it is for. 

I was following S.T.E.P guide. I was generating LODs with other texture mods without any problem with this setting set to "0"

 

Did you clean Update.esm and the DLCs with the latest xEdit and autoclean method?

Yes, everything is cleaned, LOOT shows no warnings.

There is an out of memory message in the bug report, so check if closing any unnecessary (background programs/services) helps.

Also leave the OS page file settings at default.

Page file is unchanged. When i generate LODs i do not use my PC nor any program is running in the background.

 

I have no error generating with Cathedral Landscapes installed.

I will try to run it one more time with TreeFullFallback=1 and with PapyrusUtil SE, DynDOLOD Resources SE and Cathedral Landscapes only.


  • 0

#5 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 31 March 2020 - 05:10 AM

I was following S.T.E.P guide. I was generating LODs with other texture mods without any problem with this setting set to "0"

Do you know why to set it to 0 or are you just following instructions...

Page file is unchanged. When i generate LODs i do not use my PC nor any program is running in the background.


For example, the bug report shows Steam running. It is not required for generating LOD.
  • 1

#6 massiveactive

massiveactive

    Citizen

  • Citizen
  • 10 posts

Posted 31 March 2020 - 05:54 AM

Do you know why to set it to 0 or are you just following instructions...


For example, the bug report shows Steam running. It is not required for generating LOD.

Have no choice but to break the log into 4 parts, pls check:

Part 1: https://pastebin.com/sN8RfEhG

Part 2: https://pastebin.com/vM8FNrkT

Part 3: https://pastebin.com/aw5pE39a

Part 4: https://pastebin.com/tfhFDS3n


Edited by massiveactive, 31 March 2020 - 05:55 AM.

  • 0

#7 Pawelekdabek

Pawelekdabek

    Citizen

  • Citizen
  • 23 posts

Posted 31 March 2020 - 05:57 AM

Do you know why to set it to 0 or are you just following instructions...

It was described like it is higher visual quality option. I read manual for ultra trees and you wrote that it should be used only for testing not for gameplay. Why is it in S.T.E.P guide then? Since the guide is intended for newbies, this option should not be included in it.

 

However, i ran it with all mods, TreeFullFallback=1 without any errors. 

 

I have two more questions.

1. I am experiencing distant texture flickering. Can it be fixed with DynDOLOD

2. What does NearGridToLoad and FarGridToLoad does? Can i benefit form setting both options higher? I was reading manual but i do not really understand it.


Edited by Pawelekdabek, 31 March 2020 - 06:24 AM.

  • 0

#8 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 31 March 2020 - 07:04 AM

1. The question is not very specific what is flickering. Probably large reference bugs.  See FAQ Q: Game: Out of place objects / floating objects / flickering full models

 

2. The manual has this very nice graphic that shows how many cells around the player the loaded cells (uGridsToLoad), the NearGrid and the FarGrid are. How am I supposed to explain it any way different than I already did in the manual? These are the 2 areas/distances that DynDOLOD adds dynamic and animated LOD to. If you make them larger than those objects will shows even further at the cost of performance. If the visuals are actually any better depends on a number of factors. Just make a second LOD mod with different settings and then compare if the visual and performance impact are acceptable.


Edited by sheson, 31 March 2020 - 07:26 AM.

  • 1

#9 Pawelekdabek

Pawelekdabek

    Citizen

  • Citizen
  • 23 posts

Posted 01 April 2020 - 03:19 PM

1. The question is not very specific what is flickering. Probably large reference bugs.  See FAQ Q: Game: Out of place objects / floating objects / flickering full models

I think my problem is called z-fighting.


  • 0

#10 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 01 April 2020 - 03:43 PM

I think my problem is called z-fighting.

Yes that it is what texture flickering between two similar shapes with different textures is called.

 

However, you have no explained or shown with a screenshot what it is that is actually flickering. See FAQ Q: Game: Out of place objects / floating objects / flickering full models


  • 1

#11 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,709 posts

Posted 01 April 2020 - 11:27 PM

It was described like it is higher visual quality option. I read manual for ultra trees and you wrote that it should be used only for testing not for gameplay. Why is it in S.T.E.P guide then? Since the guide is intended for newbies, this option should not be included in it.

I've removed it as an option in the instructions. I can run Full LOD without issue, but that doesn't mean others can.

Keep in mind that the STEP SE Guide is still in beta. Please feel free to report any issues with it using our Bug Report topics.



#12 Pawelekdabek

Pawelekdabek

    Citizen

  • Citizen
  • 23 posts

Posted 03 April 2020 - 06:42 PM

Okay, so i did a video on this textures flickering. It was existing save but i tried also on new one and it is the same. LODs are newly generated.


Edited by Pawelekdabek, 03 April 2020 - 06:51 PM.

  • 0

#13 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 04 April 2020 - 03:03 AM

Okay, so i did a video on this textures flickering. It was existing save but i tried also on new one and it is the same. LODs are newly generated.

That video seems to show the already mentioned large reference bugs.  See FAQ Q: Game: Out of place objects / floating objects / flickering full models. The last answer.


Edited by sheson, 04 April 2020 - 03:03 AM.

  • 1

#14 Pawelekdabek

Pawelekdabek

    Citizen

  • Citizen
  • 23 posts

Posted 04 April 2020 - 07:11 AM

Thank you, that did worked.

 

Last question. I am using HD Skyrim SE Textures and i have problem with horse stall building near Whiterun. It's LOD texture have red roof but full texture is yellow. Is it possible to somehow change it but also retain redroof lod of Whiterun buildings?

 

https://imgur.com/a/DwgVfD2


  • 0

#15 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,276 posts

Posted 04 April 2020 - 07:40 AM

Thank you, that did worked.

 

Last question. I am using HD Skyrim SE Textures and i have problem with horse stall building near Whiterun. It's LOD texture have red roof but full texture is yellow. Is it possible to somehow change it but also retain redroof lod of Whiterun buildings?

 

https://imgur.com/a/DwgVfD2

You have installed a mod that replaces the single object LOD texture textures\lod\wrbuildingslod02.dds which seem to have made the thatch look red.

Remove/Hide the single object LOD texture so it uses the vanilla version again when generating the LOD texture atlas.

To update only the LOD texture atlas, use expert mode as explained in DynDOLOD_TexGen.html "Update Texture Atlas"


Edited by sheson, 04 April 2020 - 07:41 AM.

  • 1


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users