Jump to content


Photo
- - - - -

Dread's Skyrim Build (a STEP build)


  • Please log in to reply
107 replies to this topic

#46 MetalheadVez

MetalheadVez

    Noble

  • Citizen
  • 32 posts

Posted 14 July 2020 - 07:53 AM

Update on the bug for Diverse Skyrim, I checked by visiting all the imperial camps and all the Stormcloak camps. This situation is only happening when the player attempts to speak with the quartermaster. When the quartermaster replies, he is mute and no voice is heard.

 

I have noted this bug for the following locations: Eastmarch Imperial camp; Reach Stormcloak camp; Hjaalmarch stormcloak camp.

 
This only happens in three places and not for all of the imperial camps as I mentioned before. Hope this helps :)

 

p.s. I'm playing with the Phoenix Flavour list (V3.3) at the moment, which is also running Diverse Skyrim and AI overhaul (both mods are requirements and not optionnals). I'll go ask in the Discord if someone else have encountered this bug or if this is only happening on my side.


Edited by MetalheadVez, 14 July 2020 - 03:35 PM.

  • 0

#47 MetalheadVez

MetalheadVez

    Noble

  • Citizen
  • 32 posts

Posted 16 July 2020 - 10:51 AM

I've just saw that the mod Provincial courier service was updated. The the courier house is now relocated to the southwest side of Whiterun on the main road just past the stables area. It might now be clashing with something else around this area... :(


  • 0

#48 dreadflopp

dreadflopp

    Jarl

  • Editor
  • PipPipPip
  • 1,381 posts

Posted 17 July 2020 - 02:29 AM

I've just saw that the mod Provincial courier service was updated. The the courier house is now relocated to the southwest side of Whiterun on the main road just past the stables area. It might now be clashing with something else around this area... :(


Provincial courier service is not in the guide. I have been looking for something to replace the courier system since I don't like it but I haven't found anything. A raven (like in GoT) or something magical would be better than the annoying courier that always seems to know exactly where you are.

Update on the bug for Diverse Skyrim, I checked by visiting all the imperial camps and all the Stormcloak camps. This situation is only happening when the player attempts to speak with the quartermaster. When the quartermaster replies, he is mute and no voice is heard.

I have noted this bug for the following locations: Eastmarch Imperial camp; Reach Stormcloak camp; Hjaalmarch stormcloak camp.

This only happens in three places and not for all of the imperial camps as I mentioned before. Hope this helps :)

p.s. I'm playing with the Phoenix Flavour list (V3.3) at the moment, which is also running Diverse Skyrim and AI overhaul (both mods are requirements and not optionnals). I'll go ask in the Discord if someone else have encountered this bug or if this is only happening on my side.


Thanks! I have added diversity to the guide but "disabled" it for now. You can enable it by removing the code that disables it in the readme and the fomod. I need to fix the the dark face bug, it's a load order/facegen thing. I'll take a look at Phoenix to see how it's solved there.
  • 0

#49 MetalheadVez

MetalheadVez

    Noble

  • Citizen
  • 32 posts

Posted 22 July 2020 - 07:38 AM

Hi! Since there was a huge update for the Phoenix flavour last week, I think I'll just made the switch for your list and start from the beginning. My only preoccupation with Diverse Skyrim was for the dialogue with the quartermaster's at the locations that I've mentioned but otherwise there was no other bugs that I've found. Is it the same thing on your side?

 

I'm curious about what you are looking to add for the textures, but here's some suggestions;

 

The first one is Sigils of Skyrim, which is the successor of Design of the Nords with new colors and design. It also have some textures for the shields to match the banners. For the flora, I really like the mods made by ArtbyMari, which are not too far from the vanilla look and can compliment the ones you already use from Cathedral plants.

 

There's a lot of stuff happening in my personal life, as I'm moving on a new apartment in less than two weeks, so I may be short of time to complete the guide as fast as I would like. After that, I would be more than happy to play the game and give you some comments. I really like your choice of mods and sure that it worth it to give it a shot :)


Edited by MetalheadVez, 22 July 2020 - 11:05 AM.

  • 0

#50 dreadflopp

dreadflopp

    Jarl

  • Editor
  • PipPipPip
  • 1,381 posts

Posted 22 July 2020 - 01:13 PM

Thanks, any feedback is much appreciated. There isn't any specific texture mods that I want to add. I want to see if there is anything that can further improve the mods I use, I will check out the ones you mentioned. Ground textures is something I've been wanting too compare, maybe the complimentary pack from Majestic Mountains. I'm also going to compare different snow mods.

I'm getting the dark face bug from Diverse Skyrim. I haven't had time to test if I got the quartermaster bug.
  • 0

#51 dezzybird

dezzybird

    Watcher

  • Watcher
  • 2 posts

Posted 23 July 2020 - 06:18 PM

Hi, I recently decided to get back into modding Skyrim and I've followed your build almost exactly (I left out a couple of retexture mods) but I'm getting a crash to desktop when i start a new game. The only errors LOOT is flagging are Immersive Horses and RDO being in the same load order but I assume that was fixed with the df patch. Any ideas what the problem might be? Sorry if this isn't enough info, it's been a while :blush:
 

Load Order:


Edited by dezzybird, 23 July 2020 - 06:21 PM.

  • 0

#52 dreadflopp

dreadflopp

    Jarl

  • Editor
  • PipPipPip
  • 1,381 posts

Posted 24 July 2020 - 03:44 AM

Hi, I recently decided to get back into modding Skyrim and I've followed your build almost exactly (I left out a couple of retexture mods) but I'm getting a crash to desktop when i start a new game. The only errors LOOT is flagging are Immersive Horses and RDO being in the same load order but I assume that was fixed with the df patch. Any ideas what the problem might be? Sorry if this isn't enough info, it's been a while :blush:
 

Load Order:

The RDO/Immersive Horses conflicts are indeed solved by the patches. If the game crashes before the main menu, a plugin is missing a master. If the game crashes when you start a new game it is a little harder to find the culprit. If this is the case, try/check the following:

* Does the game start without any mods enabled

* Check with vanilla .ini-files.

* Try to disable the bottom half of all plugins and see if the game starts. If it doesn't, repeat until it does. When you finally manage to start a new game, start activating disabled plugins again, either one by one or in chunks and see if you can start a new game without getting a ctd. When you finally find the problematic plugin, recheck the install instructions in the guide.
 


  • 0

#53 dezzybird

dezzybird

    Watcher

  • Watcher
  • 2 posts

Posted 24 July 2020 - 08:40 AM

The RDO/Immersive Horses conflicts are indeed solved by the patches. If the game crashes before the main menu, a plugin is missing a master. If the game crashes when you start a new game it is a little harder to find the culprit. If this is the case, try/check the following:

* Does the game start without any mods enabled

* Check with vanilla .ini-files.

* Try to disable the bottom half of all plugins and see if the game starts. If it doesn't, repeat until it does. When you finally manage to start a new game, start activating disabled plugins again, either one by one or in chunks and see if you can start a new game without getting a ctd. When you finally find the problematic plugin, recheck the install instructions in the guide.
 

I did as you suggested and disabled various plugins to see what was causing the issue and it turned out to be my Dyndolod. After redoing it with medium settings the game is now working so thank you for the troubleshooting tips and the guide!


  • 0

#54 MetalheadVez

MetalheadVez

    Noble

  • Citizen
  • 32 posts

Posted 26 July 2020 - 12:50 PM

I've been going through the whole guide (I've taken a few notes to share later) but I have an error message when I'm trying to generate the animation files with the Nemesis unlimited behaviour engine. Here it is:

---
Checking engine version
Engine is up to date
Version Code: 3886-8984

Initializing behavior generation

Mod Checked 1: nemesis
Mod Checked 2: aarm
Mod Checked 3: agpo

Mod installed: NAR
Mod installed: XPMSE

ERROR(1210): Vital behavior file cannot be found. This will cause T-pose in game. To fix this, either reinstall the mod or manually restore this behavior file
File: c:\steam\steamapps\common\skyrim special edition\data\meshes\actors\character\behaviors\0_master.hkx

Failed to generate behavior

---

Has this error occurred to anyone else? Is there a way to fix it?

 

UPDATE: Fixed the issue by downgrading to the previous version of Nemesis, v0.83. I really have no idea why it didn't work with the most recent version of the Nemesis engine (v0.84-beta), since I repeated the exact same steps ...


Edited by MetalheadVez, 26 July 2020 - 06:55 PM.

  • 0

#55 dreadflopp

dreadflopp

    Jarl

  • Editor
  • PipPipPip
  • 1,381 posts

Posted 27 July 2020 - 03:25 PM

I've been going through the whole guide (I've taken a few notes to share later) but I have an error message when I'm trying to generate the animation files with the Nemesis unlimited behaviour engine. Here it is:
---
Checking engine version
Engine is up to date
Version Code: 3886-8984

Initializing behavior generation

Mod Checked 1: nemesis
Mod Checked 2: aarm
Mod Checked 3: agpo

Mod installed: NAR
Mod installed: XPMSE

ERROR(1210): Vital behavior file cannot be found. This will cause T-pose in game. To fix this, either reinstall the mod or manually restore this behavior file
File: c:\steam\steamapps\common\skyrim special edition\data\meshes\actors\character\behaviors\0_master.hkx

Failed to generate behavior
---
Has this error occurred to anyone else? Is there a way to fix it?

UPDATE: Fixed the issue by downgrading to the previous version of Nemesis, v0.83. I really have no idea why it didn't work with the most recent version of the Nemesis engine (v0.84-beta), since I repeated the exact same steps ...


Thanks for the report. I'll check to see if I can build the animation files without getting any error.
  • 0

#56 Asar00

Asar00

    Watcher

  • Watcher
  • 1 posts

Posted 01 August 2020 - 03:05 AM

Hey Dread, thanks for your version of STEP, especially how detailed the instructions are. I use it and I appreciate the work involved.

Found a fresh project on the nexus that you and/or the STEP team might find interesting as a foundational mod. It's a complete re-optimization and re-compression of the vanilla files. Give it a look if you want.

https://www.nexusmod...ion/mods/38775/
  • 1

#57 dreadflopp

dreadflopp

    Jarl

  • Editor
  • PipPipPip
  • 1,381 posts

Posted 05 August 2020 - 03:12 AM

Hey Dread, thanks for your version of STEP, especially how detailed the instructions are. I use it and I appreciate the work involved.

Found a fresh project on the nexus that you and/or the STEP team might find interesting as a foundational mod. It's a complete re-optimization and re-compression of the vanilla files. Give it a look if you want.

https://www.nexusmod...ion/mods/38775/

Thanks! This looks very interesting. It is already considered for inclusion: https://forum.step-p...-by-kartoffels/


  • 0

#58 dreadflopp

dreadflopp

    Jarl

  • Editor
  • PipPipPip
  • 1,381 posts

Posted 05 August 2020 - 04:36 AM

I have updated all mods in the guide and made sure all patches are up to date. Two patches have been updated. Make sure to read the instructions for adamant before updating to 4.x.

 

Changelog: https://github.com/d.../commits/master


  • 0

#59 Wanderer

Wanderer

    Citizen

  • Citizen
  • 21 posts

Posted 05 August 2020 - 07:01 AM

Hi Dread,

 

first, thanks for the compilation and the work around it :) i returned back to skyrim after several years and followed your setup with few changes for my new playthrough (no adamant, no ars metallica, im using WACCF, aMidianborn content addon and CBBE SMP body). what hardware are you testing your setup with? seems i have terrible issues with performace after finishing unchained quest - the whole intro sequence im running between 40-60fps, Helgen is between 45-55fps, Helgen interiors are at 60fps, but since i leave Helgen and head down to Riverwood through that dense forrest area, my fps drop to 5...

 

my rig is not new but quite decent, i do not have issues with other games usually. i7 960 @3,2GHz, 12GB RAM, GTX1060 6GB

 

so the question is - is there any reccomended way how to troubleshoot performance? any suggested tools to use? any mods in your setup that are best candidates for heavy performance drops? i have searched around for performance tips on STEP forums but havent stumbled upon anything, maybe i'm bad in searching lol

 

thanks in advance :)
W.


  • 0

#60 dreadflopp

dreadflopp

    Jarl

  • Editor
  • PipPipPip
  • 1,381 posts

Posted 05 August 2020 - 09:28 AM

Hi Dread,

 

first, thanks for the compilation and the work around it :) i returned back to skyrim after several years and followed your setup with few changes for my new playthrough (no adamant, no ars metallica, im using WACCF, aMidianborn content addon and CBBE SMP body). what hardware are you testing your setup with? seems i have terrible issues with performace after finishing unchained quest - the whole intro sequence im running between 40-60fps, Helgen is between 45-55fps, Helgen interiors are at 60fps, but since i leave Helgen and head down to Riverwood through that dense forrest area, my fps drop to 5...

 

my rig is not new but quite decent, i do not have issues with other games usually. i7 960 @3,2GHz, 12GB RAM, GTX1060 6GB

 

so the question is - is there any reccomended way how to troubleshoot performance? any suggested tools to use? any mods in your setup that are best candidates for heavy performance drops? i have searched around for performance tips on STEP forums but havent stumbled upon anything, maybe i'm bad in searching lol

 

thanks in advance :)
W.

I'm playing on a i5 @4GHz and a 1070 (8 GB), 16 GB ram. But your hardware should be sufficient, not sure why it drops so much. If you are using ENB, try without it. If it is just forest areas, it might be something with the 3d forest. Try disabling the DynDOLOD folder to see if that helps.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users