Jump to content


Photo
bugs

STEP Skyrim SE Guide v0.3.0b - Official Bug Reports



  • Please log in to reply
155 replies to this topic

#151 CwalkPinoy

CwalkPinoy

    Watcher

  • Watcher
  • 3 posts

Posted 30 September 2020 - 01:07 PM

gonna see if i can make a patch for this today. if i get one done i'll let you know

if that was the right issue, i've made a separate patch for it. will update if other issues come up.

https://www.nexusmod...ion/mods/40977/

 

should make patching easier so TechAngel85 doesn't have to make GS a requirement for L&W


  • 0

#152 Teetsfortots

Teetsfortots

    Watcher

  • Watcher
  • 2 posts

Posted 06 October 2020 - 04:51 AM

Hey, so I just finished going through and installing the full STEP 0.3.0b guide, and the game works, but I am getting a visual bug/glitch. On a lot of clouds there is this thick vertical line. I did install an ENB to see if that would help (it didn't), but I think i'll just uninstall it. I'm not sure what is causing the bug and im not "knowledgeable" about modding, I guess? Anyway, here are two images, one with the lines circled, and one with no editing: https://imgur.com/a/uqIW4bK
Any help would be greatly appreciated. =)


  • 0

#153 Teetsfortots

Teetsfortots

    Watcher

  • Watcher
  • 2 posts

Posted 06 October 2020 - 07:52 AM

Sorry for the double post, but here is a more "exacerbated" line:

https://imgur.com/a/bdbUspa
 

These lines are more obvious when in game, rather than in the screenshots, sorry for that.

Again any help would be greatly appreciated =)


  • 0

#154 wojsku

wojsku

    Noble

  • Citizen
  • 47 posts

Posted 15 October 2020 - 04:10 PM

I can confirm the lines in the sky issue.

Tested with:

Cathedral Weathers 2.22

Ethereal Clouds 2.0

Alternate Start 4.1.3

weather 0010E1F1

 

The issue occurs when loading following mods and testing with the weather type above. The lines don't appear in every weather. I don't know what is the source of the visual issue but for me installing older version of Ethereal Clouds ( I have 1.0.7) fixed it. I wait until you guys can test, confirm the problem and find a fix.


  • 0

#155 SkyBlu

SkyBlu

    Watcher

  • Citizen
  • 2 posts

Posted 18 October 2020 - 08:56 PM

Hi!

 

There are a few bugs and outdated scripts in the mod "The Choice is Yours" by kryptopyr that have been reported on it's mod page (though only two of them can be fixed without script editing).

 

1) There is a bug which prevents the popup prompt from the book "The Aetherium Wars" from appearing if the player has entered Deep Folk Crossing.

 

From the Bugs tab by Aezay:

Found out what exactly is causing these issues.

Prompt now showing
When reading the book "The Aetherium Wars", the default script DefaultOnReadSetQuestStageNotAlias will explicitly set the stage, always. However, this mod's script TCIY_QuestBookMessageScript does a check, ensuring the stage is less than myStage (which is 10). However, when you get close to Deep Folk Crossing, the DLC1LD quest gets its stage set to 73. This means the prompt never triggers.

My proposed fix would be to do the following replacement. But I am saying that without knowing anything about papyrus scripting or having done any modding.
From: If myQuest.getStage() < myStage
Into: If (!myQuest.IsStageDone(myStage))

This fix is doable if you know how to re-compile the script yourself after making the necessary changes (I tried it and the fix works as intended, though I understand such edits are outside the scope of the STEP guide).

 

2) The same popup will not display the "There may be more to this story." message and will instead be blank.

 

Again, from the bugs tab by Aezay:

Missing header text in the prompt
The TCIY_ReadBookMessage property of "The Aetherium Wars" refers to TCIY_ReadBookMessage_DG, which is just an empty message, unlike TCIY_ReadBookMessage, which is used for the other quest books. Just delete this message and use TCIY_ReadBookMessage for both?

This can be fixed with SSEEdit and I suggest adding this to the core patch in the meantime until kryptopyr updates the mod herself.

 

To fix it, make the following edits to the core patch:

 

In FormID 02004D5B, replace the FormID "TCIY_ReadBookMessage_DG [MESG:3D016A63]" with "TCIY_ReadBookMessage [MESG:3D01665F]"

 

3) The scripts from this mod are missing changes from newer versions of USSEP (I don't know what effects these scripts have in the game).

 

From the posts tab, by user Tommy2368:

Still an essential mod for me, but six of the mod's scripts need updating for USSEP standards. Since these aren't strict bugs with the mod itself, I'm posting my findings here.

QF_FreeformSoljundsSinkholeA_0006136B: TCIY's GetFormFromFile command uses a string with a typo, preventing the relevant Object Reference from being filled.
QF_MS01_00018B4B: Based on the source code, USSEP removed changes from USKP 2.1.3 from Fragment 47.
QF_MS07Start_000AA9A9: USSEP adds an additional Stop command to Fragment 1.
QF_MS08_0001CF25: USSEP adds additional code to Fragment 13, and alters code in Fragment 21.
QF_MS09_0001CF26: USSEP adds an additional line of code to Fragment 15.
QF_MS14_00025F3E: USSEP adds and streamlines code in Fragments 25 and 27. USSEP also uses different coding in Fragment 30; the code now sets a crime faction, instead of relationship rank.

I have edited the above scripts, but I can't confirm that they work as intended as I haven't played any of the edited quests yet, so do this at your own risk (again, not in the scope of the STEP guide, only do this for testing purposes).

 

4) The mod reverts necessary USSEP changes to the Soljund's Sinkhole quest where you kill the draugr in the mine. USSEP makes it so that they don't respawn after the quest is completed, but TCIY reverts it so that they do respawn. This can result in the Draugr killing miners.

 

From the Bugs tab, by user mikeprichard:

TCIY, which must be loaded after USSEP for several reasons, reverts to broken vanilla behavior whereby completing the quest to clear Soljund's Sinkhole (FreeformSoljundSinkholeA) does not permanently disable the draugr in the mine, resulting in the draugr possibly killing the returned miners. I suggest that TCIY and the author's other mods be restructured to have USSEP as a requirement to avoid this and other similar problems.

Until this is fixed by the author, you can do it yourself by carrying over the changes USSEP makes to FormID 0006136B under the "Script Properties" tab. Even better if it is included in the Core patch.

 

I this helps!


  • 1

#156 federation25

federation25

    Noble

  • Citizen
  • 35 posts

Posted 22 October 2020 - 11:16 PM

For those reporting the seam lines in Ethereal Clouds, the latest 3.0 release purportedly fixes the issue.


  • 0



Also tagged with one or more of these keywords: bugs

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users