Jump to content


Photo
Skyrim VR

Water flickering issues...



  • Please log in to reply
1 reply to this topic

#1 VanGohman

VanGohman

    Citizen

  • Citizen
  • 18 posts

Posted 11 September 2020 - 12:50 PM

Hey guys,

I'm not sure if this is the right place to ask, so apologies in advance if this isn't the place.

In the riverside waterfalls area near Anga's Mill, (just south of Windhelm), when I'm at the top of the chain of waterfalls, standing on the rock that outcrops over the first waterfall and look down, the river water on the next level down from there has a terrible flicker.

I've tried removing all mods and using COC angasmillexterior, and it seems like this flicker is still there (although not as pronounced).

I've been doing research for a few days now, and have come across other flickering water surface issues that were related to going higher than 60fps, but so far all the video clips I've seen appear to have a slightly different issue where the whole water will flicker.

In my case, it's just the rushing white water effects (which are more prominent when using Reaslistic Water Two, hence why it's more noticeable than vanilla I think).

I happen to be using Skyrim VR, and to get a stable framerate, I'm using ASW, which locks the Rift S to 40 fps, and it makes up every other frame to simulate a 90 fps "feel" in the headset.

I've tried turning off ASW, and my headset ends up hovering between 80 and 50 fps, and I still see this issue there as well.

Has anyone come up against this sort of thing before? It doesn't seem like there are any examples out there (at least on video) that seem to match what I'm seeing

Here is a video of what i'm seeing with all mods turned on, but this still happens with vanilla (just not as obvious), so I'm thinking it's some kind of engine limitation or non ideal frame rate situation.

Any help here would be hot. :)


  • 0

#2 VanGohman

VanGohman

    Citizen

  • Citizen
  • 18 posts

Posted 13 September 2020 - 11:33 AM

It's so hard to find other people who use Skyrim VR instead of SE. :D

In case anyone else was wondering about this issue, I think it's an engine limitation. I'm able to see the flickering water from that vantage point no matter what I do.

But it seems the texture mods I was mixing and matching may have made it much more apparent.

My first suspect was Realistic Water Two, which would have been a shame because I love that mod so much, but with just that mod enabled, it didn't seem any worse than vanilla.

Ultimately, the one mod that seemed to be causing it (directly or indirectly with other mods), was Majestic Mountains?

From my research, it seems as though you are not able to turn off the "improved Shader" they added to the SE version, because the VR version was branched before adding support for turning that off with an INI command: bEnableImprovedSnow=0

This seems to be the reason I can't seem to get my snow textures to match up in the LOD (things often have a blue tint to it in the lod).

I'm not sure if this is causing other issues, but I'm wondering how many things about Skyrim VR are different enough to possibly cause issues with mods that otherwise work fine on the SE version.

If anyone has any insight about these kinds of differences, I'd love to hear about it.

 


  • 0



Also tagged with one or more of these keywords: Skyrim VR

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users