Jump to content


Photo

NifSkope: Trouble adding glowmap to FloraNirnroot01.nif


Best Answer SparrowPrince , 18 October 2020 - 01:17 PM

Hello,

 

I don't think you can use a glow texture with the Tree_Anim, flutter, flag enabled, so I'd unflag that. I did have a quick look in the files, and I noticed there was already a nirnroot_g.dds texture with glowing veins that looks to be unused. Now that's most likely just because they preferred to have the wind animation enabled, so that's that mystery solved.

Your transparency issue could be a number of things. It looks like vertex alpha, mesh transparency, to me though. I'd first try clicking the BSTriShape, clicking the flag under Vertex Desc, unchecking the Colors flag and then saving. You can unflag vertex colors under the shader flags, but sometimes that doesn't do anything for some reason.
 

Edit: It's worth noting that I would also, under BSLightingShaderProperty, unflag Vertex_Alpha and Vertex_Colors under both shaders just to clean everything up. On top of this, if your glowing veins are white in the texture, you can simply use the Emissive Color property to tweak the colour values without setting a specific colour in the texture itself. I think that's then much easier to make tweaks later on.

Go to the full post


  • Please log in to reply
2 replies to this topic

#1 Flashtoo

Flashtoo

    Watcher

  • Watcher
  • 3 posts

Posted 17 October 2020 - 03:01 PM

I posted about this on the Nexus forums and on r/skyrimmods but I've been picking at the issue for days with no luck, so I figured I'd ask absolutely everywhere relevant. Lately I've been getting back into my love that is video game texture modding and I decided to start out with the nirnroot plant, because the vanilla one is godawful and doesn't look like a real leaf at all. Because I like being fancy, I decided to add glow mapping to the veins of my new leaf texture, but I'm having issues with it that are leaving me scratching my head.

 

Here is what the Nirnroot looks like in NifSkope after following the instructions I found on how to add glow mapping to a Skyrim mesh:

 

eVqSl71.jpg 420lHZX.jpg

 

 

And here is what it looks like in Skyrim - it's like the _g texture is all white, instead of just highlighting the veins in the leaf as intended (exhibit A):

 

FjQfXMm.jpg

 

 

So after being unable to figure out what I was doing wrong, I tried the alternative tack of copying the BSLightingShaderProperty branch from the Glowing Mushroom, re-pointing the texture set paths, and adjusting the glow intensity, color, and other flags like vertex shading to match what was on the original Nirnroot, and while this does seem to result in a properly-working glow map, the mesh turns invisible except for the very tips of the leaves, like this (exhibit B):

 

reE3E0K.jpg

 

 

Weirdest of all, if I look at the block list of nirnroots A and B side by side, I can't find any difference. What am I missing? What am I doing wrong here? Has anyone had this happen before?

 

Thanks


  • 0

#2 SparrowPrince

SparrowPrince

    Jarl

  • Mod Author
  • PipPipPip
  • 1,174 posts

Posted 18 October 2020 - 01:17 PM   Best Answer

Hello,

 

I don't think you can use a glow texture with the Tree_Anim, flutter, flag enabled, so I'd unflag that. I did have a quick look in the files, and I noticed there was already a nirnroot_g.dds texture with glowing veins that looks to be unused. Now that's most likely just because they preferred to have the wind animation enabled, so that's that mystery solved.

Your transparency issue could be a number of things. It looks like vertex alpha, mesh transparency, to me though. I'd first try clicking the BSTriShape, clicking the flag under Vertex Desc, unchecking the Colors flag and then saving. You can unflag vertex colors under the shader flags, but sometimes that doesn't do anything for some reason.
 

Edit: It's worth noting that I would also, under BSLightingShaderProperty, unflag Vertex_Alpha and Vertex_Colors under both shaders just to clean everything up. On top of this, if your glowing veins are white in the texture, you can simply use the Emissive Color property to tweak the colour values without setting a specific colour in the texture itself. I think that's then much easier to make tweaks later on.


Edited by SparrowPrince, 18 October 2020 - 04:11 PM.

  • 0

#3 Flashtoo

Flashtoo

    Watcher

  • Watcher
  • 3 posts

Posted 19 October 2020 - 03:13 PM

THANK YOU!!!! That has solved my problem and I'll be able to release this as soon as I do some final tweaking of the glow texture, now that I can actually see it! I would never have guessed it was the tree animation node!


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users