Jump to content


Photo

Landscape terrain LOD texture mismatch


  • Please log in to reply
2 replies to this topic

#1 kojak747

kojak747

    Thane

  • Citizen
  • 81 posts

Posted 12 January 2021 - 05:07 AM

Hi Sheson,

 

I have an issue with landscape LOD texture mismatch (Skyrim SSE).  It's odd because the loaded cell terrain texture for snow is fine, and the lod terrain texture is fine, but  I have these odd grey squares of snow LOD? amongst them. I'm using Dyndolod Alpha 18 and DynDOLOD resources Alpha 4.

 

https://imgur.com/a/XC7wAwG

 

Also, when I zoom out to view the map, there is another area of the map in the east whose textures are also mismatched in a similar fashion, here > https://imgur.com/a/IaKmTxg

 

Thanks in advance.

 

Kojak

 

 


  • 0

#2 sheson

sheson

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,899 posts

Posted 12 January 2021 - 05:17 AM

Terrain LOD meshes/texture is done by xLODGen. DynDOLOD does tree and object LOD only.

 

Each LOD quad (4x4, 8x8, 16x16, 32x32 cells) has its own specific terrain LOD texture. If a terrain LOD texture (or parts of it) does not match, it was not generated for this load order. 

 

The map seems rather obvious, one of the terrain LOD textures is from the map with roads, while the other is not...

 

If the snow in the loaded cells does not match the snow of the object/terrain LOD textures it is because of the "improved" snow shader and/or the bEnableProjecteUVDiffuseNormals.


Edited by sheson, 12 January 2021 - 05:30 AM.

  • 0

#3 kojak747

kojak747

    Thane

  • Citizen
  • 81 posts

Posted 12 January 2021 - 06:07 AM

Reran xLODGEN and generated new terrain meshes and textures. Vast improvement. Still need to tweak my noise.dds for a perfect match but this is much closer.  Thanks

 

https://imgur.com/a/XuyGvlb


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users