Jump to content


Photo

Infinite loading screen when fast travelling from Solstheim to Skyrim


  • Please log in to reply
138 replies to this topic

#121 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 02 October 2013 - 07:53 AM

Apologies if this was already mentioned as I'm not following this thread very closely, but did anyone tried using PCB console command to fix ILS's?

I think you can only use the PCB command when you are in an interior cell, right? Given that, you would have to find an interior cell to run the pcb command, then go back outside, then fast travel back to Skyrim. I think it makes more sense just to quit to the menu and reload, then fast travel since it would basically take the same amount of time. Quitting to the menu also dumps all data so I would just do that if I had to choose between the two ideas.


  • 0

#122 rootsrat

rootsrat

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,906 posts

Posted 02 October 2013 - 07:56 AM

Ah, I was under the impression that Purge Cell Buffer does the same thing as quitting to main menu. I am aware that you should only use it in the interior cells though, but if it works (possibly for other ILS-vulnerable spots, i.e. exitting Markarth), it may be a half-solution...
  • 0

#123 Aiyen

Aiyen

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,536 posts

Posted 02 October 2013 - 01:00 PM

As part of my updating to the latest ENB version 223, then I also just tested this again! With the new EnableCompression = true, then the ILS is mostly gone! At least I could make a trip for the first time in a week. Please do try out that and then return with feedback.

#124 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 02 October 2013 - 01:20 PM

As part of my updating to the latest ENB version 223, then I also just tested this again!

With the new EnableCompression = true, then the ILS is mostly gone! At least I could make a trip for the first time in a week.
Please do try out that and then return with feedback.

Ugh. Project ENB is only updated for 0.221. You can't use it with 0.223 I don't think. I'm more concerned about freezing at this point :(
  • 0

#125 Aiyen

Aiyen

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,536 posts

Posted 02 October 2013 - 01:26 PM

Okay full diagnostic of my changes to try to get rid of this annoying issue. Replaced SFO with SFO basic. Replaced Ultimate lush overhaul with Lush trees only. Reduced to only using high quality normals in RWT 2 Upgraded to v.223 of ENB with the latest changes to ENBoost. Set it too true, and voila... no ILS. and ofc you can use it... the extra additions you are not going to notice missing anyways and they are not going to make anything stand out badly with the default settings. I would be very surprised if they where. Just copy in the new .dll and enbhost.exe and never look back. When when project ENB is someday updated you can do it "properly". But regardless about this issue, then it seems to be a simple matter of reducing the amount of stuff that needs to load solves it... like always.

#126 MontyMM

MontyMM

    High King

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,144 posts

Posted 02 October 2013 - 01:48 PM

As part of my updating to the latest ENB version 223, then I also just tested this again!

With the new EnableCompression = true, then the ILS is mostly gone! At least I could make a trip for the first time in a week.
Please do try out that and then return with feedback.


Perhaps I misunderstood, but I thought that EnableCompression = true has always been the hardcoded default in ENBboost, and the inclusion of the setting is only to give the option of disabling it, by setting it to false.
  • 0

#127 Aiyen

Aiyen

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,536 posts

Posted 02 October 2013 - 01:55 PM

You may very well be correct! And its the result of the other changes I made! Guess that also makes more sense! But good to see that my optimizations are working and making the game more stable.

#128 rootsrat

rootsrat

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,906 posts

Posted 02 October 2013 - 02:41 PM

Didn't we come to a conclusion that it was large number of SCRIPTED mods that caused ILS? Did you try to reapply previous versions of those mods and test with 223 enb file? I have a feeling that this is all too random to establish any kind of pattern... Sent from my GT-I9100 using Tapatalk 4
  • 0

#129 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 02 October 2013 - 02:46 PM

This thread is only for the ILS from Solstheim to Skyrim, right? Are we talking about ILS's in general?
  • 0

#130 Aiyen

Aiyen

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,536 posts

Posted 02 October 2013 - 06:16 PM

Not gonna bother going back... it works now! So I am not gonna jinx it. The only thing I did was to reduce the amount of meshes that require loading, and the water normal texture. If that sorts it out and I can keep wet n cold then that is a good deal. I am not that desperate for extra trees. And I still have a lush tree so the ones that are there do not look like meh. And yes Its still Solstheim to Skyrim. About the loading screens, then the ones I get now are pure black, but it loads within 30 seconds as it should.

#131 phazer11

phazer11

    Chatroom Supervisor

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,288 posts

Posted 02 October 2013 - 11:54 PM

Which meshes did you cut out and how? For those of us who can't see what you're doing please.

#132 rootsrat

rootsrat

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,906 posts

Posted 03 October 2013 - 02:58 AM

Which meshes did you cut out and how? For those of us who can't see what you're doing please.


--->

Okay full diagnostic of my changes to try to get rid of this annoying issue.

Replaced SFO with SFO basic.
Replaced Ultimate lush overhaul with Lush trees only.
Reduced to only using high quality normals in RWT 2

Upgraded to v.223 of ENB with the latest changes to ENBoost. Set it too true, and voila... no ILS.

and ofc you can use it... the extra additions you are not going to notice missing anyways and they are not going to make anything stand out badly with the default settings. I would be very surprised if they where. Just copy in the new .dll and enbhost.exe and never look back. When when project ENB is someday updated you can do it "properly".

But regardless about this issue, then it seems to be a simple matter of reducing the amount of stuff that needs to load solves it... like always.


  • 0

#133 Ubeogesh

Ubeogesh

    Guard

  • Members
  • PipPip
  • 100 posts

Posted 13 October 2013 - 02:46 AM

I have found an inconvenient yet working solution for myself. The trick is - I have to disable one (of the list posted earlier in this thread) mod to be able to travel from Solstheim to Skyrim. And I have to have it enabled while traveling to Solstheim from Skyrim. So whenever I want to travel from Solstheim to Skyrim, I save, shut down the game, disable SkyFalls and SkyMills in Mod Organizer, start the game and travel to Skyrim. Then I go inside Windhelm, save, shut down the game, enable SkyFalls and SkyMills and reload the game. If I enable the mod while I am in Windhelm docs, I still get the ILS when loading the game in there. And as I already said, I can disable some other mod, but disabling & enabling SkyFalls and SkyMills is less painful because I don't have to rebuild bashed patch, dual sheath redux patch or run boss and don't have to worry about some quests or NPCs or items ******* up because I disabled the mod.
Some of the mods that I can disable for this workaround

  • 0

#134 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 13 October 2013 - 11:04 AM

I have found an inconvenient yet working solution for myself.
The trick is - I have to disable one (of the list posted earlier in this thread) mod to be able to travel from Solstheim to Skyrim. And I have to have it enabled while traveling to Solstheim from Skyrim. So whenever I want to travel from Solstheim to Skyrim, I save, shut down the game, disable SkyFalls and SkyMills in Mod Organizer, start the game and travel to Skyrim. Then I go inside Windhelm, save, shut down the game, enable SkyFalls and SkyMills and reload the game.
If I enable the mod while I am in Windhelm docs, I still get the ILS when loading the game in there.
And as I already said, I can disable some other mod, but disabling & enabling SkyFalls and SkyMills is less painful because I don't have to rebuild bashed patch, dual sheath redux patch or run boss and don't have to worry about some quests or NPCs or items ******* up because I disabled the mod.

Some of the mods that I can disable for this workaround

A much easier way, as I said before, would be just to save, quit to menu, load your game, then fast travel.
  • 0

#135 Aiyen

Aiyen

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,536 posts

Posted 28 October 2013 - 04:56 PM

Unsticked this thread as part of my optimization of the support subforum. I plan on having a new general ILS thread up soon to take its place. Going to leave it open, since this particular transition can still be more bothersome then most!


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users