Jump to content


Photo

SMAA Injector not working


  • Please log in to reply
46 replies to this topic

#16 dreadflopp

dreadflopp

    High King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,314 posts

Posted 19 March 2013 - 01:26 PM

This is how it looks using SMAA through enb (skyrealism ENB 1.39)

What other AA settings did you use? Is it just SMAA alone or in combination with hardware-AA?

ty

I use MSAAx4 through the launcher (or skyrimprefs.ini: iMultiSample=4). I haven't checked if that actually works though. I don't think it looks like it's working.
  • 0

#17 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 19 March 2013 - 01:32 PM

Post has been deleted
  • 0

#18 dreadflopp

dreadflopp

    High King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,314 posts

Posted 19 March 2013 - 02:07 PM



This is how it looks using SMAA through enb (skyrealism ENB 1.39)

What other AA settings did you use? Is it just SMAA alone or in combination with hardware-AA?

ty

I use MSAAx4 through the launcher (or skyrimprefs.ini: iMultiSample=4). I haven't checked if that actually works though. I don't think it looks like it's working.

It does look like it's working. Also, if you're running 4xMSAA, why do you need SMAA too? 


Just trying different setups. I had a lot jagged edges using MSAA so I figured I'd try SMAA and edge AA. Really have no idea which one or which combination to use.
  • 0

#19 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 19 March 2013 - 02:20 PM

Post has been deleted
  • 0

#20 dreadflopp

dreadflopp

    High King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,314 posts

Posted 19 March 2013 - 04:05 PM

Ok. Compared a lot of different settings. Forcing AA through Catalyst control center doesn't seem to work. SMAA 4x through skyrimprefs.ini looks good. I don't see any difference from raising it to 8x. If using ENB thoug, SMAA doesn't seem to work? MSAA and Edge AA does though. I think MSAA looks better. So if using ENB, use MSAA. IF not SMAA 4x.

GPU: Gigabyte AMD 7970 GHz edition
Catalyst control center 13.2 beta
ENB 1.39 Skyrealism Cinema preset
Screens, file name describes which AA i used:
All screens in a zip:
https://dl.dropbox.c...e/AA compare.7z

Posted ImageNo AA
Posted Image2. Forcing SSAA 4xEQ standard filter

[this forum only allows 10 pics, decided to not show a picture of forcing msaa through catalyst contol center since it doesn seem to work, but posting as a link instead, https://dl.dropbox.c...dard filter.jpg]

Posted Image4. Skyrimprefs.ini iMultiSample=4
Posted Image5. Skyrimprefs.ini iMultiSample=8
Posted Image6. ENB No AA
Posted Image7. ENB SMAA injector
Posted Image8. ENB Edge AA
Posted Image9. ENB Edge AA+SMAA injector
Posted Image10. Skyrimprefs.ini iMultisampling=4+ENB EdgeAA+SMAA injector
Posted Image11. ENB+SkyrimPrefs iMultiSample=4
  • 0

#21 Garpov

Garpov

    Prisoner

  • Members
  • 27 posts

Posted 19 March 2013 - 04:27 PM

As far as i was aware, SMAA works without having any other AA option enabled, is this correct? Its confusing when we start talking about various AA methods being on or off, i`d just like someone to confirm that they use SMAA as their only AA method, and that it works.
  • 0

#22 dreadflopp

dreadflopp

    High King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,314 posts

Posted 19 March 2013 - 04:39 PM

As far as i was aware, SMAA works without having any other AA option enabled, is this correct?

Its confusing when we start talking about various AA methods being on or off, i`d just like someone to confirm that they use SMAA as their only AA method, and that it works.


I can confirm that. SMAA MSAA works if you set it in the launcher or skyrimprefs.ini. It does not seem to work (for me at least) if I use ENB.
  • 0

#23 Garpov

Garpov

    Prisoner

  • Members
  • 27 posts

Posted 19 March 2013 - 04:57 PM

What launcher are you referring to?
  • 0

#24 dreadflopp

dreadflopp

    High King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,314 posts

Posted 19 March 2013 - 05:03 PM

What launcher are you referring to?


Skyrim launcher
  • 0

#25 dreadflopp

dreadflopp

    High King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,314 posts

Posted 19 March 2013 - 05:05 PM

What launcher are you referring to?


Wait, sorry, MSAA works if set in skyrim launcher. SMAA works if using ENB. I have tried using each one of them as my only AA.
  • 0

#26 Garpov

Garpov

    Prisoner

  • Members
  • 27 posts

Posted 19 March 2013 - 05:06 PM

Could you possibly show me a screenshot of SMAA switched on and off? Edit: Sorry you did already! Can you switch off any other AA you have, either in launcher, skyrimprefs.ini or through driver software and see if it still works?
  • 0

#27 dreadflopp

dreadflopp

    High King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,314 posts

Posted 19 March 2013 - 05:08 PM

Could you possibly show me a screenshot of SMAA switched on and off?


Previous page, screenshot 6 and 7
  • 0

#28 Garpov

Garpov

    Prisoner

  • Members
  • 27 posts

Posted 19 March 2013 - 05:09 PM

Sorry, i edited post above.
  • 0

#29 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 19 March 2013 - 05:14 PM

Dreadflopp, please double check posts before posting. Some of them are very confusing because you're mistakingly interchanging MSAA and SMAA. The launcher and INI is MSAA.

#30 dreadflopp

dreadflopp

    High King

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,314 posts

Posted 19 March 2013 - 05:15 PM

Could you possibly show me a screenshot of SMAA switched on and off?

Edit: Sorry you did already!

Can you switch off any other AA you have, either in launcher, skyrimprefs.ini or through driver software and see if it still works?

Screen 7 is only using SMAA through ENB. AA switched of in launcher/skyrimprefs (same thing) and catalyst control center set to Use application settings. So no other AA.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users