Jump to content


Photo

STEP v2.2.7 Official Bug Reports


  • This topic is locked This topic is locked
179 replies to this topic

#151 Nearox

Nearox

    High King

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,396 posts

Posted 24 October 2013 - 01:48 PM

Actually, what is meant is the load order and not the install order. If you dont install the patch, GDO will overwrite some stuff from W&A fixes. 
  • 0

#152 michaelrw

michaelrw

    STEP Contributor

  • Mod Authors
  • PipPipPipPipPipPip
  • 479 posts

Posted 24 October 2013 - 03:18 PM

Better Weapon Swings and Thundering Shout .ESPS are not needed? They are just blank and are used with the BSA file. If so it can be suggested to remove the .esps from both I would think. =)

yes definitely should be noted.
however, i know there is some reason that some authors choose to release mods with an empty ESP ... i think it has something to do with mod assets being packaged into a BSA .. i think its so the assets get loaded by the game?? .. but if you use MO and/or unpack your BSAs anyway, the need for the ESP is lost. 
  • 0

#153 Eliian

Eliian

    Commander

  • Members
  • PipPipPipPip
  • 203 posts

Posted 24 October 2013 - 03:31 PM

Better Weapon Swings and Thundering Shout .ESPS are not needed? They are just blank and are used with the BSA file. If so it can be suggested to remove the .esps from both I would think. =)

yes definitely should be noted.
however, i know there is some reason that some authors choose to release mods with an empty ESP ... i think it has something to do with mod assets being packaged into a BSA .. i think its so the assets get loaded by the game?? .. but if you use MO and/or unpack your BSAs anyway, the need for the ESP is lost. 

That is indeed true. Using MO the need to use the ESP is lost. I am not sure about the author of Thundering Shouts (besides obviously using a BSA file), but the BWS's author mentioned an interesting reason. This is what he said in the commnets

"In the past I had some problems with some people using my sounds in their mods (no Skyrim mods) without giving me credit or asking me. To avoid such things and excuses like "oh i didnt know they were yours" i put them into a BSA."
  • 0

#154 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 24 October 2013 - 03:38 PM

[quote name=''Nearox' pid='54865' dateline='1382640521']Actually' date=' what is meant is the load order and not the install order. If you dont install the patch, GDO will overwrite some stuff from W&A fixes. [/quote']
Oh ok. Thanks for clearing that up.

The language is still wrong though because GDO is installed BEFORE W&A Fixes


Just to confirm, is this supposed to be "THE INSTALL ORDER?"

Guard Dialogue Overhaul
W&A Fixes - Vanilla
W&A Fixes - Dragonborn
W&A - GDO Patch
aMidianBorn MAIN MOD FILE
W&A aMidianBorn SkyForge Patch
Improved Closefaced Helmets MAIN MOD
W&A Improved Closefaced Helmets Patch

Will BOSS sort the LOAD ORDER correctly?



EDIT: SORRY! I didn't realize that these only had ESPS, therefore the install order doesn't matter. My question then, is whether BOSS will sort these correctly or if I need to do it manually. Thanks!
  • 0

#155 Nearox

Nearox

    High King

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,396 posts

Posted 24 October 2013 - 04:03 PM

Yes it will :) if you wish to verify, load all those esps together in tes5edit and open the tree for W&A-GDO patch.  And the install order matters because ICH must be overwritten by the W&A-ICH patch, which you correctly did :P
  • 0

#156 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 24 October 2013 - 04:13 PM

Yes it will :)

if you wish to verify, load all those esps together in tes5edit and open the tree for W&A-GDO patch. 

And the install order matters because ICH must be overwritten by the W&A-ICH patch, which you correctly did :P


Why does the ICP patch have to be installed after the main mod? Isn't the patch just an esp?
  • 0

#157 michaelrw

michaelrw

    STEP Contributor

  • Mod Authors
  • PipPipPipPipPipPip
  • 479 posts

Posted 24 October 2013 - 05:04 PM

probably just a formality (unless the "patch" is actually a replacement).. if you know enough to understand that install order is (usually) irrelevant for esp-only mods, then you'll be fine
  • 0

#158 Nearox

Nearox

    High King

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,396 posts

Posted 24 October 2013 - 05:20 PM

No, the W&A-ICH patch has esps which overwrite the orignal esps from ICH. It's a strange way of patching things but that is how the author(s) of the patch choose to do it.  I guess they did it to reduce the amount of esps (else up to 4 additional patch asps would be loaded)

This file contains WAF-compatible versions of Improved Closefaced Helmets. These are replacement .esp files not patches. You MUST install Improved Closefaced Helmets first before overwriting the relevant .esp files. Support is included for the following files: Improved Closefaced Helmets--Full Set, Improved Dawnguard helmets, Guard Helmets--tighter eye holes, and Imperial helmet--no cloth around neck.


  • 0

#159 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 24 October 2013 - 05:25 PM

So I need to do the same thing with the amidianborn patch? GDP patch is fine since w&a fixes is already after GDo right? Can we make the notes clearer?
  • 0

#160 Nearox

Nearox

    High King

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,396 posts

Posted 24 October 2013 - 05:35 PM

It doesn't matter where you put the GDO and the Skyforge Patch. They are merely compatibility patches with independent esps that are automatically loaded by BOSS to the end of the load order (EDIT: to the correct place in the load order, not the end)

The only reason the W&A-ICH patch has to be moved further down in the install order behind ICH is because they have the same esp names.

These instructions are also on the mod page btw at the miscellaneous files section. 

If you want to know whether install order matters, it is really simple (in MO, cant speak for WB but it must have similar functionality): you just need to check the 'flags' column for any + or -, or you open up the mod in MO and check the conflicts tab. If it is empty (no flags) then install order does not matter at all. 
  • 0

#161 DoYouEvenModBro

DoYouEvenModBro

    Dragon Prince

  • Members
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,298 posts

Posted 24 October 2013 - 05:40 PM

It doesn't matter where you put the GDO and the Skyforge Patch. They are merely compatibility patches with independent esps that are automatically loaded by BOSS to the end of the load order (EDIT: to the correct place in the load order, not the end)

The only reason the W&A-ICH patch has to be moved further down in the install order behind ICH is because they have the same esp names.

These instructions are also on the mod page btw at the miscellaneous files section. 

If you want to know whether install order matters, it is really simple (in MO, cant speak for WB but it must have similar functionality): you just need to check the 'flags' column for any + or -, or you open up the mod in MO and check the conflicts tab. If it is empty (no flags) then install order does not matter at all. 



Thanks! Can a mod move this all to the W&A fixes thread?
  • 0

#162 michaelrw

michaelrw

    STEP Contributor

  • Mod Authors
  • PipPipPipPipPipPip
  • 479 posts

Posted 25 October 2013 - 02:40 AM

im unsure whether someone has mentioned this, but the plugin for Dragons Shout with Voice is an blank plugin
  • 0

#163 Eliian

Eliian

    Commander

  • Members
  • PipPipPipPip
  • 203 posts

Posted 26 October 2013 - 06:42 AM

[quote name=''michaelrw' pid='54989' dateline='1382686842']im unsure whether someone has mentioned this' date=' but the plugin for Dragons Shout with Voice is an blank plugin[/quote']
It actually isn't. It overwrites the Dialog Topic so dragons actually use shouts as well as sound off from their location. Basically, the optional file needs the ESP and since STEP recommends it should stay.

True though that the base version of the mod does not need it. If we didn't use the optional file it wouldn't matter anyway since we would recommend the loose files version. It doesn't contain an ESP in the first place in that case. =)
  • 0

#164 michaelrw

michaelrw

    STEP Contributor

  • Mod Authors
  • PipPipPipPipPipPip
  • 479 posts

Posted 27 October 2013 - 07:21 PM

[quote='Eliian' pid='55115' dateline='1382787721']
[quote name=''michaelrw' pid='54989' dateline='1382686842']im unsure whether someone has mentioned this' date=' but the plugin for Dragons Shout with Voice is an blank plugin[/quote']
It actually isn't. It overwrites the Dialog Topic so dragons actually use shouts as well as sound off from their location. Basically, the optional file needs the ESP and since STEP recommends it should stay.

True though that the base version of the mod does not need it. If we didn't use the optional file it wouldn't matter anyway since we would recommend the loose files version. It doesn't contain an ESP in the first place in that case. =)[/quote]
ok, i mean, i cant argue with what you said but clearly we must be talking about two different ESPs because the plugin i opened up was, without a doubt, empty and record-free
  • 0

#165 Eliian

Eliian

    Commander

  • Members
  • PipPipPipPip
  • 203 posts

Posted 27 October 2013 - 08:58 PM

[quote='michaelrw' pid='55310' dateline='1382919705']
[quote='Eliian' pid='55115' dateline='1382787721']
[quote name=''michaelrw' pid='54989' dateline='1382686842']im unsure whether someone has mentioned this' date=' but the plugin for Dragons Shout with Voice is an blank plugin[/quote']
It actually isn't. It overwrites the Dialog Topic so dragons actually use shouts as well as sound off from their location. Basically, the optional file needs the ESP and since STEP recommends it should stay.

True though that the base version of the mod does not need it. If we didn't use the optional file it wouldn't matter anyway since we would recommend the loose files version. It doesn't contain an ESP in the first place in that case. =)[/quote]
ok, i mean, i cant argue with what you said but clearly we must be talking about two different ESPs because the plugin i opened up was, without a doubt, empty and record-free[/quote]
Maybe download the optional file and check it for yourself? They have the same name. Not two separate esps. The main file's esp is indeed record-free =) As you said. Didn't mean to argue that sorry.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users