Jump to content


Photo

Editing Privileges


  • Please log in to reply
25 replies to this topic

#16 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,082 posts

Posted 09 March 2014 - 12:37 PM

is this resolved?



#17 stoppingby4now

stoppingby4now

    Sleepy

  • Founder
  • PipPipPipPipPipPip
  • 2,419 posts

Posted 09 March 2014 - 12:43 PM

I fixed this yesterday for Tech, but others may be affected.


  • 0

#18 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,082 posts

Posted 09 March 2014 - 06:23 PM

Is there a way to identify or should we make this more prominent for those that may be impacted?

 

Also, how should one go about verifying whether this issue applies to them or not?



#19 phazer11

phazer11

    High King

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 3,110 posts

Posted 09 March 2014 - 08:08 PM

As I said I don't have editing privledges.


  • 0

#20 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,082 posts

Posted 09 March 2014 - 09:17 PM

I fixed this yesterday for Tech, but others may be affected.

What is the 'fix', and what is the cause?



#21 stoppingby4now

stoppingby4now

    Sleepy

  • Founder
  • PipPipPipPipPipPip
  • 2,419 posts

Posted 09 March 2014 - 11:18 PM

I have only found a few users so far and corrected them. The majority seem to be just fine. A sure fire way to tell for any user would be if they have edited their user page, but suddenly it appears blank when they visit it. Second would be to search for any edits they have done, and they will seem to have vanished. If none of the above apply, they will never know if they are/were affected.

 

The cause is I'm now enforcing username case to be matched with what is in the forum via the Auth IPB plugin. I wasn't doing this with the AuthMyBB plugin, which was an oversight and the case as applied on initial creation was matched with whatever the user typed in to login for the first time. However, that causes problems. I first became aware of it while testing when I noticed there were two users for the compiler. One titled Thecompiler, and one titled TheCompiler. That's not good, and I have fixed that from occurring again.


  • 0

#22 Neovalen

Neovalen

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,593 posts

Posted 10 March 2014 - 12:49 AM

@Tech

You have the correct group assignment. I will try and do some more digging, but you should have access.

 

For External Edit, it still works for me (using XExternalEditor). I have had a couple occasions where the ini file it generates somehow became corrupt, and deleting it and letting it recreate fixed the issue. The file will be located in %USERPROFILE%XExternalEditorwiki_step-project_com.ini

Tried this and was still not able to edit successfully using XExternalEditor... I was able to load the page fine in notepad++ but saving failed with the following message:

View source for User:Neovalen/Skyrim Revisited - Legendary Edition

You do not have permission to edit this page, for the following reasons:

  • The action you have requested is limited to users in the group: Users.
  • You must confirm your email address before editing pages. Please set and validate your email address through your user preferences.

Obviously I'm a user and I've already confirmed my email before...


  • 0

#23 stoppingby4now

stoppingby4now

    Sleepy

  • Founder
  • PipPipPipPipPipPip
  • 2,419 posts

Posted 10 March 2014 - 01:28 AM

For some reason today, I can't edit now. XExternalEditor loads, then throws an exception: "Edit time not found in HTML document". That was one of the errors I used to get with a corrupt ini file, but not helping this time. Based on the page history, it looks like you can at least edit normally via the Wiki. I'm not finding any cause as to why you would get that error, but still digging.

 

However, as a heads up, version 1.22 of MediaWiki has completely removed the ExternalEdit functionality. When we upgrade, that capability will be lost.


  • 0

#24 Neovalen

Neovalen

    Talos

  • Mod Author
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,593 posts

Posted 10 March 2014 - 02:00 AM

Well that sucks... it was really nice when doing large find/replace or adding large amounts of data. Sent from my XT907 using Tapatalk
  • 0

#25 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 13,040 posts

Posted 10 March 2014 - 09:51 AM

You can always do a page edit, copy & paste the page in your external editor, and when finished edit the page again to copy & paste your edited version. Might not be ideal but it works for when you need to do things like find & replace.



#26 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,082 posts

Posted 11 March 2014 - 01:13 AM

I have always found xTernalEditor to be clunky and potentially life killing. I recall several time doing large edits that required 30 minutes or more and losing my session and all of my edits. I will not missit, as I don't think it ever worked seamlessly enough. I agree with tech that a simple workaround is to manually use an external editor. one problem I have seen is the addition of line breaks at every n after pasting manually.

 

Visual Editor development is still progressing though. We may even have it by 2015. Flow is another one that looks nice.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users