Jump to content


Photo

SKSE with older Skyrim versions


  • Please log in to reply
15 replies to this topic

#1 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 03 July 2012 - 11:47 PM

hey guys! i found out that somehow skse doesn't work anymore with older patches (they just don't want to support them I guess and block them totally...) if you've upgraded to a newer patch. Any other/further information? I just replaced the skyrim folder with my 1.5.26 backup and couldn't find any method how to get skse (older versions of it of course) to work again... weeeeeird isn't it?
  • 0

#2 Farlo

Farlo

    Dragon Prince

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,677 posts

Posted 04 July 2012 - 12:23 AM

That is pretty weird! I'd have thought the archived versions were in their original state, perhaps it's worth a dig through the source code to see if it was on purpose?
  • 0

#3 frihyland

frihyland

    Dwemer Lord

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,087 posts

Posted 04 July 2012 - 12:39 AM

Thats because they directly inject code into the TESV.exe, it only works on the specific TESV.exe it is compiled for. To be more specific each SKSE only works with the TESV.exe it was compiled with, thats why the SKSE release versions are matched exactly to the same Skyrim version numbers.
  • 0

#4 Farlo

Farlo

    Dragon Prince

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,677 posts

Posted 04 July 2012 - 12:44 AM

Torminater is saying that he's using a backed up 1.5 version of Skyrim (and thus a 1.5 version of TESV.exe), so the version numbers should check out between the two unless you let Steam get a hold of it and partially update.
  • 0

#5 frihyland

frihyland

    Dwemer Lord

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,087 posts

Posted 04 July 2012 - 12:47 AM

You will need to run the SKSE version that was compiled for TESV.exe 1.5 then, that would be SKSE 1.5
  • 0

#6 Farlo

Farlo

    Dragon Prince

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,677 posts

Posted 04 July 2012 - 01:03 AM

He already said he was using the compatible version...
  • 0

#7 stoppingby4now

stoppingby4now

    Sleepy

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 04 July 2012 - 01:33 AM

hey guys!
i found out that somehow skse doesn't work anymore with older patches (they just don't want to support them I guess and block them totally...) if you've upgraded to a newer patch. Any other/further information?

As Fri stated, they use DLL injection, and Beth now encrypts the exe (which is decrypted at runtime). In order to properly inject, they have to update to match the new EXE.

I just replaced the skyrim folder with my 1.5.26 backup and couldn't find any method how to get skse (older versions of it of course) to work again...
weeeeeird isn't it?

Go here and click on the archived builds link. The version you want is skse_1_05_05.7z.
  • 0

#8 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 04 July 2012 - 04:33 AM

sry, i have to tell you, that i did used an old skse but it told me to update to the latest SKYRIM PATCH and not to update skse or sth like that and that archived build was from... the 4th of may. AND their archived builds all rely on papyrus scripting now. if you get what I'm saying: the archived builds are not the same as they were as they were the up to date builds...


edit; sry, forget that only the 1.5 builds are with papyrus scripting... I'm going to try 1.5.5 out again asap.
  • 0

#9 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 04 July 2012 - 09:25 AM

OK, so testing is running right now. It may be that SKSE checks the savegames and if there is a savegame from a NEWER patch than supported but the game version is older than the patch it errors: please update Skyrim to the newest version. So I deleted all new savegames and am checking it out as soon as skyrim files are copied.
  • 0

#10 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 04 July 2012 - 09:33 AM

OK just verified everything: What have I done? - saved skyrim folder version 1.6 backup - deleted skyrim folder - copied skyrim folder version 1.5 from backup into common folder (steam) - replaced MyGames Skyrim folder with 1.5 backup (after deleting the 1.6 skyrim folder here, too) - INSTALLED SKSE 1_05_05 Launched Game via skse ERROR "Please update to the latest version of Skyrim." -> Game doesn't launch. Possible cause: skse uses steam to check whether skyrim version is up to date, if steam reports back it isn't skse blocks of. Possible fix: Offline mode for steam, which currently mirracliously won't work on my laptop. No current fix for this issue out there. Any other suggestions?
  • 0

#11 frihyland

frihyland

    Dwemer Lord

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,087 posts

Posted 04 July 2012 - 10:49 AM

try again without using any skse mods, just launching from skse and show us your skse log.
  • 0

#12 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 04 July 2012 - 11:37 AM

I was using an absolutely clean vanilla install! There is just no way anything could be interfering with this...
  • 0

#13 stoppingby4now

stoppingby4now

    Sleepy

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 04 July 2012 - 01:41 PM

I know for a fact that 1.05.05 SKSE works with 1.5.26. It doesn't check saved games, all it does is inject a DLL into TESV.exe. If it's giving you those errors, then something is suspect with your backup.

Double check its version. Right click on TESV.exe and select Properties. Then click the Details tab and verify the Product version is 1.5.26.0.

Also post your skse_loader.log file.

EDIT:

Possible cause: skse uses steam to check whether skyrim version is up to date, if steam reports back it isn't skse blocks of.

Not a cause at all. I'm still using Skyrim 1.5.26, and can still launch with SKSE 1.05.05 just fine. Steam always online.
  • 0

#14 torminater

torminater

    Dragon Prince

  • Contributors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,222 posts

Posted 04 July 2012 - 02:34 PM

TESV.exe is skyrim 1.5.24??? o_O weird stuff there...
  • 0

#15 stoppingby4now

stoppingby4now

    Sleepy

  • Site Founders
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,281 posts

Posted 04 July 2012 - 05:23 PM

In that case you want SKSE version 1.4.14.
  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users