Jump to content


Photo

Archive Invalidation not working


Best Answer walterAgator , 14 June 2014 - 03:09 PM

My problem is solved. After hours of searching, head scratching and trying 4 different versions of MO including v1.2.4 (which looks interesting but is not quit ready for primetime). Turns out it wasn't Archive Invalidation. The problem was an incompatability with 2 mods, Roberts Male Body with Fallout New Vegas Redesigned 2. Roberts Male Body Nexus page descibes what I was seeing, namely black bars on the body as archive invalidation not working. But....

Roberts uses a custom nif for upperbody.nif, which in turn uses a custom upperbodymale.dds. The body parts are laid out in a different pattern within the dds file. Fallout New Vegas Redesigned 2 uses the vanilla nif and dds layout. So when installing Roberts before FNVR2 MO/FNV uses Roberts' upperbody.nif and FNVR2's upperbodymale.dds resulting in what looks the same as Archive Invalidation. Simply hiding FNVR2's upperbodymale*.dds files fixes this. Hope this helps someone else who might be fighting the same problem.

Thanks very much for your assistance.

Go to the full post


  • Please log in to reply
37 replies to this topic

#1 OrdinaryM

OrdinaryM

    Thane

  • Citizen
  • 72 posts

Posted 07 June 2014 - 11:45 PM

Just as the title says Archive Invalidation simply does not work. It's ticked on the profile and the ini's are correct but it still won't load texture mods. Any sort of possible fix would be helpful. Thank you.


  • 0

#2 OrdinaryM

OrdinaryM

    Thane

  • Citizen
  • 72 posts

Posted 08 June 2014 - 10:57 AM

bump


  • 0

#3 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 08 June 2014 - 11:32 AM

I'll take some time to look into this. I imagine with MO beta testing going on at the moment, most the MO guys are tied up.


  • 0

#4 OrdinaryM

OrdinaryM

    Thane

  • Citizen
  • 72 posts

Posted 08 June 2014 - 11:44 AM

I'll take some time to look into this. I imagine with MO beta testing going on at the moment, most the MO guys are tied up.

Much appreciated however sadly this has put my progress in the guide to a complete stop until I or someone can figure this out. I've tried just about everything possible, I even completely disabled UAC and still no luck. Hope this is solved soon.


  • 0

#5 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 08 June 2014 - 11:54 AM

Well, is the Steam directory in C:/ or C:/Program Files? Is Windows 8.1 UAC for all of the folders or only Program Files?


  • 0

#6 OrdinaryM

OrdinaryM

    Thane

  • Citizen
  • 72 posts

Posted 08 June 2014 - 12:03 PM

Well, is the Steam directory in C:/ or C:/Program Files? Is Windows 8.1 UAC for all of the folders or only Program Files?

Steam Directory is in C:/Program Files and game is in D:/ (This also might be part of the issue) and UAC controls everything.


Edited by OrdinaryM, 08 June 2014 - 12:06 PM.

  • 0

#7 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 08 June 2014 - 12:12 PM

Can you at least make the INIs write able? Can you go to your MO folder and look at the profiles folder and make sure that it is write able?

 

Open the INI editor in MO and make sure that bEnableFileSelection=1 is set in falloutprefs.ini under [launcher], I know that is the first thing people should check, but sometimes weird things happen and gets reverted.


  • 0

#8 OrdinaryM

OrdinaryM

    Thane

  • Citizen
  • 72 posts

Posted 08 June 2014 - 12:18 PM

Can you at least make the INIs write able? Can you go to your MO folder and look at the profiles folder and make sure that it is write able?

 

Open the INI editor in MO and make sure that bEnableFileSelection=1 is set in falloutprefs.ini under [launcher], I know that is the first thing people should check, but sometimes weird things happen and gets reverted.

All of my ini's under the profile are writable however under the archive section the archive list looks a bit odd (not right) could you post what yours looks like? And yes benablefileselection is set to 1 in my prefs. Another thing I thought that could have been causing this is that FNV wasn't loading loose files because that option in the launcher is disabled and when I try to check it after I close the window it unchecks itself again.


Edited by OrdinaryM, 08 June 2014 - 12:21 PM.

  • 0

#9 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 08 June 2014 - 12:21 PM

Here's what my section look like:

[Archive]SInvalidationFile = iRetainFilenameOffsetTable = 1iRetainFilenameStringTable = 1iRetainDirectoryStringTable = 1bCheckRuntimeCollisions = 0bInvalidateOlderFiles = 1bUseArchives = 1SArchiveList = Fallout - Invalidation.bsa, Fallout - Textures.bsa, Fallout - Textures2.bsa, Fallout - Meshes.bsa, Fallout - Voices1.bsa, Fallout - Sound.bsa,  Fallout - Misc.bsa

That Fallout - Invalidation.bsa is the important one. It may also be something like Fallout - AI!.bsa.


  • 0

#10 OrdinaryM

OrdinaryM

    Thane

  • Citizen
  • 72 posts

Posted 08 June 2014 - 12:26 PM

Here's what my section look like:

[Archive]SInvalidationFile = iRetainFilenameOffsetTable = 1iRetainFilenameStringTable = 1iRetainDirectoryStringTable = 1bCheckRuntimeCollisions = 0bInvalidateOlderFiles = 1bUseArchives = 1SArchiveList = Fallout - Invalidation.bsa, Fallout - Textures.bsa, Fallout - Textures2.bsa, Fallout - Meshes.bsa, Fallout - Voices1.bsa, Fallout - Sound.bsa,  Fallout - Misc.bsa

That Fallout - Invalidation.bsa is the important one. It may also be something like Fallout - AI!.bsa.

Copied that list to my ini and still no luck. Is MO supposed to create a bsa? And if it is what does that bsa look like in the data tab?


  • 0

#11 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 08 June 2014 - 12:36 PM

Yeah, it should be Fallout - Invalidation.bsa and it will be in the data folder.


  • 0

#12 OrdinaryM

OrdinaryM

    Thane

  • Citizen
  • 72 posts

Posted 08 June 2014 - 12:39 PM

Yeah, it should be Fallout - Invalidation.bsa and it will be in the data folder.

I do have that https://puu.sh/9kvYq/992c65a0e6.png

But I also have this, any idea what this is? https://puu.sh/9kvZl/49cfddbc5d.png


  • 0

#13 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 08 June 2014 - 12:53 PM

I have both. It works fine for me. I just think that you game directory being read only could be the issue. I've have that problem and making the whole directory write able was the solution. I'd just try to figure out the way to turn off UAC and make that folder write able. We may have exhausted every other thing possible that it could be. 


  • 0

#14 OrdinaryM

OrdinaryM

    Thane

  • Citizen
  • 72 posts

Posted 08 June 2014 - 01:07 PM

I have both. It works fine for me. I just think that you game directory being read only could be the issue. I've have that problem and making the whole directory write able was the solution. I'd just try to figure out the way to turn off UAC and make that folder write able. We may have exhausted every other thing possible that it could be. 

In your read only check box for the folder is it completely blank or is it partially filled in with a box?

This is mine - https://puu.sh/9kykB/df3ca93419.png Which means it only applies to files in that folder.


  • 0

#15 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 08 June 2014 - 01:10 PM

Mine is uncheck for my MO directory, fallout directory, and the FNV folder in my documents/my games folder. I was having issues with it and just made sure every file was write able.

 

I just untick the box and a pop up would show that asked if I wanted to do it for every file in the folder. Click yes and let it go through the whole thing, takes a while for the Fallout folder and MO folder. Maybe UAC should just be turned off for you, I think it is done in the Control Panel.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users