Jump to content


Photo

Archive Invalidation not working


Best Answer walterAgator , 14 June 2014 - 03:09 PM

My problem is solved. After hours of searching, head scratching and trying 4 different versions of MO including v1.2.4 (which looks interesting but is not quit ready for primetime). Turns out it wasn't Archive Invalidation. The problem was an incompatability with 2 mods, Roberts Male Body with Fallout New Vegas Redesigned 2. Roberts Male Body Nexus page descibes what I was seeing, namely black bars on the body as archive invalidation not working. But....

Roberts uses a custom nif for upperbody.nif, which in turn uses a custom upperbodymale.dds. The body parts are laid out in a different pattern within the dds file. Fallout New Vegas Redesigned 2 uses the vanilla nif and dds layout. So when installing Roberts before FNVR2 MO/FNV uses Roberts' upperbody.nif and FNVR2's upperbodymale.dds resulting in what looks the same as Archive Invalidation. Simply hiding FNVR2's upperbodymale*.dds files fixes this. Hope this helps someone else who might be fighting the same problem.

Thanks very much for your assistance.

Go to the full post


  • Please log in to reply
37 replies to this topic

#16 OrdinaryM

OrdinaryM

    Citizen

  • Members
  • Pip
  • 72 posts

Posted 08 June 2014 - 01:24 PM

Mine is uncheck for my MO directory, fallout directory, and the FNV folder in my documents/my games folder. I was having issues with it and just made sure every file was write able.

 

I just untick the box and a pop up would show that asked if I wanted to do it for every file in the folder. Click yes and let it go through the whole thing, takes a while for the Fallout folder and MO folder. Maybe UAC should just be turned off for you, I think it is done in the Control Panel.

Well I have completely disabled UAC (even in the registry) and as soon as I uncheck it and it does the process and close the window it goes back to read only. Really not sure what the issue is since my SR:LE textures work fine. 


  • 0

#17 walterAgator

walterAgator

    Prisoner

  • Members
  • 13 posts

Posted 13 June 2014 - 03:09 PM

I seem to be having trouble with Archive Invalidation as well. I have installed from EssArrBee's "Fear and Loathng...." guide. After searching the internet, I found this thread, and found I have done everything mentioned here. Curiously I tried opening the file Fallout - Invalidation.bsa in DDSOpt but it says something about sanity check failed for directory names. Clicking through the error messages the bsa still loads and shows a garbled dirctory name containing a file called ummy.dds. Disabling, deleting the bsa, and re-enabling the invalidation in the profile of MO doesn't fix it. Is this normal?

 

Also I don't have the file Fallout - AI!.bsa, where is that from?

 

Edit: Opps!! DDSOpt is not for FONV. Used FOMM instead. No errors. Shows ummy.dds as the only file.


Edited by walterAgator, 13 June 2014 - 04:44 PM.

  • 0

#18 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 13 June 2014 - 05:39 PM

I seem to be having trouble with Archive Invalidation as well. I have installed from EssArrBee's "Fear and Loathng...." guide. After searching the internet, I found this thread, and found I have done everything mentioned here. Curiously I tried opening the file Fallout - Invalidation.bsa in DDSOpt but it says something about sanity check failed for directory names. Clicking through the error messages the bsa still loads and shows a garbled dirctory name containing a file called ummy.dds. Disabling, deleting the bsa, and re-enabling the invalidation in the profile of MO doesn't fix it. Is this normal? Also I don't have the file Fallout - AI!.bsa, where is that from? Edit: Opps!! DDSOpt is not for FONV. Used FOMM instead. No errors. Shows ummy.dds as the only file.

Are you also using windows 8?

#19 OrdinaryM

OrdinaryM

    Citizen

  • Members
  • Pip
  • 72 posts

Posted 13 June 2014 - 05:49 PM

I still have had no help here except from EAB. Would really appreciate some help with someone over at MO because this is their official support forum. I feel like I am being ignored since it doesn't involve Skyrim in anyway.


  • 0

#20 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,650 posts

Posted 13 June 2014 - 06:24 PM

The thing is, I don't know much about archive invalidation, and really can't troubleshoot it since I don't have FONV. The other guys who knew about that seem rather sporadic in posting.



#21 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 13 June 2014 - 06:44 PM

I still have had no help here except from EAB. Would really appreciate some help with someone over at MO because this is their official support forum. I feel like I am being ignored since it doesn't involve Skyrim in anyway.

Have you tried MO v1.2.4? I think it is only linked to in the MO v1.2.2 beta thread for testing.

 

EDIT: I want to add this to the bug tracker, but I'm having trouble wording it correctly. Any insight to what I would add is appreciated.



#22 OrdinaryM

OrdinaryM

    Citizen

  • Members
  • Pip
  • 72 posts

Posted 13 June 2014 - 07:10 PM

Have you tried MO v1.2.4? I think it is only linked to in the MO v1.2.2 beta thread for testing.

 

EDIT: I want to add this to the bug tracker, but I'm having trouble wording it correctly. Any insight to what I would add is appreciated.

Well that worked. That actually worked. I'm not sure why that worked but it did. It was no UAC issue or read only file issue I just needed to update the damn program. Well I can't thankyou enough EAB because I probably would have given up. I would definitely mention this somewhere at the bottom of the guide because it seems like this issue has plagued more than one. Unfortunately we figured this out during exams for me. I'll probably start the guide process later tonight after studying. Once the guides completed and getting everything set up I'll be more than welcome to help you with anything such as testing or ini tweaks (Because that part of the guide still needs to get going). Just glad this curse is gone too bad it didn't happen before the hours of scouring forums

                            Thanks again

                                                   - oM


Edited by OrdinaryM, 13 June 2014 - 07:10 PM.

  • 0

#23 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 13 June 2014 - 07:31 PM

What version(s) of MO did you try? I need to know which don't work for you because I've never had that particular issue with Windows 7.



#24 OrdinaryM

OrdinaryM

    Citizen

  • Members
  • Pip
  • 72 posts

Posted 13 June 2014 - 07:38 PM

What version(s) of MO did you try? I need to know which don't work for you because I've never had that particular issue with Windows 7.

1.1.1, 1.1.2, 1.2.1,1.2.2. I believe that's them. I didn't try 1.2.3 I skipped straight to 1.2.4.
  • 0

#25 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 13 June 2014 - 07:55 PM

If you used 1.2.2 then you may have seem the BSA handling changes. You should read through the beta thread to see what is different and how to use it, since I may not time to go over that. That is only if haven't figured it out on your own yet.



#26 OrdinaryM

OrdinaryM

    Citizen

  • Members
  • Pip
  • 72 posts

Posted 13 June 2014 - 08:55 PM

Not sure which thread it is all I could find was the 1.2.x thread which didn't have much. If you know what it is and don't mind writing me a tl;dr on it that would be great. Do you think it will affect my installation of the guide at all?

 

EDIT: well from what I found out is that BSA priority is now a thing? Can't I just not have MO manage BSA's and replicate previous versions of MO BSA handling?


Edited by OrdinaryM, 13 June 2014 - 09:03 PM.

  • 0

#27 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 13 June 2014 - 09:31 PM

It handles BSAs the same as before but now treats DLC as a mod (in a way) or any mod installed in the data folder instead of with MO will be handled as a mod you can't untick in the left pane. You can move them around to reorder them if need, this is mostly for Skyrim since the unofficial patches need to be between the DLC. It also allows optimized textures to be handled correctly so they are between DLC.

 

Basic idea:

  • Fallout Textures Optimized (Fallout is required to be loaded first and not listed in the left pane)
  • Dead Money
  • Dead Money Textures Optimized
  • Honest Hearts
  • Honest Hearts Textures Optimized
  • ... other DLC
  • Other mods

This only matters if you end optimizing textures or if you use MO for Skyrim. Otherwise just put the DLC at the top in the correct order. So in 0, 1, 2, 3, 4... of the left pane priority.



#28 OrdinaryM

OrdinaryM

    Citizen

  • Members
  • Pip
  • 72 posts

Posted 13 June 2014 - 09:50 PM

Got it thanks again EAB. The only issue I ran into was with the handler, it wasn't taking the nxm link so I just replaced the handler with a previous version. (You can't even open nxmhandler.exe with the new beta) You get some weird permission error. I should probably put this in for the bug tracker.


  • 0

#29 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 13 June 2014 - 10:03 PM

It should carry over your file handler even if overwritten, don't why that didn't happen. Also, it's 'SRB'.  ::P:

 

You seem to have some serious permission issue with this game.



#30 walterAgator

walterAgator

    Prisoner

  • Members
  • 13 posts

Posted 13 June 2014 - 10:10 PM

Are you also using windows 8?

Sorry forgot to mention Windows 7 64bit.

Going to look for MO ver. 1.2.4, maybe that is what I need also.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users