Jump to content


Photo

Archive Invalidation not working


Best Answer walterAgator , 14 June 2014 - 03:09 PM

My problem is solved. After hours of searching, head scratching and trying 4 different versions of MO including v1.2.4 (which looks interesting but is not quit ready for primetime). Turns out it wasn't Archive Invalidation. The problem was an incompatability with 2 mods, Roberts Male Body with Fallout New Vegas Redesigned 2. Roberts Male Body Nexus page descibes what I was seeing, namely black bars on the body as archive invalidation not working. But....

Roberts uses a custom nif for upperbody.nif, which in turn uses a custom upperbodymale.dds. The body parts are laid out in a different pattern within the dds file. Fallout New Vegas Redesigned 2 uses the vanilla nif and dds layout. So when installing Roberts before FNVR2 MO/FNV uses Roberts' upperbody.nif and FNVR2's upperbodymale.dds resulting in what looks the same as Archive Invalidation. Simply hiding FNVR2's upperbodymale*.dds files fixes this. Hope this helps someone else who might be fighting the same problem.

Thanks very much for your assistance.

Go to the full post


  • Please log in to reply
37 replies to this topic

#31 OrdinaryM

OrdinaryM

    Citizen

  • Members
  • Pip
  • 72 posts

Posted 13 June 2014 - 10:31 PM

Sorry forgot to mention Windows 7 64bit.

Going to look for MO ver. 1.2.4, maybe that is what I need also.

https://sourceforge..../?source=navbar


  • 0

#32 EssArrBee

EssArrBee

    Incompatibilism Manager

  • STEP Staff
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,721 posts

Posted 13 June 2014 - 11:02 PM

Did you use the EXE or archive OrdinaryM?



#33 OrdinaryM

OrdinaryM

    Citizen

  • Members
  • Pip
  • 72 posts

Posted 13 June 2014 - 11:44 PM

Did you use the EXE or archive OrdinaryM?

I believe I used archive but I'm not 100% sure. I usually try to use archives.


  • 0

#34 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,650 posts

Posted 14 June 2014 - 05:19 AM

nxmhandler.exe runs fine for me. I think that you need a better setup than turning DEP, UAC, and antivirus off. I work with these things on and have little trouble. Just know where you need to give something better permissions.



#35 walterAgator

walterAgator

    Prisoner

  • Members
  • 13 posts

Posted 14 June 2014 - 03:09 PM   Best Answer

My problem is solved. After hours of searching, head scratching and trying 4 different versions of MO including v1.2.4 (which looks interesting but is not quit ready for primetime). Turns out it wasn't Archive Invalidation. The problem was an incompatability with 2 mods, Roberts Male Body with Fallout New Vegas Redesigned 2. Roberts Male Body Nexus page descibes what I was seeing, namely black bars on the body as archive invalidation not working. But....

Roberts uses a custom nif for upperbody.nif, which in turn uses a custom upperbodymale.dds. The body parts are laid out in a different pattern within the dds file. Fallout New Vegas Redesigned 2 uses the vanilla nif and dds layout. So when installing Roberts before FNVR2 MO/FNV uses Roberts' upperbody.nif and FNVR2's upperbodymale.dds resulting in what looks the same as Archive Invalidation. Simply hiding FNVR2's upperbodymale*.dds files fixes this. Hope this helps someone else who might be fighting the same problem.

Thanks very much for your assistance.


  • 0

#36 Bael

Bael

    Prisoner

  • Members
  • 6 posts

Posted 17 June 2014 - 11:20 PM

I had the same issue as the others. No matter what method I used I couldn't get the ArchiveInvalidation to take. I tried MO ver. 1.2.4 and it worked just fine.
 
I used the manual version of this and loaded it as a mod into the organizer.
 
https://www.nexusmod...llout3/mods/944
 
I edited the Fallout.ini, Falloutprefs.ini, and the Fallout_Default.ini as follows:
 


[Archive]
SInvalidationFile = 
iRetainFilenameOffsetTable = 1
iRetainFilenameStringTable = 1
iRetainDirectoryStringTable = 1
bCheckRuntimeCollisions = 0
bInvalidateOlderFiles = 1
bUseArchives = 1
SArchiveList = Fallout - ArchiveInvalidation.bsa, Fallout - Voices1.bsa, Fallout - Textures.bsa, Fallout - Textures2.bsa, Fallout - Meshes.bsa, Fallout - Sound.bsa, Fallout - Misc.bsa

 
I also went ahead and made my MO folder writable.
 
Now I have the bodies and the textures just how I want them.


Edited by EssArrBee, 12 July 2015 - 09:21 PM.

  • 0

#37 oqhansoloqo

oqhansoloqo

    High King

  • Staff
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,398 posts

Posted 23 June 2014 - 04:51 PM

For me, the solution with 1.2.1 was either of these two things (not sure which actually did it because I didn't test each one individually):

 

1. made my entire Fallout directory writable, because some things were marked read-only.

 

2. ran MO with administrative privileges.


  • 0

#38 MeanJim

MeanJim

    Prisoner

  • Members
  • 6 posts

Posted 12 July 2015 - 07:55 PM

I was having the same exact problem, and searching for a solution this was the top result.  I'm using Mod Organizer version 1.3.8, but nothing here helped me. 

 

After hours of searching for a fix, and trying everything I could think of I finally fixed it. I verified the game cache. I deleted my .ini files and generated new ones. I deleted Mod Organizer and started from scratch. None of that worked.

I found several other forum posts of people that had the same problem, but nobody ever replied back on if/how they fixed it.  Since this is the top result when searching for the problem, I'm posting my solution here just in case someone out there runs into this problem and can't find a fix. Hopefully you will find this post and I can save you hours of frustration and a headache.

For me it was Mod Organizer. On the Archives tab, it defaults to "Have MO Manage Archives," but apparently it wasn't properly set. I disabled it, tried to start FNV, but I just got a black screen. I re-enabled the setting but all of the .bsa files were unchecked.  Trying to start FNV still led to a black screen.  After re-checking all of the .bsa files, it finally worked!


  • 2


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users