Jump to content


Photo

Question about creating a FOMOD Installer

fomod script installation

  • Please log in to reply
6 replies to this topic

#1 kryptopyr

kryptopyr

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 738 posts

Posted 19 June 2014 - 06:20 PM

I'm working on a FOMOD installer for Weapons & Armor Fixes, and I've run into a question that I've not been able to find an answer for.  Depending on certain flags, I would like the installer to overwrite a file installed in a previous step with a different file (the two files have identical file names). 

 

Basically, I have it set up so that in the first step, the user chooses which DLCs they have.  If they select both Dawnguard and Dragonborn, then the "WAF Complete" file is installed instead of the individual files.  The second installation step asks the user to choose which options they would like.  If they select all three options that are included in the "WAF Complete Plus" file, then this file version needs to be installed instead of the first one.  However, I just can't get this to work.

 

I've tried using the 'priority' tags, but either I don't understand how they work (a very real possibility) or else they're simply not doing anything.  I attached the installer script if anyone cares to look at it.  This is my first time attempting to make an installer, and I've been slowly working through it and figuring things out.  I think I have everything else working properly, but this one issue has me stumped.  I've tried searching online, but I've not been able to find the right information.  Any help would be greatly appreciated.


  • 0

#2 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,639 posts

Posted 19 June 2014 - 06:53 PM

Mod Organizer fomod installer doesn't correctly handle priorities yet. Appears it might in the next version. https://issue.tannin...izer/issues/670



#3 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,658 posts

Posted 19 June 2014 - 07:19 PM

Yep, posted that bug report due to the same things happening with Better Shaped Weapons. Tannin got on top of it the same day he confirmed it. Must have been a quick fix. For now, you'll have to use the external installer (NCC).



#4 kryptopyr

kryptopyr

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 738 posts

Posted 19 June 2014 - 07:43 PM

So I am using the priorities correctly then?  Files with low priority numbers should be getting overwritten by files with higher priority numbers?


  • 0

#5 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,658 posts

Posted 19 June 2014 - 08:05 PM

Yep. Just like in MO. A priority of 2 will overwrite a priority of 1. Idk what Tannin is doing to fix this. We share wait and see.



#6 kryptopyr

kryptopyr

    Jarl

  • Mod Authors
  • PipPipPipPipPipPipPipPipPip
  • 738 posts

Posted 19 June 2014 - 08:11 PM

Great!  Thank you!  I'm glad to hear that it's a known issue and that there's already a solution in the works.  


  • 0

#7 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,658 posts

Posted 24 June 2014 - 06:08 PM

Try out your FOMOD with MO v1.2.5. Tannin has fixed some issues with the internal installer and it's now installing the mods that had these issues previously.





Also tagged with one or more of these keywords: fomod, script, installation

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users