Jump to content


Photo

The War on Microstutter/Input Lag

microstutter input lag fix build

  • Please log in to reply
9 replies to this topic

#1 Breems

Breems

    Prisoner

  • Members
  • 46 posts

Posted 11 August 2014 - 09:26 PM

I've tried every combination of VSync/Triple Buffering/FPS Limiters/RenderAheadLimit/Borderless Window settings that exists, and I haven't been able to make this issue even budge. Even turning VSync completely off in every possible way doesn't resolve the issue, which especially confuses me.

 

To be sure I'm talking about the correct problem, I'm referencing when you obtain a high FPS (typically indoors), and any movement of the mouse results in "jittering" as shown below:

 

 

Anyway, there's probably no point in posting my setup and attempted fixes as it will likely go nowhere. What I'd like to hear is:

  • Any success stories against this issue? Has anyone out there found a silver bullet fix that worked for their situation?
  • Is there anyone out there who hasn't experienced this issue at all? If so, I'd love to know your rig setup. I'll be buying/building a new PC soon, and this issue alone drives me mad enough to plan a build around fixing it.

  • 0

#2 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,964 posts

Posted 11 August 2014 - 09:32 PM

Nvidia card?



#3 Breems

Breems

    Prisoner

  • Members
  • 46 posts

Posted 11 August 2014 - 09:37 PM

Yep. GT 730m (laptop).

 

The game stays mostly above 45+ FPS outdoors, and GPU/CPU temps are fine, so I don't think this is due to hardware stress. Just engine quirks or something.


  • 0

#4 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,964 posts

Posted 11 August 2014 - 09:46 PM

Have you tried to lower the Pre-rendered frames from in Nvidia Inspector? Setting this parameter too high can sometimes cause mouse lag.



#5 CovertSlinky

CovertSlinky

    Commander

  • Members
  • PipPipPipPip
  • 252 posts

Posted 11 August 2014 - 09:51 PM

Hey, I have this same problem, I'm AMD, I use enb windowed fullscreen mode with fps limiter. And when I go into interiors, and then jittery camera movement annoys too much, I use enb's hotkey to turn off fps limiter, and voila it's gone. I know, it isn't quite the answer I was wanting either cause I don't like seeing my frames skyrocket as high as they can in interiors, 80 mostly, but well over 100 at times. But my card never seems to go over 64 degrees celsius and thats within the tdp limit. Idk, up to you if you wanna do this to eliminate it or not, I have found no other alternative method. I just chalked it up to, if, skyrim isn't being vsync'd, then it wants frames to run freely, if my frames can get over 60 (which is what I limit it to, tis my refresh rate) then this jitter always occurs.


  • 0

#6 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,621 posts

Posted 11 August 2014 - 10:05 PM

hmm... ok in the skyrim ini ( this is just to see dont make it official or anything) set the iPresetinterval=0. In enb set vsync to 0 and then enable frame limiter to 60-66 fps. Be warned this will probably cause weirdness in-game but test it.

 

I'm going to have a mod or someone else come in here and be like back up your saves and ini's before you do any edit that can potentially hurt your game. I figure, if you don't then that is your own fault but to be fair I guess I'll say it to cover myself.

 

I dont know if I read Slinky correctly but your frames should never go over 60 unless for a special reason but still max 70 fps otherwise  really weird stuff occurs


Edited by hishutup, 11 August 2014 - 10:11 PM.


#7 CovertSlinky

CovertSlinky

    Commander

  • Members
  • PipPipPipPip
  • 252 posts

Posted 11 August 2014 - 10:11 PM

Yeah, and the fps limiter has a tendency to go 2.1 frames past what you set it at, so if you want 60 then set it to 57.9. Just a lil trivial non sense I thought I would add....for what sounds like no reason now lol :)


  • 0

#8 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,621 posts

Posted 11 August 2014 - 10:14 PM

I dont believe there really is a way to precisely count frames other than Vsync, especially in skyrims engine. 

What I said is kinda wrong but its complicated. 

 

Anyhow I get what you mean but use enb and set it in there and get rid of any other weird d3d9 dll. Sweetfx, SMAA, and color injectors are fine though.


Edited by hishutup, 11 August 2014 - 10:17 PM.


#9 camaro_69_327

camaro_69_327

    Prisoner

  • Members
  • 44 posts

Posted 14 August 2014 - 10:08 PM

I feel ya, had it Forever...TILL, i got rid of it !!!! in order for this to work you MUST have a monitor that can do 100 hz or better. (When i had a 60 HZ and set for 1/2 i still had it for some reason?)

 

Skyrim Vsync  OFF

ENB Vsync OFF

Nvidia = the power.

 

In nvidia Inspector, Skyrim Profile set...

Pre rendered frames 8 (seems to help keep the CPU busy)

Threaded Optimization = on

Triple buffering = on

Vertical Sync smooth AFR = on

Vertical Sync Tear Control = Adaptive 

Vertical Sync = 1/3 Refresh Rate

 

Set the Monitor to 100 Hz this will Net you 33 FPS , Avoiding the 64 Hz stutter bug and giving you a completely smooth Skyrim!

 

Other things that help.....

Gaming mouse = 1000 MS polling @ 2000 DPI (No accel)

Mouse Accel OFF in skyrim INI

UNpark your CPU cores

Only load your GPU to about 80-90 % VRAM load (use Skyrim Performance monitor) SPM will help you find the balance.

Run SLI

Add All 13 Multi threading tweaks to the Skyrim/prefs INI (grins..i you cant find all 13 threaded tweaks hollar i will post mine)

 

Took me a really long time to finally squash this bug.

 

Normal Play LONG sessions, 6-8 hour on weekends 2-3 hour runs a day after work, Thanks to everyone here and STEP i run a Full Setup. 257 mods (wrye is hiding a few for me) STEP extended + ENB + 2K + HR-DLC's , only 3 crashes and am level 20 ( 47 Hours ). ALL 3 crashes were at end of 6 or 8 hour session so no concern.

 

Last save = Save 213 - Darkness  Whiterun  47.06.03.ess

 

Again I do not think i could have this without STEP. Now that the Game is smooth with a crap ton of mods i cant wait to play every day.

 

 

EDIT:Mouse polling


Edited by camaro_69_327, 14 August 2014 - 10:24 PM.

  • 0

#10 generalmx

generalmx

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 15 August 2014 - 12:44 AM

- Try setting fTreeLoadDistance no higher than 40000 (on High this is 75000.0000).

 

- For the FPS Limiter, don't use 60 FPS if you can't actually sustain 60 FPS --- 30 FPS is a better target for you. Note that you can go higher, but for maximum stutter relief you want it to be a multiple of your refresh rate.

 

- Try making a custom resolution in Nvidia Control Panel (or Custom Resolution Utility by Toasty) that covers your average framerate limit in Skyrim --- if it's 45 FPS, have it be 45Hz. This way you can keep V-Sync enabled.


Edited by generalmx, 15 August 2014 - 12:46 AM.

  • 0



Also tagged with one or more of these keywords: microstutter, input, lag, fix, build

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users