Jump to content


Photo

SkyProccer "Error: "Could not create the Java virtual machine."


  • Please log in to reply
6 replies to this topic

#1 mikegray

mikegray

    Guard

  • Contributors
  • PipPip
  • 127 posts

Posted 31 August 2014 - 02:17 PM

I'm beta testing Patcher Maximus, the proccer behind the followup mod to SkyRe ("Perkus Maximus"). The thing is VERY ambitious and, if run normally on a large plugin list, takes a very long time (say, 20 minutes) and often runs into memory errors. 

 

The author has provided a .bat file that should free up more RAM with the following line:

 

javaw.exe -Xmx1024m -jar "PatchusMaximus.jar" "-NOSTREAM"

 

However, when run inside of MO, it fails to construct the virtual folder system. 

 

As an alternative, I tried to create a link to an executable with the following settings:

 

Binary: C:Program Files (x86)Javajre7binjavaw.exe

Start in: E:Skyrim UtilitiesMod OrganizermodsPerkusMaximusSkyProc PatchersT3nd0_PatchusMaximus

Arguments: -Xmx1024m -jar "E:Skyrim UtilitiesMod OrganizermodsPerkusMaximusSkyProc PatchersT3nd0_PatchusMaximusPatchusMaximus.jar" "-NOSTREAM"

 

However, this gets tangled up, too - java returns the error above: "Error: Could not create the Java virtual machine."

 

Can anyone help me figure out the problem?

 

 


  • 0

#2 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,541 posts

Posted 31 August 2014 - 02:34 PM

Perhaps try this line. Worked successfully with Dual Sheath Redux, although I have no idea if the extra parameters did anything.

-jar "E:Skyrim UtilitiesMod OrganizermodsPerkusMaximusSkyProc PatchersT3nd0_PatchusMaximusPatchusMaximus.jar" -Xmx1024m -NOSTREAM

 

Also, make sure your path is correct.



#3 mikegray

mikegray

    Guard

  • Contributors
  • PipPip
  • 127 posts

Posted 01 September 2014 - 09:34 AM

Perhaps try this line. Worked successfully with Dual Sheath Redux, although I have no idea if the extra parameters did anything.

-jar "E:Skyrim UtilitiesMod OrganizermodsPerkusMaximusSkyProc PatchersT3nd0_PatchusMaximusPatchusMaximus.jar" -Xmx1024m -NOSTREAM

Also, make sure your path is correct.

Thanks, DoubleYou!

 

As it turns out, I had two different, 32-bit versions of java installed on my PC. All my links above went to v.7, but EITHER the Proccer wanted v.8 OR ELSE a necessary change to an environmental variable was only applying to v.8. In any case, after uninstalling java v.7. and changing the links above to the correct directory, everything was fine.

 

For future reference, here are the steps that gave SkyProccer the extra ram it needed to run PerMa under Windows 8.1:

 

First, change a System variable (instructions from a post on Tomshardware): 

Open the Control Panel.
Go to System.
Go to Advanced Systems Properties, then Environment Variables.
In System Variables, click Add:
New Variable Name: _JAVA_OPTIONS
New Variable Value: -Xmx512

 

Then create a a run executable entry in Mod Organizer as follows (drives and directories will obviously be different for everyone - I've left mine in!)

 

Title: PaMa - Expanded RAM

Binary: C:Program Files (x86)Javajre1.8.0_20binjavaw.exe

Start in: E:Skyrim UtilitiesMod OrganizermodsPerkusMaximusSkyProc PatchersT3nd0_PatchusMaximus

Arguments: -Xmx1024m -jar "E:Skyrim UtilitiesMod OrganizermodsPerkusMaximusSkyProc PatchersT3nd0_PatchusMaximusPatchusMaximus.jar" "-NOSTREAM"


  • 0

#4 Libertron

Libertron

    Prisoner

  • Members
  • 19 posts

Posted 09 April 2015 - 12:58 PM

This worked for me! Thank you. Glad it was linked on the main PerMa page.

Edit: It's refusing to work now. I will try another post.


Edited by Libertron, 09 April 2015 - 07:08 PM.

  • 0

#5 rinomasaya

rinomasaya

    Prisoner

  • Members
  • 1 posts

Posted 15 April 2017 - 04:59 AM

Most of the time you can fix this problem by uninstalling the Java runtime and then reinstalling it all over again.  

To do this, go to the control panel and then Programs and Features. If you’re running Windows 8.1 Update 1, just right-click on the Start button and click on Programs and Features. Locate the Java runtime, uninstall it and reboot your PC.

Next, download the latest Java Runtime from java.com, taking care to install the correct version for your PC. You will likely want the 32-bit version as the 64-bit option is specifically for 64-bit browsers. Most browsers are 32-bit on Windows, even on 64-bit editions of the OS.

Sometimes this error can be caused by not having enough system memory allocated to the Java Virtual Machine – or not enough system memory full stop.  

You can also try increasing the amount of system memory allocated to the Java virtual machine by setting an environment variable.

To do this, go back to the Control Panel and click on System, then Advanced system settings. Now click the Environment Variables button to bring up a list of all those currently set.


  • 0

#6 joviermark

joviermark

    Prisoner

  • Members
  • 1 posts

Posted 13 June 2017 - 05:17 AM

Open the Control Panel
Go to System
Go to Advanced Systems Properties
Then Environment Variables
In System Variables, click Add
New Variable Name: _JAVA_OPTIONS
New Variable Value: -Xmx512M
Click OK
 
That's it, your Java program should now be able to execute properly.
For those interested, Java -Xmx/s is the configuration parameter that control the amount of memory Java uses.
 
Xmx sets the maximum heap memory size
Xms sets the minimum heap memory size 
 
 
Mark

 


  • 0

#7 GlassDeviant

GlassDeviant

    Prisoner

  • Members
  • 25 posts

Posted 21 November 2017 - 02:52 PM

A bit necro-y but relevant:

 

You can save a step by changing the New Variable Value to -Xmx1024M (or 2048M), which will help not just this process but also many other things that use Java, for example newer (and larger) versions of Minecraft. Don't use 2048 unless your computer has at least 6GB of RAM, preferably 8GB or more.

 

Don't forget to leave out the -Xmx1024m parameter in your shortcut as this becomes redundant.


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users