Jump to content


Photo

ArchiveInvalidation Is Not Working, No Textures in Game


Best Answer StupidFox , 03 September 2014 - 12:51 PM

For anyone else who happens to find this thread looking for the answer: Yes, do what I said above.  If you're looking for how to make archive invalidation work (and haven't yet tried to change anything to that end) just trust MO. Go to the drop down for profiles, click manage, and make sure the automatic archive invalidation is ticked on your profile, then close. If you have already tried other archive invalidation methods (Archive Invalidation Invalidated or Archive Invalidation generator, etc) they're NOT going to work with MO because of how MO hands the files. So delete Fallout.ini, Fallout_Default.ini and FalloutPrefs.ini (from base game and from Documents/My Games/FNV) and go verify your files on Steam. It will reaquire changed files. Then launch the game through the base launcher, set your resolution and options, load to the menu and then exit. At that point, go to MO, check your profile and toggle archive invalidation off then back on. It should now work just fine. If you'd already cleaned your files with FNVedit you will need to do this again now, but at least your textures will work at this point!

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 StupidFox

StupidFox

    Thane

  • Citizen
  • 66 posts

Posted 03 September 2014 - 05:09 AM

I am working on Win7 with a decent mid-range gaming rig. I am using MO. This is not my first MO rodeo.  I am using NVSE, 4GB Loader, LOOT, FNVEdit, Wrye, and NMM (just to get HUD mods working). I tried installing NMC texture pack and a Type 3 body replacer (Beware of Girl) and it is not working.  I have tried every archive invalidation tool I can find and all of them are failing.  At one point, it worked briefly (loaded game, saw textures were working, logged out) but I went to change the files from beware of girl because it'd installed the wrong options. After that, went back in and the textures were broken again (on NMC too). Not sure what happened. I tried uninstalling and reinstalling the archive invalidation, but it didn't fix it. So I tried every other archive invalidation mod out there and none of them worked.  I enabled automatic archive invalidation from the profile in MO and that didn't work (first thing I did).  How do I get my textures working? Current Load Order (only half-finished setting up mods so it's not everything)

 

Active Mod Files:
 

 


  • 0

#2 StupidFox

StupidFox

    Thane

  • Citizen
  • 66 posts

Posted 03 September 2014 - 12:15 PM

I think I've figured out at least this. Part of why it's not working is because of the MO VFS.  I was using ArchiveInvalidation generator and it generates an ArchiveInvalidation.txt. I realized when I went back and re-read the readme on that program that it does its work by reading for .dds files in the fallout directory to tell the game which ones to load. Unfortunately, since I'm modding through MO and not dumping my textures into the main folders, it means that method will not work. So I want to revert to base MO archive invalidation but I can't find documentation on how it handles it so I know what to change to fix it. I'd go just verify my files through Steam, but I don't know if that's okay at this point since I have NSVE and ENB and the 4bg loader installed.  Would verifying and redoing all my cleaning with FNVedit fix this? Does MO's base Archive invalidation work with FNV at base?? And if so, if I do it this way (reverifying files), will it automatically kick in or do I need to set up a new profile to get it working?


  • 0

#3 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 03 September 2014 - 12:41 PM

Archive Invalidation for MO is done for each profile individually. You need to click the profile icon and make sure you untick and tick AI for that profile you are using to get it to work.


  • 0

#4 StupidFox

StupidFox

    Thane

  • Citizen
  • 66 posts

Posted 03 September 2014 - 12:51 PM   Best Answer

For anyone else who happens to find this thread looking for the answer: Yes, do what I said above.  If you're looking for how to make archive invalidation work (and haven't yet tried to change anything to that end) just trust MO. Go to the drop down for profiles, click manage, and make sure the automatic archive invalidation is ticked on your profile, then close. If you have already tried other archive invalidation methods (Archive Invalidation Invalidated or Archive Invalidation generator, etc) they're NOT going to work with MO because of how MO hands the files. So delete Fallout.ini, Fallout_Default.ini and FalloutPrefs.ini (from base game and from Documents/My Games/FNV) and go verify your files on Steam. It will reaquire changed files. Then launch the game through the base launcher, set your resolution and options, load to the menu and then exit. At that point, go to MO, check your profile and toggle archive invalidation off then back on. It should now work just fine. If you'd already cleaned your files with FNVedit you will need to do this again now, but at least your textures will work at this point!


  • 0

#5 StupidFox

StupidFox

    Thane

  • Citizen
  • 66 posts

Posted 03 September 2014 - 12:58 PM

Only problem is... when I did this, for some reason, it lost Update.esm. I didn't delete it...  Where did it go? I search Fallout directory and there is no Update.esm anymore. I verify files through Steam and it doesn't reacquire it. I noticed when I went to start re-cleaning files. How do I get Update.esm back?


  • 0

#6 StupidFox

StupidFox

    Thane

  • Citizen
  • 66 posts

Posted 03 September 2014 - 01:12 PM

Ah.. It now has Update.bsa but there's no Update.esm...  How do i get Update.esm back?


  • 0

#7 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 03 September 2014 - 01:23 PM

I don't have Update.esm. Is there supposed to be one? I'm pretty sure then isn't or I'd have it.


  • 0

#8 StupidFox

StupidFox

    Thane

  • Citizen
  • 66 posts

Posted 03 September 2014 - 01:27 PM

Guh. I've been modding my FNV and my wife's Skyrim for the past week straight. I'm probably remembering cleaning Update.esm with TES5Edit... there's not one in the clean install on my housemate's computer... so Yeah, going with that I'm just confused.  Ignore this part about Update.esm I'm just loopy from so much modding work. :) Thanks guys. I sorted this out. So much of it is because of your guides and explanations here.  Thank you!  


  • 1


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users