Jump to content


Photo

Papyrus ini settings invalid after installing SkyUI following STEP


  • Please log in to reply
30 replies to this topic

#1 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 05 September 2014 - 05:42 PM

Hi

 

Just to be clear, its nothing wrong with STEP, this is most likely just another user created problem created by myself :blush:

 

I'm following STEP 2.2.9 installing Core + Extended carefully and slowly to make sure everything is done right.

I started with fresh install of Skyrim and all tools included mod organizer. Everything seem to go well until I installed SkyUI.

After installing SkyUI I run LOOT and started the game to see that everything was ok. I started a few new games and loaded a few.

 

Then suddenly I got this message right after loading or starting a new game:

Error Code 4: Your Papyrus INI settings are invalid.

 

The last 6-7 hours I have been trying to find out why it happened and how to fix it. It is a lot of info and fixes about error 4 out there, mod developer even made a error list with solutions and fixes but nothing seem to help.

 

I have downloaded and reinstalled SKSE and SkyUI multiple times, I have looked trough settings and ini files in Skyrim and SKSE and I can't find anything wrong. I have not touched any papyrus settings or done anything that is not in the STEP guide, no extra mods or tweaking and no mods from steam workshop. I have tried all things I have found from deleting ini files and copying them into mod organizer to replacing all SKSE scripts. I have disabled Consistent Older People and Complete Crafting Overhaul Remade for now since they depend on other mods.

 

The only thing I have found that temporarily remove the error warning is to replace all SKSE scripts. Then I can start a saved game or a new game a 7-8 times before the error message is back.

 

Anyone have any idea what this can be?


Edited by xxx78, 08 September 2014 - 04:20 PM.

  • 0

#2 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 06 September 2014 - 11:21 AM

A little update. After hours of different testing I finally seem to have gotten some progress.

I have done many different things included testing with only a few basic mods, also tested SKSE and SkyUI as the only mods in MO but the error still came.

 

The last test I did was to remove SKSE from MO install order and installed it with exe installer instead and added skse.ini manually into skyrim data folder, and now I dont get any error and everything seem to work as it shall.

I have no idea why this seem to work or why it happened in the first place but now I can start the game 20 times with no errors.

 

So I wonder how important is it to have SKSE in the install order in MO, or if it is ok to install SKSE outside MO in a STEP perspective?


Edited by xxx78, 06 September 2014 - 12:11 PM.

  • 0

#3 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 07 September 2014 - 09:57 AM

I have continued to install STEP mods but Im still unsure if taking SKSE out of MO install order will have any negative effects, and also wonder why SKSE was put into MO install order in the first place. Great if anyone have any knowledge/experience about this they can share ::):

Cheers


Edited by xxx78, 07 September 2014 - 10:41 AM.

  • 0

#4 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,541 posts

Posted 07 September 2014 - 11:24 AM

Papyrus ini settings being invalid and install location of SKSE have absolutely no correlation, so I have absolutely no idea what you are trying to say. The error regarding incorrect ini settings happens when you modify the Papyrus section of the skyrim.ini using the bad tweaks that are all over the Internet, or using blindly someone else's ini settings that they recommend to you.

 

We only support installation of SKSE as outlined here when using Mod Organizer. If you decide to do it some other way, you do so at your own risk.



#5 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 07 September 2014 - 01:07 PM

Thanks for your reply ::):

Papyrus ini settings being invalid and install location of SKSE have absolutely no correlation, so I have absolutely no idea what you are trying to say.

Ok thank you, thats good to know. I'm sorry if the name is thread is bad or misleading, I tried to be concrete on the subject but my English is not that good.

I only say that I for some strange reason have a issue getting error message with having SKSE in the install order in left panel in MO, and when I removed it from the install order in MO I dont get that error message anymore.

 

The error regarding incorrect ini settings happens when you modify the Papyrus section of the skyrim.ini using the bad tweaks that are all over the Internet, or using blindly someone else's ini settings that they recommend to you.

That's the funny thing, there is no changes done in papyrus settings or any other ini files in game folders or in MO, only those that is mentioned in post 1.D.1 and 1.D.2 in the STEP guide is implemented and some from mods like Skyrim flora overhaul for grass. I tried to find out what was wrong with backtracking each step in the STEP guide and deleting all ini files both in my games folder and in mod organizer with no effect. I only have STEP mods from STEP guide 2.2.9 installed and all installed in the order from the guide. No extra tweaks is done in mods or in Skyrim files. Non of the fixes from forum, mod creator or from anywhere related to deleting ini files, reinstalling, downloading again, setting in ini settings had any effect at all.

 

Im not very knowledgeable in this area and I try to learn more but this seem to be an issue with papyrus settings, and I have tried multiple times with only SKSE and SkyUI enabled in left panel of MO but I still get the error message. And everything should be clean and look ok but I have probably done something wrong and is just trying to figure out what and how to fix it, and for that I'm asking for some guidance if possible.

 

We only support installation of SKSE as outlined here when using Mod Organizer. If you decide to do it some other way, you do so at your own risk.

I totally understand that and I try to follow it, but in this case if I put SKSE into install order in MO, even with only SKSE and SkyUI enabled I get the error message. The only way I have found to stop the error message from coming is to take SKSE out of MO install order, but I dont like to do that since you guys have done such an amazing work setting up this guide and making mods work well and stable together.

 

I would love some help if possible since this is bothering me and Im afraid it will cause problems later having SKSE not in install order in MO. If it is ok to run with not having SKSE in the install order after Cleaned update ESM please tell me so I can continue with installing STEP ::):

 

Thanks again guys for creating this awesome guide :thumbsup:


Edited by xxx78, 07 September 2014 - 01:12 PM.

  • 0

#6 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,541 posts

Posted 07 September 2014 - 02:23 PM

My guess is you are not posting the correct error message. You probably have an old version of SKSE installed in MO, and that is why you are getting an error. It probably is saying that the scripts are the incorrect version.



#7 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 07 September 2014 - 04:00 PM

My guess is you are not posting the correct error message. You probably have an old version of SKSE installed in MO, and that is why you are getting an error. It probably is saying that the scripts are the incorrect version.

I downloaded all fresh before I started, using SKSE 1.07.01 but I shall look into it. The error message is the same all the time, error 4 with info that papyrus ini settings is invalid, but Im open for anything here. Think I downloaded a new version and tried earlier both SKSE and SkyUI but what the hell, lets try again :wallbash:

 

You probably get a loot of questions and comments that is pretty silly and not very well thought through, but I dont make posts for fun and try to look into things before i post. I have spent more than 6-7 hours trying to solve this, I have read many threads about error message 4 and problems related to SkyUI and SKSE, and tried all the fixes I could find. Im not a programmer or computer master mind but Im very dedicated and thorough when modding, making backup often and keeping track of things I do in excel, sorting out info and organizing things so don't worry, what I write here is correct, even if it make no sense :geek:


Edited by xxx78, 07 September 2014 - 04:18 PM.

  • 0

#8 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 07 September 2014 - 05:04 PM

No that did not help. My version of SKSE is the latest, I have latest MO, latest game version, latest SkyUI. As said everything seem to work great when I dont install SKSE as a mod in MO, so SKSE and SkyUI works, its only when I try to put SKSE into load order in MO this error message is showing up.

 

Anyway, I dont seem to get any progress here and since the only solution I have found is to take SKSE out of load order in MO, can someone confirm if it will be any problems running STEP without having SKSE installed through MO and in the install order?


  • 0

#9 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,541 posts

Posted 07 September 2014 - 07:27 PM

I cannot guarantee you will have no issues, but you might slide by ok. Please post your skyrim.ini file. (Puzzle, INI Editor, Skyrim.ini, copy and paste).



#10 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 08 September 2014 - 06:12 AM

Ok thank you, appreciate it.

 

Skyrim.ini

 

 

Other ini tweaks from mods in STEP I have installed as a separate mod as explained in the mod organizer guide to easily keep track of them and to easily do changes if needed.

 

ini tweaks from mods


Edited by xxx78, 08 September 2014 - 06:14 AM.

  • 0

#11 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,541 posts

Posted 08 September 2014 - 09:44 AM

Ok, if SkyUI is working, it should work fine. I can't seem to find a reason for what you are experiencing, so whatever works works I guess.



#12 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 08 September 2014 - 12:30 PM

ok thanks for looking into this. For now I will use the fix I have but its not optimal so I will try to solve this and when its done hopefully soon, I will post it here.

Most likely this is an error created by myself so look forward for a laugh guys :;):

 

cheers


  • 0

#13 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 11 September 2014 - 11:20 AM

Hi again and sry for waking up this nightmare

 

Since I did not manage to solve this issue I started STEP over again. Installed a new Mod organizer, deleted all ini files in user in windows and installed skyrim in another location. Have used 4-5 hours now to finish section 2.E. Interface in the STEP guide.

But to my big shock I getting this fuc&%¤#"%¤/&¤# SkyUI error code 4 again: Your papyrus ini settings are invalid. what the hell is going on?

 

The reason I started over again was that I had some issues with Skyfalls and Main Menu Spinning Emblem so I thought that maybe it was related to not having SKSE installed through MO and in the install order.

 

Im about to give this up, I'm following all instructions in STEP guide, double checking everything but Im getting errors like this for no know reason.

 

Would really appreciate some more help here.


  • 0

#14 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,541 posts

Posted 11 September 2014 - 12:52 PM

Okay, after more research on this issue, I see that if scripts are installed incorrectly, it will indeed produce this error.  When you open the skse scripts mod in MO, does it show anything in the Conflicts tab? If so, post a picture.



#15 xxx78

xxx78

    Commander

  • Members
  • PipPipPipPip
  • 259 posts

Posted 11 September 2014 - 02:42 PM

Hi again DoubleYou :)

 

There is no conflicts as I can see.

 

Here is some images from MO and SKSE installed in case something is wrong. I'm in the middle of installing 2.F. Conflicting Graphics so its not complete yet.

 

Mod organizer main window 1

 

Mod organizer main window 2

 

SKSE conflict window

 

SKSE content in MO

 

SKSE ini added as instructed in STEP guide

Edited by xxx78, 11 September 2014 - 02:57 PM.

  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users