Jump to content


Photo

Semi-random freezing

freeze

  • Please log in to reply
12 replies to this topic

#1 Gratis_monsta

Gratis_monsta

    Citizen

  • Citizen
  • 14 posts

Posted 07 October 2014 - 10:25 PM

Hi,

 

Long story short - trying to set up the basic SR:LE and I'm getting a semi-reproducible freeze (have to Alt+Tab and close Skyrim.exe from the task manager to do anything on my PC after it freezes) when doing the following.

 

Steps to reproduce:

1. Alternate Start option -> Patron at Inn -> Riverwood

2. Exit inn, go in the direction of Helgen along the path

3. Dual wield Flame spells

4. Once outside Riverwood, try casting the spell (one at a time or both hands does not matter)

5. Game freezes with hand outstretched and the flame sound loop playing in the background - this doesn't always happen on the first cast (hence the semi-randomness)

 

I'm at a loss now - I abandoned STEP because of the same problem but assumed that all the high res textures were at play. This time I followed the SR:LE guide to the letter and this still happens.

 

System specs Summary from Speccy: (because I cannot log into the wiki)

 

Mod Organizer Install order modlist.txt (left pane)

 

Active Mod Files: (from Wrye Smash)

 

=== Current Bash Tags: (from Wrye Smash)

 

I have attached my BOSS log and my SR Conflict Resolution.esp as well.

 

Any help in sorting this out would be appreciated! Thanks.

Attached Files


  • 0

#2 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 07 October 2014 - 11:01 PM

hmmm... very good presentation on what you examined. 

So, lets cover everything since you seem very competent

 

I typed everything below without looking at your VRAM...

It may have been mostly pointless sooooo lets try this... 

 

Well uncheck 

Skyrim Realistic Overhaul

Project Parallax Remastered

Vivid Landscapes - All In One

test it and report back
then go ahead onto the next
 
 

uncheck the Deadly Spell Impacts, Better Freeze and Shock Effects and Enhanced Blood... and all dependancies 

 

use Memory Blocks Log and then show me the log that it spits out in Overwrite using spoilers...

use spoilers to show your skse.ini and your enblocal.ini

Report back

 

 

Ignore this for now...


Edited by hishutup, 07 October 2014 - 11:04 PM.

  • 0

#3 Gratis_monsta

Gratis_monsta

    Citizen

  • Citizen
  • 14 posts

Posted 08 October 2014 - 12:59 AM

Thanks.

 

Well uncheck 

Skyrim Realistic Overhaul

Project Parallax Remastered

Vivid Landscapes - All In One

test it and report back
then go ahead onto the next
 

I managed to cast a few times exhausting my magicka but it freezed when fighting some wolves with an Iron Sword in that same game.

 

uncheck the Deadly Spell Impacts, Better Freeze and Shock Effects and Enhanced Blood... and all dependancies 

 

use Memory Blocks Log and then show me the log that it spits out in Overwrite using spoilers...

use spoilers to show your skse.ini and your enblocal.ini

Report back

Had to disable the SR Conflict Resolition.esp and ASIS.esp for this as they had masters among these.

 

This went much further than the earlier try. Fought wolves and bandits all the way up to the Talos Shrine Massacre site (where Immersive Creatures adds the Thalmor skeletal guards that activate when you disturb the shrine)

 

Game freezed when I backed up from one of these inactive guards.

 

MemoryBlockLog:

 

skse.ini:

 

enblocal.ini:

 

Did not try the "Check for Errors" instructions yet. Will do that if needed.

 

Thanks again.


  • 0

#4 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 08 October 2014 - 01:08 AM

I found your problem

the mem blocks log say [color=rgb(178,177,176);font-family:verdana, helvetica, sans-serif;background-color:rgb(47,55,66);]Block1[/color] is limited to 256... and thats maxing whooooo CTD

It should be set at 512 and its not soooo....

[color=#ffff00;]That TOOL is AMAZING [/color]and should be part of step

 

go ahead and enable everything and ignore the other suggestions

there a problem with SSME (SKSE version) not reading the skse.ini correctly

you see on windows explorer header it has Name, Date modified, Type, et cetera

look for the type of file that skse.ini is...

It should be "configuration settings" as the type

 

if its not I'll explain in more detail but download this... Its mine without the tint tweak but it should be set at .ini as the file type and not just the extension

 

 

A while back I was having the same problem and it was a massive headache.

Windows was hiding the file extension so my original skse.ini was actually

skse.ini.txt

 

To stop windows from hiding the extensions:

in the start menu search for 

"hidden"

select the "show hidden files and folders"

In the advanced settings:

Uncheck "Hide extensions for know file types"


Edited by hishutup, 08 October 2014 - 01:15 AM.

  • 0

#5 Gratis_monsta

Gratis_monsta

    Citizen

  • Citizen
  • 14 posts

Posted 08 October 2014 - 01:21 AM

I admit I misunderstood your response and changed the ScrapHeapSizeMB to 512 in skse.ini, enabled everything and started a game.

 

It crashed after fighting a few wolves. I had a look at the new MemoryBlockLog and it still seemed to take 256 as the max for Block1. It was then that I realized my game was really not reading skse.ini like you said.

 

skse.ini is indeed a configuration settings file in windows explorer. (I have extensions shown in windows - It is placed in Mod OrganizermodsSkyrim Script Extender)


Edited by Gratis_monsta, 08 October 2014 - 01:24 AM.

  • 0

#6 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 08 October 2014 - 01:27 AM

I think you should actually place it in your skyrim directory... STEP may argue but test it

 

Place skse.ini in this folder

 

<skyrim installation location>Dataskse

 

Set it back to the values below because those are perfect. Then test it

[General]ClearInvalidRegistrations=1[Memory]DefaultHeapInitialAllocMB=768ScrapHeapSizeMB=256[Display]iTintTextureResolution=2048

yes, I got carried away... It happens


Edited by hishutup, 08 October 2014 - 01:52 AM.

  • 0

#7 Gratis_monsta

Gratis_monsta

    Citizen

  • Citizen
  • 14 posts

Posted 08 October 2014 - 02:25 AM

Tried placing it directly in the Skyrim directory (beside skyrim.exe) as well as under Dataskseskse.ini - no effect, it stays at 256 max.


  • 0

#8 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 08 October 2014 - 02:56 AM

I hope in mo you skse selected as the executable. And not skyrim or skyrimlauncher Start skse outside of mo and check the log that appears outside of mo If it's still messed up reinstall skse
  • 0

#9 Gratis_monsta

Gratis_monsta

    Citizen

  • Citizen
  • 14 posts

Posted 08 October 2014 - 03:17 AM

Yes I run SKSE from MO.

 

I checked running SKSE from outside MO but no logs seem to be generated.

 

SKSE's scripts are installed via MO (according to STEP and SR:LE) so maybe that's the reason.


  • 0

#10 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 08 October 2014 - 08:34 AM

Reinstall with the latest skse... Why? idk, I figure why not. It's super easy to do and is unlikely to cause any problems.
  • 0

#11 Gratis_monsta

Gratis_monsta

    Citizen

  • Citizen
  • 14 posts

Posted 01 December 2014 - 10:13 PM

An update:

 

I tracked down the problem to the EXE and the SKSE memory patch feature and remembered I had applied the 4GB patch to it. Reverted back to the vanilla EXE (4GB patcher makes a .bak file of the original unpatched EXE) and voila!

SKSE's memory management functionality requires the original unmodified latest patch EXE to work since it uses absolute addresses of the memory block code the extender handles.

 

Thanks a lot for your generous and patient help hishutup.


  • 0

#12 phazer11

phazer11

    High King

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 3,110 posts

Posted 01 December 2014 - 10:25 PM

So you were using the 4GB patch even after the LAA update?


  • 0

#13 Gratis_monsta

Gratis_monsta

    Citizen

  • Citizen
  • 14 posts

Posted 01 December 2014 - 10:40 PM

To summarize, yes - but it was the SMME functionality that was not taking effect, not the LAA flag.


  • 0



Also tagged with one or more of these keywords: freeze

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users