Jump to content


Photo
dropped

STEP Optimized Vanilla Textures (by z929669)

optimized textures

  • Please log in to reply
122 replies to this topic

#1 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,053 posts

Posted 14 December 2014 - 05:32 PM

Discussion thread:
STEP Optimized Vanilla Textures by z929669
Wiki Link

 

Dropped in v3.0. Now longer being maintained.

 

This is a thread corresponding to the optimized vanilla textures for those vanilla textures not already covered by other texture replkacers in the STEP mod lineup. The mod has Standard and Performance versions available.
 
 

 

Mod Testing

Just need people to load this up in their game (see ReadMe for details). Load directly after the Unofficial High Res Patch:

  • check as many indoor/outdoor areas as possible for any borked textures.
  • Check FPS and VRAM consumption differences with and without this mod for both Performance and Standard versions.

 

 

I have provided a patch (available on the Nexus now [Dec, 18, 2014]) to correct the original versions of the optimized textures for those of you that already downloaded the original versions. From the patch ReadMe:
 

Patch ReadMe
 

This is just a simple patch for those who have already downloaded the main optimized texture package and would rather not
do so again. This patch will effectively bring Performance/Standard v1.0 up to v1.1 by 'forwarding' the following:

     **************
     Unofficial High Resolution Patch:
     **************
          .../textures/weapons/elven/scabbard/scabbard.dds
          .../textures/weapons/elven/mace/mace_m.dds

     **************
     Unofficial Skyrim Patch:
     **************
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.8.-39.23.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.8.-39.15.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.8.-31.23.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.8.-31.15.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.4.-35.23.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.4.-35.19.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.4.-35.15.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.4.-31.23.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.4.-31.19.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.4.-31.15.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.32.-39.-1.dds
     .../textures/terrain/deepwoodredoubtworld/deepwoodredoubtworld.16.-39.15.dds
     .../textures/clutter/hagravenveins01.dds

     **************
     Vanilla HRDLC:
     **************
     ...textures/terrain/tamriel/objects/tamriel.objects.dds



#2 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 14 December 2014 - 08:47 PM

I discovered a few oddities. I am not using step but that shouldn't matter because this looks like some sort of corruption.

 

EDIT: (insert pics here because of link rot )


  • 0

#3 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,942 posts

Posted 14 December 2014 - 09:01 PM

yep looks like corruption. Z will have to investigate. He did the optimization.



#4 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,053 posts

Posted 14 December 2014 - 09:02 PM

You need to use imagur or Dropbox for posting pics. Link to them via URL instead of uploading.

 

 

Can you tell me the names of the textures you are referring to and confirm that this is related to the textures provided by this package? You can use MFG Console to help identify the textures. (that first one seems like an ore texture).

 

Are you using Performance or Standard?



#5 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 14 December 2014 - 09:16 PM

I know it is because I just installed it after testing out VRAM in certain locations.

I tried out performance version to see if there was any difference.

 

I'll get back to you on which ones...

yay, digging for records is going to be fun. *Sarcasm

or does MFG give that, I guess ill see soon enough


  • 0

#6 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,053 posts

Posted 14 December 2014 - 09:22 PM

MFG Console gives you the info, but you may have to activate that piece in the INI (you probably won't want the other features of the mod though).



#7 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 14 December 2014 - 09:32 PM

hmm, I kept getting sky\* meshes

there was one building that came through though.

9C8D3

Architecture\WhiteRun\WRBuildings\WRLODWindowGlow01.nif

 

Theres a lot of corruption as I am flying around. What do you want me to do? List them out as I find them?

This is only vanilla+HD+Unofficial patches+Optimized 

 

EDIT: I cant seem to select any LOD object... or did you want the regular one...


  • 0

#8 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,942 posts

Posted 14 December 2014 - 09:40 PM

I have noticed the one on the whiterun walls that is in the second image you posted. It's an LOD texture I think because it corrects itself when you get closer to the wall.



#9 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 14 December 2014 - 09:48 PM

that one is loaded... fov was set to something like 20

 

I can fly right up to them

 

 

Oops, had a brain fart on how LODs work...

here is the Blue Rock model.

6e1ec


  • 0

#10 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,053 posts

Posted 14 December 2014 - 10:03 PM

that looks like a form reference ... can you provide the texture name? Or at least a location?



#11 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,053 posts

Posted 14 December 2014 - 10:13 PM

Wait ... are you using TFC in the console? If you are, then you can only evaluate textures that are in the current cell, as content outside the cell is not loaded, because your PC remains in the current cell and only the camera flies around.

 

This will look like a bunch of LOD up close I think.

 

EDIT: OK, that first image is the mountain behind the first windmill you pass as you go to Whiterun from Riverwood ... it looks fine in Performance version for me (less the shadow striping I see in TFC mode)



#12 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 14 December 2014 - 10:28 PM

ok, I left a lot of details out

I coc'd to riverwood from teh main menu because I was just going to assess the performance but then I noticed when I walked to whiterun that all of the whiterun buildings looked way worse than normal. 

As I got closer it looked like corruption so I turned the fov down so I can take a good screenshot.

I turn around and observed what else is effected by the optimization and took a few more screens.

 

You asked for the texture and because I didn't have nifskope downloaded and the meshes extracted, I only gave the baseID. To get a base ID I just flew around click everywhere to get an ID. Most of the time all I could get is a cloud. I am assuming that this is because you can't select LODs.

 

At this point I given up looking via in game forms and I just started looking through the textures and the textures looked okay but not very good ingame so... At this point I have run out of ideas on how to fine the LOD.

 

I guess I'll keep looking around.


  • 0

#13 z929669

z929669

    Ixian Inventor

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,053 posts

Posted 14 December 2014 - 10:35 PM

See my previous ...

 

Also, I guess MFG Console does not give the texture name :/



#14 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 14 December 2014 - 10:45 PM

ok... I found the LOD model

meshes\LOD\mountains\mountaintrim01_lod_0.nif

 

the supposedly blue texture is 

snow01lod.dds

 

After removing it, it still exists...

 

 

I removed the mod once more to verify that it is the optimized textures and removing it fixes the issue.

 

 

 

I guess I start hiding stuff till I locate it.


  • 0

#15 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 14 December 2014 - 10:54 PM

FOUND IT

 

Exclude

textures\terrain\tamriel\objects

 

I would also say do not optimize and of the tamriel folder stuff.

I think these are generated and will have issues.

 

0dc1365cec.jpg

now doesn't that look pretty.


  • 0



Also tagged with one or more of these keywords: dropped, optimized, textures

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users