Jump to content


Photo

Freezing near the entrance to Riverwood.


Best Answer keithinhanoi , 18 December 2014 - 06:08 PM

@TigerWolfe - If those two lines I mentioned in my previous are not in skse_steam_loader.log, then the heap block memory fix setting in your skse.ini wasn't read, plain and simple. Even your test with Memory Blocks Log confirms this.

 

So, I will go out on a limb and say that you have discovered your problem right there.

 

A majority of the times I've seen people claiming the SKSE implementation of Sheson's memory fix doesn't work either:

  • did not actually have skse.ini in the correct location,
  • had not updated to SKSE 1.7.1, or
  • had set Windows to hide file extensions, and accidentally saved skse.ini as skse.ini.txt (as Nozzer66 points out)

SKSE will look for the skse.ini file in ... Skyrim/Data/SKSE/

 

Alternatively, if SKSE's script files have been installed as a mod in Mod Organizer, the .ini can be kept in there, in a subfolder named SKSE, like this:

 

wjnui9W.png

 

I would suggest this method for storing the skse.ini because then you can edit it directly in MO - just click on the INI-files tab as seen in the above pic of the mod info window, and then choose skse.ini to edit right in that window.

 

Until you see those two lines in skse_steam_loader.log, and verified that block 1 can go over 256, there is honestly no use in looking at other reasons for the CTDs.

 

If your skse.ini is in the correct location but the heap size lines are still not appearing in skse_steam_loader.log let us know, and we can help troubleshoot why it's not working.

 

Good luck!

 

 

@Vulgar1 -

 

Regarding your iMaxAllocatedMemoryBytes setting - with absolutely no personal offence meant towards you, that is a ridiculously high number, and although not necessarily CTD-inducing, will almost guaranteed lead to Papyrus stack dumping, which means at best you get massive script lag, and at worst lots of scripts won't run or finish - in other words, things won't work as intended or expected.

 

I have just posted about this and the myth about another supposed "magical" game-fixing .ini setting in the Correct Enblocal Settings thread, here. I highly recommend reading it.

 

(Post edited to add one more reason why the SKSE implementation of the memory patch may not work - thanks to Nozzer66 for the reminder!!)

Go to the full post


  • Please log in to reply
34 replies to this topic

#1 TigerWolfe

TigerWolfe

    Citizen

  • Citizen
  • 14 posts

Posted 17 December 2014 - 09:34 PM

  • Been trying to find the answer/solution to this for several days now. Reinstalled STEP + the 2 patches I'm using twice. Turned off Burn Freeze Shock that wasn't enough. Quite frustrated. 
  • System
  • Using Mod Organizer

 

 

Load Order
  • Followed STEP then installed 2 STEP Packs followed by about 3 or 4 other mods I wanted to run. 
  • No additional ini tweaks.
  •  
  • Freeze
  •  
    • Between Helgen and Riverwood. Always at least after the two wolves. Sometimes as far as actually entering Riverwood.
    • Ralof, sometimes the wolves, sometimes a Riverwood NPC or 2. Sometimes I'm completely away from everyone. 
    • Either just walking, or trying to attack one of the wolves.
    •  
    • I've been running the Papyrus Logs so if someone would like to see those I can provide them. Any help would be greatly appreciated. 

Edited by TigerWolfe, 17 December 2014 - 11:30 PM.

  • 0

#2 Nozzer66

Nozzer66

    High King

  • Citizen
  • PipPipPipPipPipPip
  • 2,582 posts

Posted 17 December 2014 - 11:18 PM

You're definitely running ENBoost? 

 

And your SKSE ini might help, too.


  • 0

#3 TigerWolfe

TigerWolfe

    Citizen

  • Citizen
  • 14 posts

Posted 17 December 2014 - 11:29 PM

I'm fairly certain I'm running ENBoost. It tells me I'm using my integrated graphics card at the start of every session (I'm actually using my Nvidia card). 

 

 

[Display]

iTintTextureResolution=2048
 
[General]
ClearInvalidRegistrations=1
 
[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256

That's all I have in my SKSE.ini


  • 0

#4 TigerWolfe

TigerWolfe

    Citizen

  • Citizen
  • 14 posts

Posted 17 December 2014 - 11:43 PM

This appears to be at the end of my last four Papyrus logs.

 

[12/17/2014 - 06:59:40PM] Warning: Property DLC1VampireBeastRace on script zbloodnpc attached to Active effect 4 on  (17990074) cannot be initialized because the script no longer contains that property

 

 

Google says it's Enhanced Blood Textures. Should I just go it without that? Or is there a relatively simple fix?


  • 0

#5 Vulgar1

Vulgar1

    Guard

  • Citizen
  • 131 posts

Posted 18 December 2014 - 12:11 AM

Get rid of enhanced blood textures and just use the brawl bugs patch, i had this problem and that is just one of the things that helped.

If you still have problems I'd suggest not using the following:

Footsteps

Wet and Cold

Minty Lightnig Mod

Shooting Stars

The Choice Is Yours

Better Quest Objectives

Drop Lit Torches

You can keep the textures from Deadly Spell Impacts but get rid of the esp.

And I don't know why the same couldn't be said for Enhanced Blood Textures.

Trust that your game will run WAAAAAAAAAAAAAAAAAAAAAAY better without those mods.

The problem you then run into is the STEP and REGS patches but you might want to look into making some adjustments. It's up to you to save your Skyrim.


  • 0

#6 Nozzer66

Nozzer66

    High King

  • Citizen
  • PipPipPipPipPipPip
  • 2,582 posts

Posted 18 December 2014 - 12:25 AM

It's telling you you're using your integrated card versus your nVidia discrete card? Something not quite kosher there.


  • 0

#7 TigerWolfe

TigerWolfe

    Citizen

  • Citizen
  • 14 posts

Posted 18 December 2014 - 12:35 AM

Is there a way to modify the STEP patch, so it doesn't have that EBT dependency?


  • 0

#8 Vulgar1

Vulgar1

    Guard

  • Citizen
  • 131 posts

Posted 18 December 2014 - 12:50 AM

Is there a way to modify the STEP patch, so it doesn't have that EBT dependency?

Yes but it's pretty difficult and requires extensive knowledge of TES5Edit. It would be easier for you to use the STEP Core patch instead of the STEP Extended Patch and then manually download and install any other patches in the extended patch from each of the mods original source pages. There really aren't that many.

You can find out which mods need manual patching by looking through the change logs here

https://wiki.step-pr...Recommendations

Just from a quick glance I can tell you if you remove EBT it will effect the STEP Extended patch because of these two mods Audio Overhaul for Skyrim 2 and Improved Combat Sounds.

 

EDIT: Everything you need to know is in the wiki link above.


Edited by Vulgar1, 18 December 2014 - 12:52 AM.

  • 0

#9 phazer11

phazer11

    High King

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 3,110 posts

Posted 18 December 2014 - 12:51 AM

It sounds like the lvlpredatorscript.

 

Now, were you just running the papyrus logs for fun or did you turn them on to diagnose the issue after you started having it?


  • 0

#10 Vulgar1

Vulgar1

    Guard

  • Citizen
  • 131 posts

Posted 18 December 2014 - 01:01 AM

After he fixes the crash between Riverwood and the Guide Stones he'll have to deal with the Companions fighting the Giant on the way to Whiterun crash. :;):


  • 0

#11 TigerWolfe

TigerWolfe

    Citizen

  • Citizen
  • 14 posts

Posted 18 December 2014 - 01:05 AM

I turned on Papyrus for diagnosis purposes. So I killed the EBT.esp and switched over to the STEP Core patch (haven't installed the extra patches yet). Then got a CTD that appeared to be triggered by the SM drop lit torch. So I killed that. Crash to desktop again, right outside Riverwood (what's the deal with Riverwood?). Papyrus has this as the last several script calls.

 

 

zBloodNPCQuestUpdateScript.psc

 

 

Looks like that's EBT too... I don't have any of the EBT esps running though, why would it still be trying to call a script? Just gonna deactivate EBT all the way, bummer about the textures but we'll see what happens. 


Edited by TigerWolfe, 18 December 2014 - 01:08 AM.

  • 0

#12 TigerWolfe

TigerWolfe

    Citizen

  • Citizen
  • 14 posts

Posted 18 December 2014 - 01:19 AM

Now we're just CTD'ing. Looks like maybe Footprints is the last thing trying to load... 

 

:bashes head against wall:


  • 0

#13 Vulgar1

Vulgar1

    Guard

  • Citizen
  • 131 posts

Posted 18 December 2014 - 01:21 AM

Don't forget you'll have to run LOOT, Wrye Bash, TES5Edit, Wrye Bash agai, DSR, and FNIS.

 

EDIT: EBT, Drop lit torches, footprints, I'm sensing a pattern.

Try making these these change in your skyrim.ini in MO

[Papyrus]

fUpdateBudgetMS=1.4

fExtraTaskletBudgetMS=1.4

fPostLoadUpdateTimeMS=500.0

iMinMemoryPageSize=128

iMaxMemoryPageSize=512

iMaxAllocatedMemoryBytes=76800

bEnableLogging=0

bEnableTrace=0

bLoadDebugInformation=0

bEnableProfiling=0


Edited by Vulgar1, 18 December 2014 - 01:25 AM.

  • 0

#14 TigerWolfe

TigerWolfe

    Citizen

  • Citizen
  • 14 posts

Posted 18 December 2014 - 01:33 AM

Make those changes and keep the mods uninstalled?


  • 0

#15 Vulgar1

Vulgar1

    Guard

  • Citizen
  • 131 posts

Posted 18 December 2014 - 01:40 AM

Well that's up to you. I personally don't use those three or the or the other ones I listed because they are script heavy and they take space and plug-in slots. There are other mods I'd rather use.

Plus the three you've listed so far are constantly running scripts especially Footprints and EBT. Think about it everytime you take a step the game is being given new information thats not even originally part of the game.

If you want to keep Wet and Cold and the other ones I listed you should at least get rid of the three you are having problems with now and make those changes.

Throw up your specs, enblocal.ini, skyrim.ini, and skyrimprefs.ini and maybe you can get more help.

 

EDIT: Checked out your system, it's decent but you only have 2gb vram. What was Nozzer saying about you integrated card being used instead of nvidia?

 

Also try this real quick in MO click the gears, under SKSE add this to the arguements space: -forcesteamloader

 

*hot damn there were a lot of errors in this post


Edited by Vulgar1, 18 December 2014 - 01:53 AM.

  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users