Jump to content


Photo

Random crash when casting a magic spell


Best Answer hishutup , 25 December 2014 - 08:03 PM

you can confirm these correct?

6549a7f1b1.png

81df8621db.png

b46df6dcbb.png

Go to the full post


  • Please log in to reply
25 replies to this topic

#1 Eagleman

Eagleman

    Noble

  • Citizen
  • 43 posts

Posted 24 December 2014 - 01:03 PM

So i've been using STEP Extended with 2k textures where possible. After that i began using Vividian ENB with COT, ESS ELFX and RCRN.
 
Then when i started playing at random times my game crashes when starting to cast a magic spell.
 
I am not sure if i had this issue before using Vividian becuase i only started playing after installing Vividian.
 
This is my load order list:
 


Edited by Eagleman, 24 December 2014 - 02:37 PM.

  • 0

#2 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 24 December 2014 - 02:00 PM

instead of putting the mod list as a block of code can you use spoilers

 

First, lets check the memory stuff

Download and install Memory Blocks Log then cause your game to crash (however you want) and then go to the overwrite folder/skse/plugins and share the text that is in the memoryblockslog.log

 

I doubt Im going to see anything on that one but I might as well make sure.

 

You dont need the following plugins because of the STEP patch

 

I think I can also see that you are missing various Meta rules for loot. Did you check to see if you got all of them.


  • 0

#3 Eagleman

Eagleman

    Noble

  • Citizen
  • 43 posts

Posted 24 December 2014 - 02:21 PM

I removed the plugins you suggested to remove.

 

https://wiki.step-pr...Recommendations

 

I did add all those meta rules to loot, also meta rules with this notice:

 

Notice: STEP:Extended users: Please DISREGARD the following LOOT Meta Rules at this time. They pertain to interactions between this mod other mods installed downstream in STEP:Extended, so these rules cannot be implemented until those mods are installed. Those mod pages also contain similar LOOT Meta Rule instructions that can be applied later on.

 

I am now going to test the Memory Blocks Log.

 

I first ran LOOT to order the plugins then i rebuild the Bash patch becuase i installed the Memory Blocks Log plugin and ran LOOT. Should i re run loot after making the bash patch?


Edited by Eagleman, 24 December 2014 - 02:37 PM.

  • 0

#4 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 24 December 2014 - 02:51 PM

Memory blocks log is an skse DLL. There i s no need to rebuild any patch and /or run loot
  • 0

#5 Eagleman

Eagleman

    Noble

  • Citizen
  • 43 posts

Posted 24 December 2014 - 03:52 PM

It just crashed when i was fighting the snow troll at the thousand steps, after switching over to fire destruction (i didnt caste it yet) and after leveling up my game crashed, forcing me to end it with task manager.

 

Windows did complain a few times in the background that i was running low on RAM but on max usage i only had 6.1GB of ram in use of the 8GB.

 

 

EDIT

 

One of the last crashed also had this error about running low on RAM with windows, the windows error came at the same time as the game crash itself.


Edited by Eagleman, 24 December 2014 - 03:56 PM.

  • 0

#6 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 24 December 2014 - 04:12 PM

well, found the problem... the skse memory tweaks are not working or are not existing in the skse.ini.

The memory blocks log should be like the following

logging of blocks enabled
logging max values only
Timer disabled
Block1 Block2
512MB    256MB

replace your skse.ini with the following 

[General]
ClearInvalidRegistrations=1

[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256

If it looks like what is posted above then in the Mo executable arguments

-forcesteamloader 

  • 0

#7 Eagleman

Eagleman

    Noble

  • Citizen
  • 43 posts

Posted 24 December 2014 - 04:51 PM

I have that in my config, with the MO executable arguments you mean in SKSE and then as an Argument?


Edited by Eagleman, 24 December 2014 - 04:52 PM.

  • 0

#8 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 24 December 2014 - 04:59 PM

a65902a844.png


  • 0

#9 Eagleman

Eagleman

    Noble

  • Citizen
  • 43 posts

Posted 24 December 2014 - 05:02 PM

So what does it do?

 

I do have the steam version of Skyrim, is it somehow not loaded when using SKSE with MO?


  • 0

#10 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 24 December 2014 - 05:05 PM

the memory block log that you shared showed that Block1 size is 256 which shouldn't be the case because the memory patch increases it to 512 which reduces crashes almost completely. 

 

In other words, you are not using the memory patch because it isn't working. One way that is known to fix it for some people it to add the -forcesteamloader argument. 

Why? I don't know but it works.

 

Just do what I suggested and try to cause it to crash. I will be surprised if you succeed in causing it to crash 


  • 0

#11 Mangaclub

Mangaclub

    Knight

  • Mod Author
  • Pip
  • 295 posts

Posted 25 December 2014 - 05:33 AM

can assure you its no cause of vividian enb. More or less a memory problem it is.


  • 0

#12 Eagleman

Eagleman

    Noble

  • Citizen
  • 43 posts

Posted 25 December 2014 - 09:35 AM

It crashed after 2 hours of playing:

 

 

This is my in S:\Utilities\Mod Organizer\mods\SKSE\skse.ini file

 

 

Looks like it is still not using the 512mb memory blocks.

 

Also when trying to load any of my save game it is stuck on the loading screen and after a few seconds task manager says Skyrim is not responding. The game never loads.

 

A new game seems to work, but i want to be able to play with my save games, I am not going to start over becuase of some silly crash.

 

EDIT, recovered with the quicksave.ess.bak. However it still crashes when I am in riften, it has something to do with the vampires attacking, when I get near my game crashes.


Edited by Eagleman, 25 December 2014 - 10:12 AM.

  • 0

#13 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 25 December 2014 - 10:18 AM

Did you add the argument that I said to add?

Actually place your skse.INI file into the data\skse folder

I don't know why STEP has people do it in MO, it just seems silly to me
  • 0

#14 Eagleman

Eagleman

    Noble

  • Citizen
  • 43 posts

Posted 25 December 2014 - 10:53 AM

Yes i did add the argument.

 

I now placed the SKSE from the mod folder in: S:\Skyrim\SteamApps\common\Skyrim\Data\SKSE


  • 0

#15 hishutup

hishutup

    Daedric Prince

  • VIP-Supporter
  • PipPipPipPipPipPip
  • 2,680 posts

Posted 25 December 2014 - 11:00 AM

I guess the next thing to ask is can you start your game, load up into the world and then close out and share the memoryblockslog log


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users