Jump to content


Photo

Worse Performance than expected, want better FPS

performance fps core

Best Answer phazer11 , 18 January 2015 - 11:46 PM

That's pretty much normal. That path exiting the Helgen dungeon usually drops me to about 45 FPS with ENB enabled on my rig with my mod setup. Reduce your shadow settings in your .ini's via Mod Organizer.

https://wiki.step-pr...ng_INI_settings

Edit the values in your SkyrimPrefs.ini to look something like this and see if it helps any.

iBlurDeferredShadowMask = 3
iShadowMapResolutionPrimary = 2048
iShadowMapResolutionSecondary = 1024
iShadowSplitCount = 2
fShadowLODStartFade = 200.0000
bShadowMaskZPrepass = 0
fShadowBiasScale = 0.1500
iShadowMaskQuarter = 4
iShadowMode = 3
Go to the full post


  • Please log in to reply
3 replies to this topic

#1 gamequack48

gamequack48

    Prisoner

  • Members
  • 2 posts

Posted 18 January 2015 - 09:55 PM

Hello everyone,

 

I recently followed the STEP v2.2.9 guide, and I have been experiencing worse framerates than I was expecting.  I followed the STEP:Core guide, adding some of the extended mods.  I tried installing higher resolution textures than recommended, but after having these issues I replaced them with the recommended resolutions, which did not noticeably improve my performance.  I am using ModOrganizer.

 

I have been using the opening sequence to test my framerate.  I can maintain 60fps while looking at the two men opposite me, however when I look in certain other directions, the framerate drops to 45-50.  On the steep part of the path right before entering Helgen, my framerate drops to 35-40. I recently built this pc, and I figured it would be powerful enough to run at least STEP:Core at 60fps.  I'm not sure if this is relevant at all, but I can run Titanfall on highest settings at 60fps, and I thought that game would be similar in how demanding it is.

 

I tried following the INI tweaks in this thread, but they didn't make a difference.  I also tried increasing the ReservedMemorySizeMB, since i have 4GB of VRAM.  It didn't help either.  Finally, I tried reducing the MaxAnisotropy to 4 and disabling Vsync in enblocal.ini just to see if it would help at all, but it didn't.

 

Here is the full list of mods I installed.

 

I ran GPU-Z and Fraps to record my performance during the opening sequence.  I started it from the beginning and ended when the cart stopped (some frames at the beginning are loading screen/main menu and some frames at the end are pause screen).  These are the results.

 

Here are my system specs.

 

I figured I would be able to keep it at 60fps.  I'm not sure if INI tweaks will be able to get me better performance, I may have to disable some mods.  I'd like to keep the FPS at least 50.  But maybe I just need to stop complaining  ::P:

 

Any information or help would be extremely appreciated!

 

 

 

EDIT: turns out I had The Skyrim Distance Overhaul from STEP:Extended.  Disabling that gave me about a 4fps boost, but it still falls to 40 at times.


Edited by gamequack48, 18 January 2015 - 10:08 PM.

  • 0

#2 phazer11

phazer11

    Chatroom Supervisor

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,288 posts

Posted 18 January 2015 - 11:46 PM   Best Answer

That's pretty much normal. That path exiting the Helgen dungeon usually drops me to about 45 FPS with ENB enabled on my rig with my mod setup. Reduce your shadow settings in your .ini's via Mod Organizer.

https://wiki.step-pr...ng_INI_settings

Edit the values in your SkyrimPrefs.ini to look something like this and see if it helps any.

iBlurDeferredShadowMask = 3
iShadowMapResolutionPrimary = 2048
iShadowMapResolutionSecondary = 1024
iShadowSplitCount = 2
fShadowLODStartFade = 200.0000
bShadowMaskZPrepass = 0
fShadowBiasScale = 0.1500
iShadowMaskQuarter = 4
iShadowMode = 3


#3 gamequack48

gamequack48

    Prisoner

  • Members
  • 2 posts

Posted 19 January 2015 - 07:13 PM

Actually, those were the values when I went to check.  But I looked up what many of them did, and lowered the shadow quality, and now other than a couple quick dips it stays above 50! Here's what I ended up with.

iBlurDeferredShadowMask = 5
iShadowMapResolutionPrimary = 1024
iShadowMapResolutionSecondary = 512
iShadowSplitCount = 2
fShadowLODStartFade = 200.0000
bShadowMaskZPrepass = 0
fShadowBiasScale = 0.1500
iShadowMaskQuarter = 4
iShadowMode = 3

iShadowMapResolution = 1024

The shadows now look pretty bad, but at least the game runs better.  I didn't know what iShadowMode, fShadowLODStartFade, or iShadowSplitCount do so I left them alone.


Edited by gamequack48, 19 January 2015 - 07:13 PM.

  • 0

#4 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,313 posts

Posted 19 January 2015 - 07:37 PM

I would prefer maintaining a minimum of 30 FPS and bumping all of my shadows and detail settings to max (which is what I do). 30+ FPS runs nicely, IMO.





Also tagged with one or more of these keywords: performance, fps, core

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users