Jump to content


Photo

Microstuttering in 3rd person running/horseback riding on good rig

stutter

  • Please log in to reply
71 replies to this topic

#1 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 28 March 2015 - 12:06 PM

I am using STEP:EXTENDED 2.2.9, (EDIT: Now using a fresh install of STEP:EXTENDED 2.2.9.1 and stuttering still persists unless "Distant Object Detail" is set at High down from Ultra) have followed all instructions to the letter and used GamerPoet's Bash Patch, FNIS, DSR guide but I am having stuttering despite having a good rig. I am playing on a GTX 780 Ti which has 3GB VRAM, an i7 3770k at 4.5GHz, 8GB RAM, Windows 8.1 64 Bit(EDIT: Now on a GTX 980 Ti 6GB, 16GB RAM and Windows 10 pro 64 Bit) and when I tried using the 2k resolution textures for all the texture mods, I had massive stuttering/brief freezing when roaming outside on horseback. I had to reinstall everything a second time using the "Baseline" 1K or lower textures to reduce the stuttering which I STILL get every few seconds when on horseback outside.

Most of the "Baseline" Textures are aimed at people with 1GB to 2GB VRAM so why do the 2k Textures give me this problem with 3GB VRAM (EDIT: Now 6GB)? And as I said I still get stuttering every few seconds when outside on horseback especially, its just not as severe as when I used the 2k textures.
 
Meanwhile, I saw Gamespot's video where they used full 2K and up to 4k textures on almost EVERYTHING plus ENB preset with a GTX 780 and they get butter smooth gameplay without any stuttering. What could be going wrong? I followed all the instructions.
 

I make sure everytime I play a game that the ONLY programs running are Steam and the game itself. I always close all explorer windows and unnecessary processes beforehand. I am well aware of the craziness in Skyrim when going above 60 fps as I have a 120Hz monitor and it was not pretty when I played the game at over 100 fps average. I change my monitor's refresh rate to 60Hz everytime before playing Skyrim. I have the game installed on a Samsung EVO 840 250GB SSD. I had it on a fully defragmented Western Digital 7200 RPM hard drive before and frankly the only difference it has made is speed up loading screen time. The stutters I had before are still present so I doubt this is an I/O issue.

 

My CPU is watercooled and My GPU never exceeds 77 degrees when under full load. In Skyrim it does not even reach 74 degrees. My GPU usage is actually really low in the game, never exceeding 40%, however RAM usage seems right, I have seen it close to 2.8GB. I have Hyperthreading disabled when playing Skyrim and the load is spread across all 4 cores with core 1 having noticeably more load. I am using ENBoost and all the recommended settings found on the EnbLocal.ini guide on STEP guide. I am using Sheson's memory patch as recommended on STEP guide.

Now to the stutter itself. Inside cities and dungeons the game is SMOOTH and VRAM usage is the most. I have actually seen VRAM usage exceed 3.5GB inside dungeons with absolutely no stutter at all which surprises me. Once I go outside in 3rd person view/horseback and I start running, I am hit by microstuttering as soon as I cross borders. I closely monitored my GPU usage and VRAM usage and found that GPU usage is never more than 50% and VRAM usage is MUCH lower than inside dungeons. In First person the stuttering is almost nonexistant, even when I cross borders. As soon as I mount my horse/switch to third person view and start running, micro-stuttering starts. It's as if the game can't keep with the loading. My UGrids values are at the default, never messed with them. (EDIT: After enabling "tb" command, I can confirm that the stutters happen EXACTLY at cell border lines.)

Sometimes the microstuttering turns into actual mini freezes where the game just freezes for like 5 seconds then resumes as usual, though they were much more severe when I was using the 2K textures. Since downgrading to 1K textures the minifreezes are mostly gone, but they will still happen. I also noticed that as the stutters happen, I can clearly see things pop in the distance at the same time. Some areas where the stutter is very noticeable are the tundra outside Whiterun, the road from Helgen to Riverwood, the road from Whiterun to Falkreath and the intro carriage ride which gets really choppy just as Helgen becomes visible, almost like a mini-slideshow until the gate opens and the carriage enters Helgen.

 

I do not understand however why it happens when I have the game on an SSD, have a powerful GPU with 3GB VRAM (EDIT: Now 6GB VRAM) and have 8GB system RAM (EDIT: Now 16GB system RAM). I have done some digging and it seems as if it has something to do with cell loading stutter and increased I/O activity.
 

 

EDIT:

I have now done a fresh install of Skyrim and the full STEP:EXTENDED 2.2.9.1 modlist exclusively, with install instructions followed to the letter using Mod Organiser. The original Skyrim.ini and SkyrimPrefs.ini files located in MyDocuments are vanilla intact and the ini files I use are the Mod Organiser ones. In fact, my whole Skyrim install is pure Vanilla. Everything is done from Mod Organiser. I can play Vanilla Skyrim if i don't launch the game through Mod Organiser. It contains the original intact .esm files.

 

All the texture mods are the 2K variants. (EDIT: I have now downgraded every single 2K Texture Mod to 1K version after experiencing severe stuttering/mini freezes and stutter is STILL present, but less severe) STEP:EXTENDED Patch, Bashed Patch, Dual Sheath Redux Patch, FNIS Patch and Dyndolod steps have all been successfully completed and are working.

 

Nothing has changed. The stutters are still there even though I have made substantial hardware upgrades. Lowering "Distant Object Details" to High, ESPECIALLY fTreeLoadDistance is still the only "fix" that works, but one that I think I should not have to do. Some people are increasing those values to crazy high amounts to combat z-fighting  and getting smooth gameplay with lower end hardware. In this current state, I couldn't even think of doing that. I tried it and it DID get rid of z-fighting but the stutter was severe and the minifreeezes more frequent.

 

 

My Mod Load Order straight from Mod Organiser:

 

 

My Plugins Load Order straight from Mod organiser:

 

 

EDIT:

Skyrim performance Monitor logs:

Log1:

up301OQ.png

 

Log2:

FurOkCt.png

 

Log Download Links:

https://www.mediafir...Stutter Log.log

https://www.mediafir...utter Log 2.log

 

 

My Full Specs:

i7 3770k @ 4.5Ghz - Watercooled

EVGA GTX 780 Ti Classified Kingpin Edition - Watercooled(EDIT: Upgraded to a MSI GTX 980 Ti Gaming 6GB with latest Geforce Driver, problem persists)

8GB G-Skill Ripjaws X DDR3 RAM 1600Mhz(EDIT: Upgraded to 16GB RAM, problem persists)

Asus Sabertooth Z77 Motherboard
Samsung 850 EVO 250GB SSD(EDIT: Disabling pagefile/Moving Pagefile to another drive has not made any difference)
Corsair RM1000 1000Watt Power Supply
Windows 8.1 PRO 64 Bit
(EDIT: Upgraded to Windows 10 PRO 64 Bit, problem persists)

 

 

Similar 2015 Thread on Nexus forums. His system is almost identical to mine and he has the exact same issues:

https://forums.nexus...on-powerful-pc/

 

 

Thanks!


Edited by scorpgul, 21 August 2015 - 08:07 AM.

  • 0

#2 DanimalTwo

DanimalTwo

    Thane

  • Members
  • PipPipPipPipPipPip
  • 479 posts

Posted 28 March 2015 - 12:52 PM

From Neovalen's Skyrim Revisited: Legendary Edition guide.

 

 

Under [MEMORY], set ReservedMemorySizeMb=X. Where X = 64, 128, 256, 512, or 1024. This setting is highly dependent on the users system. If stuttering is experienced when turning 360 degrees in game, increase this value.

 


  • 0

#3 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 28 March 2015 - 01:47 PM

Under [MEMORY], set ReservedMemorySizeMb=X. Where X = 64, 128, 256, 512, or 1024. This setting is highly dependent on the users system. If stuttering is experienced when turning 360 degrees in game, increase this value.

I have tried 512 and as high as 768 and it changed nothing. Also I do not have stuttering when turning 360. I get stutters evebn when running straight forward.

 

I tested extensively and I would rate the severity of the stutters as follows:

First person view on foot: Very smooth, almost no stutter. Maybe a tiny little bit of stutter here and there but barely noticeable.
Third person view on foot: Stutter can be felt, running makes the stutters obvious but still not too distracting and do not happen every 2 seconds.
Third person on horseback: stutters are VERY REAL here and happen EVERY 2-3 seconds. and while the stutter happens, I can clearly see objects etc popping in the distance.
If I zoom out the camera evebn more, the stutter worsens.

I changed the FOV to as low as 65 and the stutters are still there when in 3rd person/horseback

It seems as if the speed at which the horse goes is "forcing" the engine to load up stuff that it does at its own pace when on foot.


  • 0

#4 Halde

Halde

    Thane

  • Members
  • PipPipPipPipPipPip
  • 375 posts

Posted 28 March 2015 - 06:44 PM

You haven't by any chance up'ed uGridsToLoad? Your game can be very unstable if you have it too high.


  • 0

#5 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 28 March 2015 - 06:57 PM

You haven't by any chance up'ed uGridsToLoad? Your game can be very unstable if you have it too high.

I have not touched Ugrids. After a lot of testing and reading I have found that quite a few people are having the same problem. I found some threads on Nexus mods and one here on STEP.

 

I have tried everything and what got rid of I would say 80% of the stuttering is changing the "DISTANT OBJECT DETAIL" settings in SkyrimPrefs.ini from ULTRA to HIGH:

DISTANT OBJECT DETAIL ULTRA:
fTreeLoadDistance=75000
fBlockMaximumDistance=250000
fBlockLevel1Distance=70000
fBlockLevel0Distance=35000
fSplitDistanceMult=1.5

DISTANT OBJECT DETAIL HIGH:
fTreeLoadDistance=40000
fBlockMaximumDistance=150000
fBlockLevel1Distance=40000
fBlockLevel0Distance=25000
fSplitDistanceMult=1.1

 

I find it shocking that I have had to downgrade in order to eliminate the stuttering despite having a good rig. Meanwhile I see so many people on Youtube running much more intensive configs with Uber HD mods and get smooth stutterfree gameplay. I don't understand what I am doing wrong. I have followed every step to the letter, even been communicating with GamerPoets on Youtube and even he told me it was strange that I had to lower these settings, and that I SHOULD be able to run everything at max WITH 2K TEXTURES with ease(I am running 1k textures...).

 

What could be causing this issue?

 

This is the latest and most relevant thread with very similar rig/issue I found on Nexus forums:

https://forums.nexus...on-powerful-pc/


Edited by scorpgul, 28 March 2015 - 07:02 PM.

  • 0

#6 Halde

Halde

    Thane

  • Members
  • PipPipPipPipPipPip
  • 375 posts

Posted 28 March 2015 - 08:00 PM

I have a GTX 760m 2 GB VRAM (mobile graphics) and I'm even running 2k textures (however my Skyrim is neither on High, nor Ultra from default). This seems very odd.

 

Something you can look at, if you haven't already done it, is using DDSopt to optimize your textures. Mods with heavy, but unoptimized, textures can waste a lot of VRAM, even though that shouldn't be the issue for you.


Edited by Halde, 28 March 2015 - 08:04 PM.

  • 0

#7 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,635 posts

Posted 28 March 2015 - 10:45 PM

Please post your full skyrim.ini and skyrimprefs.ini and enblocal.ini in spoilers

[spoiler]text[/spoiler]
.

 

You could also try removing Skyrim Distance Overhaul and see if that helps.



#8 Sinnerman

Sinnerman

    Prisoner

  • Members
  • 1 posts

Posted 29 March 2015 - 03:51 AM

Hey,

 

my rig is almost similar to yours and a also had some problems with microshutter when running high speed. Of course there may be multiple causes, but you could try to disable the ENB v-sync (if enabled) and use the v-sync from the nvidia driver. 

 

3 GB vram should be enough, but if you want to get an better idea of your vram usage, you could install the skyrim performance monitor.

 

https://www.nexusmod...im/mods/30187/?

 

If you added lines in your skyrim.ini and skyrimprefs.ini, you may added/edited some harmful stuff (IMO: be careful with stuff related to  multithreading, and Papyrus). I also got some problems with shutter (when crossing cell borders) when i set Distant Object Detail to very high values (higher than default Ultra), but right now i'm running ultra without problems.

 

Well, good luck. Pinpoint such problems can be wearing - even harder if there are multiple causes/factors. 


  • 0

#9 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,621 posts

Posted 29 March 2015 - 05:05 AM

I noticed strange stuttering with occlusion culling enabled in enblocal.ini



#10 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 29 March 2015 - 09:27 AM

I have a GTX 760m 2 GB VRAM (mobile graphics) and I'm even running 2k textures (however my Skyrim is neither on High, nor Ultra from default). This seems very odd.

 

Something you can look at, if you haven't already done it, is using DDSopt to optimize your textures. Mods with heavy, but unoptimized, textures can waste a lot of VRAM, even though that shouldn't be the issue for you.

I was going to use DDSopt after installing STEP, however I read that it can actually cause issues so didn't proceed. Can you confirm that DDSOpt will not cause any issues whatsoever?

I cannot risk losing the current playthrough, have invested too much.

 

Please post your full skyrim.ini and skyrimprefs.ini and enblocal.ini in spoilers

[spoiler]text[/spoiler]
.

 

You could also try removing Skyrim Distance Overhaul and see if that helps.

 

I followed GamerPoet's video where he suggested using the Mod Organiser Profile Inis so that the default Skyrim inis remain intact. I checked and the Inis in the My documents/My Games/Skyrim folder are intact. So I will post the Mod Organiser Profile ones.

 

This is the Skyrim.ini:

 

This is the SkyrimPrefs.ini

 

This is the ENBLocal.ini:

 

 

I was going to remove SDO, however I had the exact same stutters on Vanilla Skyrim, I just did not realise that Distant Object Detail at Ultra was the culprit. Mind you that was vanilla Syrim without Sheson's Memory patch or ENBOOST so installing those "performance enhancers" in STEP did not change anything.

 

Hey,

 

my rig is almost similar to yours and a also had some problems with microshutter when running high speed. Of course there may be multiple causes, but you could try to disable the ENB v-sync (if enabled) and use the v-sync from the nvidia driver. 

 

3 GB vram should be enough, but if you want to get an better idea of your vram usage, you could install the skyrim performance monitor.

 

https://www.nexusmod...im/mods/30187/?

 

If you added lines in your skyrim.ini and skyrimprefs.ini, you may added/edited some harmful stuff (IMO: be careful with stuff related to  multithreading, and Papyrus). I also got some problems with shutter (when crossing cell borders) when i set Distant Object Detail to very high values (higher than default Ultra), but right now i'm running ultra without problems.

 

Well, good luck. Pinpoint such problems can be wearing - even harder if there are multiple causes/factors. 

I tried running Performance Monitor, I went into Setup, ticked the following boxes:

Attempt Support for Custom D3D9.dll

Combine TESV and ENBHost System RAM

 

then changed the filepaths to:

 

Ini file path:

E:\SteamGames\SteamApps\common\Skyrim\Mod Organizer\profiles\STEP CORE\skyrim.ini

 

Skyrim Main Program File Path:

E:\SteamGames\SteamApps\common\Skyrim\TESV.exe

 

Skyrim Launcher File path:

E:\SteamGames\SteamApps\common\Skyrim\Mod Organizer\ModOrganizer.exe

 

and it didn't work. Are the above correct?

 

As you can see in my inis I just posted, the only modifications I made are the ones ferom the STEP guide. My install is STEP exclusively. Made no other tweaks.

 

You tried to go above Distant Object Detail Ultra, something which I never attempted and still I was stuttering. The game has forced me to downgrade those settings to High, which I cannot explain.

 

I doubt the ENB Vsync is to blame here, but I will try and see if it changes anything.


Edited by scorpgul, 29 March 2015 - 09:34 AM.

  • 0

#11 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 29 March 2015 - 09:40 AM

I noticed strange stuttering with occlusion culling enabled in enblocal.ini

I will try disabling it and see if the stutters stop.


Edited by scorpgul, 29 March 2015 - 09:41 AM.

  • 0

#12 Halde

Halde

    Thane

  • Members
  • PipPipPipPipPipPip
  • 375 posts

Posted 29 March 2015 - 10:29 AM

Can I confirm it won't cause issues? No. I have done it twice, and it haven't caused issues for me. For empirical certainy, I would need data from 1000+ instances of it working correctly. But you should remember, that we are only talking about textures. You can swap/remove/add textures on a whim, whenever you want. It won't mess up your save. And if you find yourself with glitchy textures or missing textures after it, just enable to un-optimized textures again, and remove the DDSopt'ed ones. 

If this is something you are going to try, remember that with STEP the "base" texture mod is Skyrim Realistic Overhaul, which is already optimized. Just so you don't waste a lot of time on that one, since it is by far the largest, save for the High Res DLC and the textures for Vanilla + all DLC (although I believe you can find all Vanilla + all DLC and High Res DLC optimized textures as a mod on Nexus).

 

This is probably not your issue, but you might as well do it anyway. It's not hard at all, but it takes an hour or two.


Edited by Halde, 29 March 2015 - 01:08 PM.

  • 0

#13 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 29 March 2015 - 12:46 PM

I noticed strange stuttering with occlusion culling enabled in enblocal.ini

I set the Distant Object Details settings back to Ultra values and disabled Occlusion Culling in EnbLocal.ini and the stutters are back. That setting at Ultra is not agreeing with my PC at all for some weird reason...

 

I played around with the Distant Object Detail Settings and the main culprit I have found is fTreeLoadDistance

 

 

The game still stutters when the following:

 

fBlockMaximumDistance
fBlockLevel1Distance
fBlockLevel0Distance
fSplitDistanceMult

 

are set at Ultra Values  but not as much as when fTreeLoadDistance is raised. As soon as its at 55000 to Ultra value(75000) the stutters increase dramatically. Higher than 75000 and it gets REALLY CHOPPY


Edited by scorpgul, 29 March 2015 - 03:51 PM.

  • 0

#14 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 09 August 2015 - 02:09 PM

I really need your help now guys. I am back with a brand new MSI GTX 980 Ti Gaming 6GB, fresh Skyrim install on a newly formatted PC on an SSD, 16 GB RAM, Windows 10 64 bit install. Installed the whole STEP 2.2.9.1 and was so excited thinking I'm finally going to smoke this game now with 2k Textures and guess what, the stuttering persists and is back with a VENGEANCE... :(

 

Cell loading stutter seems to be even worse than with my GTX 780 Ti 3GB and I can see the textures literally appearing all at once when it starts chugging. Whole mountain sides, trees and grass just suddenly pop into view when I move on horseback and sprint in third person. I mean now I have 6GB VRAM and 16GB system RAM, that should be more than enough to run this game at a buttery smooth 60fps at ultra with 2k textures. I am still stuttering like crazy like when I had 3GB VRAM and 8GB System RAM before, something is not right...

 

Again I lowered fTreeLoadDistance, fBlockMaximumDistance, fBlockLevel1Distance and fBlockLevel0Distance and the stuttering almost disappeared. What is it that is preventing me from playing this game? I do not have such issues with any other game. GPU usage is also shockingly low at around 30%. The VRAM is being used. I saw 4GB usage and System RAM reached 6GB so I don't know what is going on. This is driving me insane, I keep seeing videos of people playing with 4k textures, heavy ENBs on last gen GPUs and getting butter smooth FPS. Help me troubleshoot this please!

 

 

i7 3770k at 4.5Ghz

MSI GTX 980 Ti Gaming

Asus Sabertooth Z77

G-Skill Ripjaws X 16GB RAM

Corsair RM1000 1000W PSU

Windows 10 Pro 64 Bit

Game installed on Samsung 850 Evo 250GB SSD

 

Thanks!


Edited by scorpgul, 09 August 2015 - 02:23 PM.

  • 0

#15 n0mad23

n0mad23

    Guard

  • Members
  • PipPip
  • 143 posts

Posted 09 August 2015 - 02:49 PM

For me, increasing ReservedMemorySizeMb to 640 got rid of the stuttering.  It was pretty noticable at 512 but disappeared when pushed up to 640.  I thought I might have to push it up to 768 because of the number of mods (graphic upgrades) I'm using, but 640 seemed to have done the trick.


  • 0



Also tagged with one or more of these keywords: stutter

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users