Jump to content


Photo

Microstuttering in 3rd person running/horseback riding on good rig

stutter

  • Please log in to reply
71 replies to this topic

#31 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 17 August 2015 - 05:30 PM

@scorpgul

Hi, in looking over your skyrimprefs.ini I see the following, iSize W=3840 and iSize H=2160. In your profile your display is as follows, BenQ XL2420T 120Hz 24inch 1920x1080 TN+. Have you tried to set your ini to 1920 x 1080?

It is Nvidia DSR downsampling. Yes I have tested 1920 x 1080 as well extensively in the ini.  The stutters and framerate are identical at  both 1080p and 4k DSR (which again does not make sense; it shows this is not a graphics card problem), but the image quality is way superior with 4k DSR and I don't have to use any antialiasing at all.


Edited by scorpgul, 17 August 2015 - 05:32 PM.

  • 0

#32 Thick8

Thick8

    Guard

  • Members
  • PipPip
  • 120 posts

Posted 17 August 2015 - 06:41 PM

I've been following this thread because I have the same issue. I wanted to get my STEP:extended process finished prior to chasing this issue down. I just did the "TB" in console. You're right, it happens nearly every time I cross a border and only when I cross a border. That slight pause. It's more of a single full stop and go than what I've come to associate with a micro-stutter.

My system couldn't be more different than yours. FX-8350@5GZ, dual R9 290s. Like you, I am using an SSD (samsung 840 evo). I'm only running 8Gb of ram right now but have 16Gb on the way. This was going to be my first swing at the issue.

As school has started back this week and I have to "be the teacher"; I won't be able to devote any time to this issue. Needless to say, I'm rooting for you wholeheartedly in this endeavour!

John

 

EDIT: My motherboard is an ASUS sabertooth 990FX R2.0


Edited by Thick8, 17 August 2015 - 06:42 PM.

  • 0

#33 Thick8

Thick8

    Guard

  • Members
  • PipPip
  • 120 posts

Posted 17 August 2015 - 07:27 PM

One of the values that I don't undertand is the "uExterior Cell Buffer=36". I did a search and found several references to it. This was one of them.

General layout of your values will look like this, just plug in the number for where "X" is located and then do the math
 

[General]
uExterior Cell Buffer=(X+1)^2
uGridsToLoad=X
iPreloadSizeLimit=(X*1024)^2

so with ugrids 7
 

[General]
uExterior Cell Buffer=64
uGridsToLoad=7
iPreloadSizeLimit=51380224
 
And this:
Using UGrids at 7 really does improve the distance drawing, it's much better than 5 but a good GPU is required. Nothing worse than chunks of terrain loading up near by like in the console version.
 
Could this be the issue with things poping in out of nowhere? Based on this formula our uGridTo Load is WAY low. Or is there some other factor at work here?
 
 

  • 0

#34 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 17 August 2015 - 07:33 PM

Ugrids shouldn't be changed until after you have a solid STEP install. DynDOLOD is also set up to use uGrids of 5 which is the game's default value.

 

Pauses at cell borders is usually an issue with textures loading and switching in and out of RAM/VRAM.



#35 Thick8

Thick8

    Guard

  • Members
  • PipPip
  • 120 posts

Posted 17 August 2015 - 07:43 PM

I can cross back and forth over a border at a full run and the only time it pauses is with the first crossing. Once I cross an intersecting border it pauses again. As I have 8Gb of Vram is there a way I can use that excluively to verify if texture loading is the culprit?


Edited by Thick8, 17 August 2015 - 07:44 PM.

  • 0

#36 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 17 August 2015 - 08:20 PM

I've been following this thread because I have the same issue. I wanted to get my STEP:extended process finished prior to chasing this issue down. I just did the "TB" in console. You're right, it happens nearly every time I cross a border and only when I cross a border. That slight pause. It's more of a single full stop and go than what I've come to associate with a micro-stutter.

My system couldn't be more different than yours. FX-8350@5GZ, dual R9 290s. Like you, I am using an SSD (samsung 840 evo). I'm only running 8Gb of ram right now but have 16Gb on the way. This was going to be my first swing at the issue.

As school has started back this week and I have to "be the teacher"; I won't be able to devote any time to this issue. Needless to say, I'm rooting for you wholeheartedly in this endeavour!

John

 

EDIT: My motherboard is an ASUS sabertooth 990FX R2.0

 

I am glad to see that I am not the only one on STEP forums with this issue in 2015. It really felt like I was.

 

Here is another thread from this year on nexus forums with the exact same issue running almost identical hardware. I suggest you read through it. I am posting in that thread as well. It has a bevy of "fixes" recommended by different users, worth a try:

https://forums.nexus...on-powerful-pc/

 

Now I had the full STEP 2.2.9 installed before and I was using a GTX 780 Ti 3GB, 8GB RAM, Win 8.1 and a 7200RPM Western Digital HDD, then later an OCZ Agility 120GB SSD (Switching from HDD to SSD made no difference in stutters, it only reduced the loading screen times)

 

Let me tell you, although i have upgraded to a 980 Ti 6GB, 16GB RAM, Win 10 and a Samsung Evo 840 250GB SSD, the stutter is so IDENTICAL that it is just shocking. It feels as if the beefier hardware has not improved the game in any way. With my hardware, I should be able to run at 2k-4k textures on EVERYTHING. Instead i can barely run 1k textures. 2k is out of question, it worsens the stutters. I am sorry but I don't think that the extra 8GB of RAM you are getting to attempt to fix this will change anything. That is what i initially thought as well.

 

The issue is so bad that I have had to downgrade all the 2k recommended STEP mods to their 1K variants and the stutters and minifreezes when crossing borders STILL happen although they are not as severe. So texture loading into memory is definitely the culprit and the bigger the textures the worse the stutters are regardless of VRAM and RAM pool and SSD superior read speed. But WHY does it happen with such powerful overkill hardware? That is the real question and that is what i am desperately trying to investigate

 

 

 

Ugrids shouldn't be changed until after you have a solid STEP install. DynDOLOD is also set up to use uGrids of 5 which is the game's default value.

 

Pauses at cell borders is usually an issue with textures loading and switching in and out of RAM/VRAM.

So what could be causing this? You have here 3 people with the exact same problem(including the guy from the other thread i linked), all running on SSDs and with more than 8GB RAM and GPUs with 3GB+VRAM and stuttering even on vanilla Skyrim. It cannot be hardware issues.

 

I can cross back and forth over a border at a full run and the only time it pauses is with the first crossing. Once I cross an intersecting border it pauses again. As I have 8Gb of Vram is there a way I can use that excluively to verify if texture loading is the culprit?

 

I can hear my SSD working really hard when I am crossing a border and whenever a stutter happens, the SSD's noise will actually stutter as well for half a second.

 

I read about people fixing stutters by disabling pagefile which some applications access heavily such as Battlefield 4. I tried it thinking that finally I might crack the puzzle and was greeted with a massive stutter when crossing a border... -.-

 

I have now re-enabled it and put in on a different drive (I heard its better to have the pagefile on another drive) and again it has not made any difference, I still hear heavy reading noise from my SSD and the chugging when a stutter happens.

 

ApXG1xi.png

 

You can see that the pagefile is now on drive :F(OCZ Agility 3 120GB SSD). Before the pagefile was on my :C drive(Samsung 840 Evo 250GB SSD) which is where Windows and Skyrim are installed. :E and :G are 7200RPM HDD drives.


Edited by scorpgul, 17 August 2015 - 08:53 PM.

  • 0

#37 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 17 August 2015 - 09:05 PM

For both of you this definitely sounds like texture loading issues. If you're both running vanilla INIs that is good. Make the STEP recommended tweaks and nothing else.

 

Enblocal.ini...

 

Thick8, please post yours.

 

@Both

 

Please run the Vram Tool by Boris for the Dx9.exe and post your values.



#38 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 17 August 2015 - 09:25 PM

For both of you this definitely sounds like texture loading issues. If you're both running vanilla INIs that is good. Make the STEP recommended tweaks and nothing else.

 

Enblocal.ini...

 

Thick8, please post yours.

 

@Both

 

Please run the Vram Tool by Boris for the Dx9.exe and post your values.

I just ran the VRamSizeDX9.exe and it says:

 

Video memory Available (Mb): 4064

 

Hmm, my card is 6GB. Is this normal?

 

EDIT: Just found this thread:

https://forums.gefor...or-dx9-games/1/


Edited by scorpgul, 17 August 2015 - 09:40 PM.

  • 0

#39 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 17 August 2015 - 09:29 PM

I figured it would be higher with your VRAM and RAM and it might be Win 10, but try making these adjustments

[MEMORY]
ExpandSystemMemoryX64=false
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=256
VideoMemorySizeMb=3714
EnableCompression=true
AutodetectVideoMemorySize=false


#40 Thick8

Thick8

    Guard

  • Members
  • PipPip
  • 120 posts

Posted 17 August 2015 - 09:44 PM

Vram test

DX9=4064

DX11=15008


  • 0

#41 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,626 posts

Posted 17 August 2015 - 09:46 PM

@Thick8

In Windows 10 as well?

 

Try the above settings.



#42 Thick8

Thick8

    Guard

  • Members
  • PipPip
  • 120 posts

Posted 17 August 2015 - 10:07 PM

No I'm still on 8.1. I'm waiting for the kinks to go out of 10 before I make the switch.

 

I'm playing on a Eyefinity setup. When I checked Vram usage with MSI afterburner it hung out around 6.5Gb - 8Gb. I don't think 3Gb is going to cut it. But I'll try.

BRB


Edited by Thick8, 17 August 2015 - 10:11 PM.

  • 0

#43 scorpgul

scorpgul

    Prisoner

  • Members
  • 33 posts

Posted 17 August 2015 - 10:17 PM

 

I figured it would be higher with your VRAM and RAM and it might be Win 10, but try making these adjustments

[MEMORY]
ExpandSystemMemoryX64=false
ReduceSystemMemoryUsage=true
DisableDriverMemoryManager=false
DisablePreloadToVRAM=false
EnableUnsafeMemoryHacks=false
ReservedMemorySizeMb=256
VideoMemorySizeMb=3714
EnableCompression=true
AutodetectVideoMemorySize=false

Has not changed much I am afraid. It felt a tiny bit smoother i have to admit, but then as soon as I set ftreeloaddistance back to its ultra value at 75000, the stutters are back in full force


  • 0

#44 Thick8

Thick8

    Guard

  • Members
  • PipPip
  • 120 posts

Posted 17 August 2015 - 10:25 PM

IT seems to have made a chnge but i have to go to bed like a half an hour ago. Tomorrow then.


  • 0

#45 Thick8

Thick8

    Guard

  • Members
  • PipPip
  • 120 posts

Posted 19 August 2015 - 08:37 PM

I was just playing around and set my pagefile to 1024 and received a low meemory warning about 30 seconds into the game. Does the game use RAM or disk space to store textures? just wondering.


  • 0



Also tagged with one or more of these keywords: stutter

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users