Jump to content


Photo

LOOT fails to run through Mod Organizer.


Best Answer marieruth , 22 June 2015 - 04:47 AM

Have you changed any permissions on the LOOT executable or made it to run in compatibility mode or any such action?

There should be no reason why wow_helper.exe is being called. That is a utility designed to run programs in a certain mode inside Windows, the naming schema is: Windows on Windows helper.

I have never seen the need to call either LOOT or MO via this method as they will 'just work'.

 

The actual file in the LOOT folder that the error message is referencing is a 64bit exe, hence the error.

 

I can't see why this is being called so these next steps are just a shot in the dark.

Rename the folder where LOOT is stored to remove any periods in its name, call it just LOOT, not LOOT 0.7.0b4 and remove the 'Start in' field entry.

 

Oh, well shoot. I guess the problem was me running Mod Organizer in compatibility mode. I must have forgot to disable it after I figured out why Fallout 3 kept crashing at launch.

 

Thanks for trying to help me anyhow. :)

Go to the full post


  • Please log in to reply
5 replies to this topic

#1 marieruth

marieruth

    Prisoner

  • Members
  • 14 posts

Posted 20 June 2015 - 05:04 PM

I'm using MO for Fallout 3, and I use the external most recently updated version of LOOT on my computer. Yesterday, I could run LOOT successfully through MO with no issues at all. Today it is not functioning as it did yesterday. The only difference from today and yesterday is that today I installed a pip-boy retex mod, but I don't think it's related to my toubles. The error log that Mod Organizer displayed is this:

 

DEBUG (14:47:03.0361): get file attributes: D:\Steam\steamapps\common\Fallout 3 goty\Data\JIP Companions Command & Control.esp -> D:\Steam\steamapps\common\Fallout 3 goty\Data\ModOrganizer\mods\JIP Companions Command & Control\JIP Companions Command & Control.esp: 20
DEBUG (14:47:03.0361): first access to Storage for Craterside Supply in Megaton
DEBUG (14:47:03.0361): get file attributes: D:\Steam\steamapps\common\Fallout 3 goty\Data\CratersideSupplyStorage.esp -> D:\Steam\steamapps\common\Fallout 3 goty\Data\ModOrganizer\mods\Storage for Craterside Supply in Megaton\CratersideSupplyStorage.esp: 20
DEBUG (14:47:03.0428): create process (w) null - "D:\Bethesda Programs\LOOT 0.7.0b4\wow_helper.exe" 0x9b0 0xf60000 (in null) - hooking
ERROR (14:47:03.0430): failed to inject into (null): failed to access thread context. Please note that Mod Organizer does not support 64bit binaries! (The parameter is incorrect. [87])
DEBUG (14:47:06.0102): sh file operation w 3: C:\Users\Marie\AppData\Local\Temp\scoped_dir4676_1254 - nullptr
DEBUG (14:47:06.0130): hooks removed
----------- LOG END -----------

 

I don't understand what I did wrong to cause that error, since it worked fine yesterday. I thought that running LOOT in compatibility mode to Windows XP SP3 would help, thinking that would put it in 32-Bit mode or something, but that did not make anything better or worse. I also tried running LOOT as Administrator, which also didn't do anything. Any help would be appreciated.


  • 0

#2 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 20 June 2015 - 07:12 PM

Check the settings in your 'Executables' list, is the LOOT setting actually running LOOT.exe or the wow_helper.exe?

 

Ensure it is pointing to LOOT.



#3 phazer11

phazer11

    Chatroom Supervisor

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,288 posts

Posted 20 June 2015 - 10:33 PM

Also where is loot installed?



#4 marieruth

marieruth

    Prisoner

  • Members
  • 14 posts

Posted 21 June 2015 - 10:40 PM

Check the settings in your 'Executables' list, is the LOOT setting actually running LOOT.exe or the wow_helper.exe?

 

Ensure it is pointing to LOOT.

 

The executable points to LOOT.exe

https://www.dropbox.....36.50.png?dl=0

 

Also where is loot installed?

 

LOOT is installed under the D drive on my computer. The C drive is where the Operating system is installed, Windows 8.1


  • 0

#5 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 21 June 2015 - 11:23 PM

Have you changed any permissions on the LOOT executable or made it to run in compatibility mode or any such action?

There should be no reason why wow_helper.exe is being called. That is a utility designed to run programs in a certain mode inside Windows, the naming schema is: Windows on Windows helper.

I have never seen the need to call either LOOT or MO via this method as they will 'just work'.

 

The actual file in the LOOT folder that the error message is referencing is a 64bit exe, hence the error.

 

I can't see why this is being called so these next steps are just a shot in the dark.

Rename the folder where LOOT is stored to remove any periods in its name, call it just LOOT, not LOOT 0.7.0b4 and remove the 'Start in' field entry.



#6 marieruth

marieruth

    Prisoner

  • Members
  • 14 posts

Posted 22 June 2015 - 04:47 AM   Best Answer

Have you changed any permissions on the LOOT executable or made it to run in compatibility mode or any such action?

There should be no reason why wow_helper.exe is being called. That is a utility designed to run programs in a certain mode inside Windows, the naming schema is: Windows on Windows helper.

I have never seen the need to call either LOOT or MO via this method as they will 'just work'.

 

The actual file in the LOOT folder that the error message is referencing is a 64bit exe, hence the error.

 

I can't see why this is being called so these next steps are just a shot in the dark.

Rename the folder where LOOT is stored to remove any periods in its name, call it just LOOT, not LOOT 0.7.0b4 and remove the 'Start in' field entry.

 

Oh, well shoot. I guess the problem was me running Mod Organizer in compatibility mode. I must have forgot to disable it after I figured out why Fallout 3 kept crashing at launch.

 

Thanks for trying to help me anyhow. :)


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users