Jump to content


Photo

Question regarding 2.B. Clean the Update ESM


Best Answer Charlie86 , 29 June 2015 - 05:08 PM

Since I posted the same thing yesterday in the bug reports: the update.esm in your skyrim folder should now be smaller than the one you backed up.

Do the following:

 

1. Go to your MO mods folder (you find the location in MO's Settings -> Common -> Mod Directory, loose translation from the autoenabled translation in my version)

2. Create a new directory, e.g. "STEP Cleaned Update"

3. Move the smaller update.esm from your Skyrim\Data directory into the new directory

4. Move your backed up file into your Skyrim\Data directory

5. Restart Mod Organizer

 

You will now have the new mod listed, just as if you had created it according to the current docs.

 

Hope it helps!

Go to the full post


  • Please log in to reply
37 replies to this topic

#1 TheOne320

TheOne320

    Prisoner

  • Members
  • 21 posts

Posted 28 June 2015 - 09:50 AM

I am following "2.B. Clean the Update ESM" in the STEP guide v.2.2.9.1 and in step 11. the overwrite should turn red and the update.esm should appear in the overwrite list. This is not the case. The only thing in the grey overwrite is the "TES5Edit Backups" folder. I am using MO v.1.3.8 and TES5Edit v.3.1.1. What could I be doing wrong?


  • 0

#2 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 28 June 2015 - 10:09 AM

Sounds like you didn't check the box in TES5Edit to backup the plugin. You have to have that box checked as well as the plugin checked after the cleaning is done and before you close the program.



#3 TheOne320

TheOne320

    Prisoner

  • Members
  • 21 posts

Posted 28 June 2015 - 10:27 AM

Here like this? That is what I did. MO is not registering any update.esm in the overwrite list.

Attached Files


  • 0

#4 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 28 June 2015 - 10:33 AM

Where do you have MO installed?



#5 TheOne320

TheOne320

    Prisoner

  • Members
  • 21 posts

Posted 28 June 2015 - 10:35 AM

I just have it unpacked. G:\Downloads\Skyrim\ModOrganizer

Skyrim is also installed in a folder with write privileges. (D:\Steam\steamapps\common\Skyrim\)


  • 0

#6 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,625 posts

Posted 28 June 2015 - 11:37 AM

Then you likely have a stray update esm in one of your mods. Check the Data tab in Mod Organizer to see where your Update.esm is located.



#7 TheOne320

TheOne320

    Prisoner

  • Members
  • 21 posts

Posted 28 June 2015 - 11:41 AM

This is happening with absolutely no mods installed. I deleted the skyrim directory and redownloaded it to make sure everything is clean.

 

p.s. why can't I attach any files?

 

 

*edit*

Does this help?

 

INFO (18:44:43.0338): deleting D:\Steam\steamapps\common\Skyrim\data\Update.esm -> D:\Steam\steamapps\common\Skyrim\data\Update.esm
DEBUG (18:44:43.0338): add mod file G:\Downloads\Skyrim\ModOrganizer\overwrite\TES5Edit Backups\Update.esm.backup.2015_06_28_18_44_43 (TES5Edit Backups\Update.esm.backup.2015_06_28_18_44_43)
DEBUG (18:44:43.0338): using path from previous deletion: D:\Steam\steamapps\common\Skyrim\data\Update.esm
DEBUG (18:44:43.0339): remove mod file D:\Steam\steamapps\common\Skyrim\Data\Update.esm.save.2015_06_28_18_44_42

ERROR (18:44:43.0339): not a mod directory: D:\Steam\steamapps\common\Skyrim\data\Update.esm
DEBUG (18:44:43.0356): move (ex) D:\Steam\steamapps\common\Skyrim\Data\Update.esm.save.2015_06_28_18_44_42 to D:\Steam\steamapps\common\Skyrim\Data\Update.esm - 1 (203)
DEBUG (18:44:43.0384): hooks removed
----------- LOG END -----------

 

*edit2*

 

I think that section of the STEP guide is outdated.

I checked https://wiki.step-pr...ng_Instructions and this describes the behaviour I am experiencing.


Edited by TheOne320, 28 June 2015 - 12:02 PM.

  • 0

#8 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 28 June 2015 - 12:51 PM

I've completed that section of the Guide without issue unless something changed from MO v1.3.7 to v1.3.8 which is causing it. I could check again tonight if no one else gets to it before then.

#9 TheOne320

TheOne320

    Prisoner

  • Members
  • 21 posts

Posted 28 June 2015 - 12:52 PM

ok, I will just go on with the other STEPS. I can do the cleaning later right?


  • 0

#10 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,623 posts

Posted 28 June 2015 - 01:05 PM

If you do that, skip the cleaning for the other DLC, as well, until you can clean Update.esm

#11 TheOne320

TheOne320

    Prisoner

  • Members
  • 21 posts

Posted 28 June 2015 - 01:06 PM

Ok, thanks. I hope we can figure out what is causing the problem.


  • 0

#12 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 28 June 2015 - 07:31 PM

I too have seen this and there is currently an open issue with a couple of questions to @Tannin about this behaviour.

I'm not 100% sure of when the change in behaviour came in, around 1.3.4 I think, but there is something different about it.

 

Previously cleaned ESMs would replace the existing and the backup would be in the 'overwrite', now I get a cleaned ESM AND the backup in the 'overwrite and nothing in 'Data'. This means moving the cleaned files back into 'Data', or a new cleaned mod folder, and proceeding.



#13 TheOne320

TheOne320

    Prisoner

  • Members
  • 21 posts

Posted 28 June 2015 - 07:46 PM

yeah I just put the cleaned files into the Data folder, but this does not let me put the "Cleaned ESM" in the loadorder of MO after the uncleaned version.


  • 0

#14 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 28 June 2015 - 08:01 PM

I just checked the cleaning instructions in the guide and they describe exactly the 'new' behaviour and how to have the correct files in their place.

I hadn't read the instructions for many months and I was going off my memory of what they said so that would allow for some strangeness in observed results.

 

You are correct about the TES5Edit cleaning steps in the separate wiki page, they are outdated and need revising.

 

Keep in mind, in the STEP instructions you need to firstly make a backup of the original ESM and it is that file that needs to be placed back into 'Data', not the cleaned one in 'overwrite'. That's my bad, I usually don't bother with having the original AND a cleaned file. My apologies if I caused confusion.

 

EDIT:

Those instructions are now updated.



#15 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,625 posts

Posted 28 June 2015 - 08:16 PM

I just checked the cleaning instructions in the guide and they describe exactly the 'new' behaviour and how to have the correct files in their place.

I hadn't read the instructions for many months and I was going off my memory of what they said so that would allow for some strangeness in observed results.

 

You are correct about the TES5Edit cleaning steps in the separate wiki page, they are outdated and need revising.

 

Keep in mind, in the STEP instructions you need to firstly make a backup of the original ESM and it is that file that needs to be placed back into 'Data', not the cleaned one in 'overwrite'. That's my bad, I usually don't bother with having the original AND a cleaned file. My apologies if I caused confusion.

 

EDIT:

Those instructions are now updated.

No, those instructions are for mods. Mod behavior is different from behavior of the files in the data folder. I have reverted to the past revision, which I assure you, is how it works for mods installed in Mod Organizer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users