Jump to content


Photo

Some texture mods refuse to show up

archive invalidation

  • Please log in to reply
16 replies to this topic

#1 Nerd_Venom

Nerd_Venom

    Prisoner

  • Members
  • 7 posts

Posted 02 July 2015 - 01:24 AM

So after using Nexus Mod Manager (NMM) for a long time I decided to use Mod Organizer (MO) v1.3.8 to install my mods later. I completely uninstalled and reinstalled New Vegas, started it vanilla and exited. I started up NMM and I told it where to find the newly installed New Vegas. After that, I saw all my old mods that I had previously installed and still had Archive Invalidation enabled.

 

I saw a video about MO and decided to use that instead. I installed MO to the default location of program files(x86)\Mod Organizer which I know realize was a bad idea. Going through the MO tutorial I enabled Auto Archive Invalidation and copied the default profile making my own. I installed some basic UI mods which worked just fine, but it's when I started installing texture mods that I noticed something strange. Some textures just wouldn't show up no matter what I did. I tried disabling and enabling Auto Archive Invalidation, using the Archive Invalidation Invalidated mod with Auto Archive Invalidation off and on but nothing seemed to fix this.

 

Ignoring all this I made a new copy of the Default profile with Auto Archive Invalidation on and followed the entire STEP guide for New Vegas. Going into my game, I noticed that mods that effected things such as NPC clothing textures, clutter like cash registers, money, phones and ect. didn't change at all. I had problems with Robert's Male Body mod and Type3 Armor Replacer having the black bar on the chest and mismatched textures on the whole body. I was able to fix it by making a archiveinvalidation.txt with all the texture files listed and putting in the mods install folder for MO. Yet large texture packs like NMC's Texture pack or Poco Bueno Texture pack appeared to work just fine.

For example this mod "Tweaked Cash Register": ( https://www.nexusmod...as/mods/40329/? ) won't work at all, yet this mod "Fallout Food Package Retexture Compilation" :  ( https://www.nexusmod...as/mods/59232/? ) works with and without Auto Archive Invalidation, or any other method of Archive Invalidation enabled. It doesn't seem to matter what profile I use in MO either.

 

I did test these two mods out without MO by simply installing myself into the New Vegas data folder and using the Archive Invalidation Invalidated mod which fixed this problem completely. Every mod I tried out worked flawlessly. Even using NMM allowed these mods textures to show up in my game. For some reason when I try using MO only some mod's textures seem to work.

 

Is there any way to fix this at all? I could just ignore this and play my STEP guided profile but I just really annoys my seeing that low res cash register or phone sitting there in Goodsprings General Store. I would love some help with this, it's driving me insane.

 

I should also mention it's a Steam version of New Vegas and that I uninstalled MO from the default location and re-installed it into New Vegas's install location after all this.

 

TLDR: Some mod's textures just don't show up at all when using Mod Organizer.

 

Thanks


Edited by Nerd_Venom, 02 July 2015 - 02:14 AM.

  • 0

#2 Nozzer66

Nozzer66

    Dragon Prince

  • Pack Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,594 posts

Posted 02 July 2015 - 01:59 AM

Someone's bound to ask... You probably will need to say what version of Mod Organizer you're using. 

 

Also, try going to the archive tab on MO, click let MO manage archives and then ensure every BSA in the list that CAN be checked is actually checked as a starter.


  • 0

#3 Nerd_Venom

Nerd_Venom

    Prisoner

  • Members
  • 7 posts

Posted 02 July 2015 - 02:13 AM

Someone's bound to ask... You probably will need to say what version of Mod Organizer you're using. 

 

Also, try going to the archive tab on MO, click let MO manage archives and then ensure every BSA in the list that CAN be checked is actually checked as a starter.

Just edited my OP with the version number, thanks. Also, doesnt seem to help checking or unchecking any BSA's.


  • 0

#4 oqhansoloqo

oqhansoloqo

    High King

  • Staff
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,398 posts

Posted 02 July 2015 - 01:48 PM

I forget what all that I did to try to fix this issue, but it was possibly fixed by starting MO with admin privileges.


  • 0

#5 Nerd_Venom

Nerd_Venom

    Prisoner

  • Members
  • 7 posts

Posted 02 July 2015 - 06:07 PM

I forget what all that I did to try to fix this issue, but it was possibly fixed by starting MO with admin privileges.

Appreciate the help, but I have UAC disabled. I tried it anyway and no change at all. Any other suggestions?


  • 0

#6 oqhansoloqo

oqhansoloqo

    High King

  • Staff
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,398 posts

Posted 02 July 2015 - 06:24 PM

The problem is that I tried like 3 different things all at once to solve my problem and so I don't know which of them fixed the problem, nor do I remember the other things I tried. :/


  • 0

#7 Nerd_Venom

Nerd_Venom

    Prisoner

  • Members
  • 7 posts

Posted 02 July 2015 - 07:07 PM

The problem is that I tried like 3 different things all at once to solve my problem and so I don't know which of them fixed the problem, nor do I remember the other things I tried. :/

Well, I'm just creating ArchiveInvalidation.txt's for any texture mods that dont work and hoping that works as a workaround. Wish you did remember though, would feel so great to fix this.


  • 0

#8 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,621 posts

Posted 02 July 2015 - 08:13 PM

My issue was the invalidation bsa was not at the top of the list.



#9 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,333 posts

Posted 02 July 2015 - 08:40 PM

Try these steps.



#10 Nerd_Venom

Nerd_Venom

    Prisoner

  • Members
  • 7 posts

Posted 02 July 2015 - 09:07 PM

Oh my god, now I feel dumb. I put the AI.bsa at the top of the list and it works. Just went into the Goodsprings General Store and saw all the new textures were applied like they should be. Such an easy fix too, guess I should have just searched huh? Thanks GrantSP, now I can regain my sanity.


Edited by Nerd_Venom, 02 July 2015 - 09:09 PM.

  • 0

#11 oqhansoloqo

oqhansoloqo

    High King

  • Staff
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,398 posts

Posted 02 July 2015 - 10:53 PM

Oh my god, now I feel dumb. I put the AI.bsa at the top of the list and it works. Just went into the Goodsprings General Store and saw all the new textures were applied like they should be. Such an easy fix too, guess I should have just searched huh? Thanks GrantSP, now I can regain my sanity.

That may have been one of the things I tried.  Glad to hear that someone thought of that answer.


  • 0

#12 Nerd_Venom

Nerd_Venom

    Prisoner

  • Members
  • 7 posts

Posted 03 July 2015 - 09:45 PM

OK, I've finally started playing for real this time and now I get textures that will randomly change to odd things like teeth or stone. It changes constantly whenever I look around. Seems to happen inside mostly. Oddly enough, I could walk outside and all the textures looked just fine. I've tried disabling and re-enabling Auto Archive Invalidation but it doesn't seem to fix it.

 

Screen_Shot2.png

 

This is my load order:

 


Edited by Kelmych, 03 July 2015 - 10:59 PM.

  • 0

#13 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,990 posts

Posted 03 July 2015 - 10:57 PM

To start with you have way too many plugins. Fallout New Vegas gets flaky above around 140 plugins as mentioned in the Fallout NV guide on the STEP forum. You need to merge or eliminate some of the plugins.

 

Also, please use the spoiler tag when posting large lists.



#14 Nerd_Venom

Nerd_Venom

    Prisoner

  • Members
  • 7 posts

Posted 04 July 2015 - 02:17 AM

To start with you have way too many plugins. Fallout New Vegas gets flaky above around 140 plugins as mentioned in the Fallout NV guide on the STEP forum. You need to merge or eliminate some of the plugins.

 

Also, please use the spoiler tag when posting large lists.

I was getting the feeling that I did have too many but was unsure. Is there any way to tell what I can merge together or what not to merge together? So as long as it's 140 and below I'm fine and won't see random textures anymore? I manage to reduce it down to 114 plugins, will report if I still see glitched textures. It didnt seem to happen until I got out of Goodsprings and arrived in Primm. Also, I would have used the spoiler tag but I couldn't see where it was when posting. Anyway, thanks for the suggestions.


Edited by Nerd_Venom, 04 July 2015 - 04:24 AM.

  • 0

#15 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,990 posts

Posted 04 July 2015 - 10:48 PM

The Fear and Loathing in New Vegas guide for Fallout NV has some suggestions on this.





Also tagged with one or more of these keywords: archive invalidation

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users