Jump to content


Photo

Disappointing Frame Rates (FPS)

fps performance load order enb

  • Please log in to reply
80 replies to this topic

#1 Pillendreher

Pillendreher

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 29 September 2015 - 08:02 AM

I've upgraded my 6850 1 GB VRAM to a R9 380 4 GB VRAM, but the performance gain isn't nearly as big as I hoped. I noticed gigantic macro stuttering after installing the card, so I "stripped down the game" to find the culprit.

 

I've started with the Vanilla Game+HighResDLC. With everything set to ultra and VSync off, I'm getting 41/81/60,3 fps during the first minute of the intro (with my FX-8320@stock). This just seems off based on these Skyrim Benchmark results:

 

https://www.hardware...st.html?start=9

https://www.pcgamesh...X-Test-1162303/

 

The card itself is working fine since I'm getting results via the Heaven Engine benchmarks that match those by other R9 380 owners.

The FX-8320 is working at 3,7 GHz (Turbo) at 1,4V. My fps dropped even further while running the CPU at 3,7 GHz (No Turbo, OC via BIOS) at 1,35V (solid 13% drop even though the clock speed is the same). - How is that possible?

 

Before I start tackling the stutter issue again - is that kind of performance normal? I mean we're talking about a 4 year old game with no mods whatsoever barely hitting 60 fps. My fps near Whiterun aren't better mind you.


  • 0

#2 magician16

magician16

    Prisoner

  • Members
  • 15 posts

Posted 29 September 2015 - 11:05 AM

Go into "skyrimprefs.ini" and press CTRL + F, in the search box, type in "ishadowmapresolution". Make sure that one you're looking at doesn't have "Primary" and "Secondary" in it, what you're looking for is the one that says "ishadowmapresolution" nothing more. If it is set to 4096, change it to 2048 or 1024.

 

Do you have the correct GPU drivers? Did you install AMD Gaming Evolved? Uninstall Gaming Evolved, it causes problems with Skyrim. Before you install make sure that Gaming Evolved has not changed the Skyrim's resolution to 1440p or 4k using VSR (which is basically playing at 1440p/4k at cost of playing at true 1440p/4k and getting half of the benefits, i.e you don't actually play at 1440p/4k, it down samples the image.)

 

Uninstall previous drivers. Use Display Driver Uninstaller for this, DDU for short.

 

Install GPU-Z/MSI Afterburner and monitor your core clock, temperatures and make sure the GPU is not throttling/overheating. If you have trouble understanding please post a screenshot here. I recommend using GPU-Z. When in GPU-Z, click on Sensors and play around in Skyrim for a bit and post results here.


Edited by magician16, 29 September 2015 - 11:06 AM.

  • 0

#3 echo451

echo451

    Guard

  • Members
  • PipPip
  • 101 posts

Posted 29 September 2015 - 11:37 AM

The AA setting for the game have serious performance impacts with, as far as I can tell, no benefits.  

 

Most folks recommend using the driver control software to set these in any case. 

 

When I was first setting up the game, I turned off AA and lower the graphics setting. At one point was getting 140 FPS. The game is unplayable at this framerate. Anything over 60 will break the physics engine and causes some very strange graphic annomilies. Creatures floating about. Riderless horses.  

 

The original xbox version of the game ran at 30 FPS, or so the story goes.

 

Higher framerates, for me, lead to tearing and other graphics oddities. I experimented with lower the FPS.

 

Turns out if you have ENBoost installed, with the default key mapping, you can hit <shift><home> and it will switch to a FPS limiting mode. <shift><home> to toggle off. NUM8 to show a FPS counter.

 

I find that I can't tell the difference between 30 and 60 FPS as long as the framerate is constant. Your mileage will vary.

 

Consensus is that VSYNC needs to be enabled. This is again a function of how the Skyrim game works.

 

Except good things from your new card. I would.  


  • 0

#4 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,313 posts

Posted 29 September 2015 - 12:29 PM

Use ENBoost (enable vsync, thus limiting FPS to <= 60 FPS), INI settings, and AMD graphics settings exactly as described in the STEP guide.

 

Skyrim will stop even the best GPU, because it is based on a game engine that is much older than 4 years. Your frame rates are fine, and your stuttering issues are most likely related to no vsync and possibly improper AMD settings and ENBoost setup.



#5 Pillendreher

Pillendreher

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 29 September 2015 - 12:45 PM

First of, thanks for your answers!

 

AA and AF are disabled, as always. I've just gone ahead and redone my inis (based on STEP's recommendations).

 

1920x1080, Vanilla, Ultra based on Step, first minute of the intro, everything at stock

 

FPS: 46/84/63,4

Memory Clock: Varies between 700 and 1450 MHz, stays on 1450 MHz after 28 seconds

Core Clock: Varies between 311 and 985 MHz, never stays put and is always changing; the average value is 820 MHz

GPU Load: Varies greatly as well, everything between 0 % and 99 %. Average value is 43,11 %.

Memory Usage (Dedicated): Stays somewhere around 1,1 GB after 28 secons (see Memory clock).

 

I don't know why my clocks vary like that. It's really strange because the card shouldn't be switching around like that. I always thought it was 2D and 3D and that's it. Btw the temperature never rises above 62°C.

 

--------------------------------

 

 

1920x1080, Vanilla, Ultra based on Step with magician16's shadow settings (2048), first minute of the intro, everything at stock

 

 

FPS: 45/82/63,2

Memory Clock: Stays firmly at 1450 MHz, which is the stock value.

Core Clock: Now it's steadier. Stays between 843 and 948 MHz. Still never reaches the stock 985 MHz though.

GPU Load: Big fluctuations as well. Average value is 44,4 %.

Memory Usage (Dedicated): Less memory usage this time; stays at ~ 990 MB.

 

----------------------------

 

Gaming Evolve isn't running on my system. I'm using the 15.8 beta drivers.

 

--------------------------------

 

As for ENBoost: I've run the sequence above with the STEP settings and lesser shadows with these values (without SKSE mind you):

 

ReservedMemorySizeMb=512
VideoMemorySizeMb=7746

 

FPS: 46/82/62,2

Memory Clock: Stays firmly at 1450 MHz, which is the stock value.

Core Clock: Varies between 839 and 955 MHt

GPU Load: Average value is 58,7 %.

Memory Usage (Dedicated): Increased memory usage - stays at ~ 1,3 GB.

 

A thing I noticed the last two runs: There were two times that all clocks went down: 1450=>700 (Memory); 900 => 397 (Core). I haven't mentioned these because they seem like flukes, but it's exactly these drops that I noticed with my fully modded SRLE Setup.

 

 

Concerning VSync: I'll turn it on later on, but for the moment it's off because I want to know the maximum amount of fps I'm getting. To me it's ridiculous that this card would drop below 60 fps with the vanilla game, even on ultra. The R9 380 should be bored out of its mind, not struggling to maintain 60 fps.

 

 


Use ENBoost (enable vsync, thus limiting FPS to <= 60 FPS), INI settings, and AMD graphics settings exactly as described in the STEP guide.

 

Skyrim will stop even the best GPU, because it is based on a game engine that is much older than 4 years. Your frame rates are fine, and your stuttering issues are most likely related to no vsync and possibly improper AMD settings and ENBoost setup.

I've already done everything you told me with my modded setup and it still stuttered severely.


  • 0

#6 n0mad23

n0mad23

    Guard

  • Members
  • PipPip
  • 143 posts

Posted 29 September 2015 - 12:57 PM

I found experimenting with my ENBlocal.ini settings helped a lot.  Your VideoMemorySizeMb= might be set somewhat higher (how much system RAM do you have?) and I found with my laptop I had to set ReservedMemorySizeMb=640 to reign in stuttering.


  • 0

#7 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,313 posts

Posted 29 September 2015 - 01:04 PM

Are you certain?
 
iMultiSample=4 (this is Skyrim AA)

 

Do you have ENBoost vsync enabled?

 

Are ALL of your CCC settings identical to those I linked?

 

Is everything set exactly as described in the links I provided? (check again, and again ... and again)

 

I use AMD (several different cards since we have created these recommendations), so I have set these optimally based on my own testing. They really work, so since there are many settings, I cannot help but assume that you have missed something or changed something that we did not mention.

 

We have already verified that ENBoost VideoMemorySizeMb recommendations are correct, so only deviate once you have made absolutely certain that your settings match ours (and that nothing else was altered).



#8 d3monic

d3monic

    Prisoner

  • Members
  • 34 posts

Posted 29 September 2015 - 02:15 PM

Don't forget to check not only the INI settings, but also any overrides set for Skyrim in your GPU configuration utility. Make sure those match the above recommendations also.


  • 0

#9 Pillendreher

Pillendreher

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 29 September 2015 - 03:59 PM

OK. So I've done the following:

 

-I've uninstalled the 15.8 driver (CCC was acting buggy; couldn't access profiles) via DDU and I've installed the 15.7 driver. Checked that everything matches the STEP settings (although I didn't force AF via driver).

-I've made every ini tweak recommended by STEP

-I've activated VSync via ENB(oost)

 

I'm getting slightly higher min fps (52 instead of 45ish). No fps-drop though this time.

 

This still seems weird to me. I should be able to run ultra vanilla without dropping below 60 fps. Or am I underestimating the crappy Skyrm engine?


  • 0

#10 Pillendreher

Pillendreher

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 29 September 2015 - 04:19 PM

Seems like I can't get rid of the stuttering/loading lags even with Vanilla. Settings as above starting in Dragonsreach and running around Whiterun:

 

https://imgur.com/0Hd5KOO

https://imgur.com/ujkYqw6


  • 0

#11 Greg

Greg

    Dragon Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,024 posts

Posted 29 September 2015 - 05:06 PM

If you're starting fresh with a completely vanilla setup, you might consider using DoubleYou's Skyrim Project INI to setup the optimized/cleaned INI files. He's been putting a lot of hours into figuring out all the settings in the Skyrim's INI files and the optimum settings for performance/quality, so this should give you a good baseline to build on.

 

Also keep in mind that Skyrim's intro (the cart ride into Helgen) is very script intensive so you will not get steady 60fps. You'll also notice some areas of Skyrim where performance may dip into the 40s or 50s depending on your video card even if you have an R9 380 or R9 390. I know Bethesda says the game engine is four years old, but I really think it's more like 10 years old with patches.

 

Most everything you've mentioned so far seems about average and nothing to worry about, but the stutter may be troublesome depending on how bad it may be.

 

Finally, can you provide us with your system specs? Things like CPU, CPU speed, amount of RAM installed, and whether you're running Skyrim on an SSD or HDD?



#12 Pillendreher

Pillendreher

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 29 September 2015 - 05:18 PM

I'll give those inis a try. I've gotten the Intro consistently above 60 fps via lowering shadows to medium and distant object detail to medium - up from 60 to 76 fps avg. :)

 

I'm using an FX-8320 on an 970 Extreme3 R2.0, powered by an 430W beQuiet PSU. I'm using 8 GB G.Skill NT Series DDR3-1333 DIMM CL9 Dual Kit and Skyrim is running on an HDD (Western Digital WD5000AAKX Blue).


  • 0

#13 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,621 posts

Posted 30 September 2015 - 04:22 AM

I compared a few other systems after moving from two 6970 -> a single 970.
For someone that has a similar machine other than they had a weaker gpu and an Intel cpu, the person was able to get 60fps with a modded game where as I was only about to achieve 20 with only jk whiterun the sample was taken at whiterun.
My conclusion is that amd cpus are terrible. If I had the funds I would do an apples to apples comparison.

I hope this makes sense, I am on my phone and its not the best.

#14 Pillendreher

Pillendreher

    Citizen

  • Members
  • Pip
  • 59 posts

Posted 30 September 2015 - 04:35 AM

Yeah, I've read that as well. Seems like AMD CPUs perform better in multi-core-scenarios whereas Intel CPUs are better for single-threaded applications. As far as I know, Skyrim can't really benefit from multiple cores, so there's that.

What's strange though is that the CPU could bottleneck the whole system like that.

 

EDIT: God damn, this game is pissing me off. Even on the lowest settings possible I'm getting those stutters and fps drops. How is that possible?!


Edited by Pillendreher, 30 September 2015 - 04:46 AM.

  • 0

#15 Quinnbeast

Quinnbeast

    Citizen

  • Members
  • Pip
  • 77 posts

Posted 30 September 2015 - 07:06 AM

Are you able to test the same part of the game with your old GPU? Have you moved beyond the intro into the game world proper, to see if the stutter persists after the opening scripted sequence?

Skyrim does not carry a big GPU load in vanilla, and is much more likely to be CPU bound until you start adding ENBs on top of big texture packs. It seems unlikely to be an issue with your new GPU...
  • 0



Also tagged with one or more of these keywords: fps, performance, load order, enb

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users