Jump to content


Photo

Disappointing Frame Rates (FPS)

fps performance load order enb

  • Please log in to reply
80 replies to this topic

#46 Pretendeavor

Pretendeavor

    Knight

  • Citizen
  • Pip
  • 359 posts

Posted 11 October 2015 - 04:30 PM

I think you should expect 40-60 fps in exteriors with a modded Skyrim. Don't waste too many hours trying to make it run smoothly at 60 fps, turn off the fps counter and start playing ;)


  • 0

#47 winflakes

winflakes

    Citizen

  • Citizen
  • 21 posts

Posted 11 October 2015 - 04:57 PM

I think you should expect 40-60 fps in exteriors with a modded Skyrim. Don't waste too many hours trying to make it run smoothly at 60 fps, turn off the fps counter and start playing ;)

That's the thing Pretendeavor, I fully expect to be in the 40-60 range once i start installing mods. Up till now the only mods I have installed are the bug fixes. I haven't added anything to increase the graphical load from the base game. I won't run the FPS counter when I actually play, but to be experiencing those drops without adding any real mods means something is wrong.

 

I just did the coc whiterun run and averaged 41.0175. 

 

Anyone have any ideas why my systems seems to be self-capping at 40 FPS?


  • 0

#48 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,928 posts

Posted 11 October 2015 - 09:18 PM

What are your vsync settings in Inspector? Also check to make sure the frame rate limiter isn't running.



#49 winflakes

winflakes

    Citizen

  • Citizen
  • 21 posts

Posted 11 October 2015 - 11:40 PM

Vertical Sync Smooth AFR behavior - Off

Vertical Sync Tear Control - Standard

Vertical Sync - Use the 3d Application Setting

 

I hadn't heard of the frame rate limiter, but after a quick google search it says that should be in the "common" section. I don't have it there, so I assume it isn't running.

 

On a separate question, I was going into my ini file to do some edits for 2.G and it looks like i may have something wrong. I made the edits to the actual ini files because i didn't know that MO did that. When I click the ini editor in MO, none of my changes are showing in that file. I copy pasted over it yesterday, but today those edits are gone. So is MO using the ini file in the skyrim folder, or whatever this ini file is that pulls up?


  • 0

#50 Greg

Greg

    High King

  • Uber Moderator
  • PipPipPipPipPipPip
  • 2,196 posts

Posted 12 October 2015 - 12:19 AM

Mod Organizer uses the Skyrim.ini and SkyrimPrefs.ini files stored in the ModOrganizer\Profiles\[profile] folder. Also note that mods can also provide tweaks (or override) settings in plugin.ini files (where plugin is the same name as the esm or esp file).

 

The INI files in the Skyrim folder are used only when you run Skyrim Launcher to set the resolution and graphics quality. In other words, these are the base defaults settings that are copied to your user profile folder (usually C:\Users\[username]\Documents\My Games\Skyrim).



#51 winflakes

winflakes

    Citizen

  • Citizen
  • 21 posts

Posted 12 October 2015 - 01:01 AM

Gotcha. Thanks Greg. Looks like I need to go through everything thus far and make any ini tweaks inside MO.


  • 0

#52 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,928 posts

Posted 12 October 2015 - 08:50 AM

Do you have Enboost installed? If so, make sure you check your vsync and limiter settings in the enblocal.ini, as well. Also, what is your screen resolution?



#53 winflakes

winflakes

    Citizen

  • Citizen
  • 21 posts

Posted 12 October 2015 - 05:34 PM

Yes I do have ENBoost. 

 

Vsync:

EnableVSync=true
VSyncSkipNumFrames=0
 
Limiter:
WaitBusyRenderer=false
EnableFPSLimit=false
FPSLimit=10.0
 
My gut is telling me that it can't be anything with a limiter, because it goes above 40FPS often. It just holds steady at 40FPS longer than what i would deem just an FPS dip due to randomness.
 
Monitor is 1920 X 1080 at 120 Hertz refresh rate.

  • 0

#54 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,928 posts

Posted 12 October 2015 - 09:31 PM

Ah, turn off all vsync (driver, game, enb) and set the limiter in enblocal.ini to 59.9. That should fix it. Let me know of it does.

#55 winflakes

winflakes

    Citizen

  • Citizen
  • 21 posts

Posted 12 October 2015 - 10:19 PM

Thanks Tech. I won't be home to test until Wednesday, but I will do that for sure. Quick question about the limiter, would the number it is set to even matter if it is toggled off?


  • 0

#56 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,928 posts

Posted 12 October 2015 - 10:36 PM

No, it won't be used at all if it's turned off. Best bet is the hertz of your monitor is what's causing the issue. Turning off all vsyncs and limiting the frame rate should allow the game to run as fast as it can without going over 60fps, which causes havok issues.

#57 winflakes

winflakes

    Citizen

  • Citizen
  • 21 posts

Posted 14 October 2015 - 11:46 PM

Looks like that was my issue. I turned off vsync in the enblocal.ini and set the limiter to 59.0 (even though it is still off) and my frames started at 83 and went up and averaged 132 for the first 19 seconds... until i had to close the game due to the card spinning like a top. I'll turn on the limiter and set it to 65 and see how that does.


  • 0

#58 winflakes

winflakes

    Citizen

  • Citizen
  • 21 posts

Posted 15 October 2015 - 12:49 AM

Turning off all vsyncs and limiting the frame rate should allow the game to run as fast as it can without going over 60fps, which causes havok issues.

This fixed my Framerate drop issue. Thanks so much Tech. My average Framerate for 2.H was 59.92 with a low of 53. Thats after adding a dozen or so non-step mods, like Immersive armors and weapons.

 

The issue with the spinning cart was due to a bug in Immersive armors that i needed to download a fix for and works fine now.

 

Thanks for your help Tech!


  • 0

#59 Hackfield

Hackfield

    Guard

  • Citizen
  • 122 posts

Posted 15 October 2015 - 07:22 AM

Ah, turn off all vsync (driver, game, enb) and set the limiter in enblocal.ini to 59.9. That should fix it. Let me know of it does.

Hi Tech, wanted to ask you, what's the benefit of setting ENB's fps limiter instead of nvidia's? Because for me, the ENB limiter often gets turned off in certain places (for example when I look at Farengar's room in Dragonsreach, the limiter suddenly gets turned off and my fps goes to the sky) while with nvidia's fps limiter this doesn't happen.


  • 0

#60 TechAngel85

TechAngel85

    Akatosh

  • Administrator
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,928 posts

Posted 15 October 2015 - 09:47 AM

None and I would normally recommend Nvidia's. I said to use ENB limiter because Winflakes said the limiter wasn't an option when looking in Inspector.



Also tagged with one or more of these keywords: fps, performance, load order, enb

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users