Jump to content


Photo

SKSE .ini Settings Not Working



Best Answer Greg , 01 October 2015 - 07:45 PM

According to the original post, the skse.ini settings are 768/256 so the first line in Memory Blocks Log should be 512/256 but is 256/256 instead. This seems to indicate either skse_loader.exe isn't running, it isn't finding the skse.ini file, or there's a typo somewhere in the skse.ini that is causing it not to read the entries correctly. I ruled out skse_loader.exe not running because he added the -forcesteamloader argument and (correct me I'm mistaken) Memory Blocks Log doesn't work with skse_loader running.

 

You know, thinking about this in more depth, is it possible that skse.ini is stored in Unicode format? Seems I ran into an issue a while back with an ini file not being read and I finally figured out the bloody thing was in Unicode instead of ANSI/ASCII.

 

[General]
ClearInvalidRegistrations=1

[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256

[Display]
iTintTextureResolution=2048
Go to the full post


  • Please log in to reply
20 replies to this topic

#16 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,621 posts

Posted 01 October 2015 - 08:53 PM

Oh, that... That isn't something that I was expecting.
Is that a bug?

Anyway, I'll add it to the op soon

#17 Lagosaurus

Lagosaurus

    Prisoner

  • Members
  • 7 posts

Posted 01 October 2015 - 11:14 PM

 

According to the original post, the skse.ini settings are 768/256 so the first line in Memory Blocks Log should be 512/256 but is 256/256 instead. This seems to indicate either skse_loader.exe isn't running, it isn't finding the skse.ini file, or there's a typo somewhere in the skse.ini that is causing it not to read the entries correctly. I ruled out skse_loader.exe not running because he added the -forcesteamloader argument and (correct me I'm mistaken) Memory Blocks Log doesn't work with skse_loader running.

 

You know, thinking about this in more depth, is it possible that skse.ini is stored in Unicode format? Seems I ran into an issue a while back with an ini file not being read and I finally figured out the bloody thing was in Unicode instead of ANSI/ASCII.

[General]
ClearInvalidRegistrations=1

[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256

[Display]
iTintTextureResolution=2048

I was debugging some old code for a colleague that just so happened to be in UCS-2LE and ended up encoding my SKSE.ini file in it. I converted it over to UTF-8 and the ini settings were properly registered. As far as ANSI/ASCII/Unicode goes, SKSE doesn't really care what you throw at it as long as you don't use some archaic encoding method like I did. Thanks for the help.


  • 0

#18 Neovalen

Neovalen

    Talos

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 5,679 posts

Posted 01 October 2015 - 11:19 PM

Glad that was figured out, it was a real head scratcher. :)


  • 0

#19 z929669

z929669

    Ixian Inventor

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 9,314 posts

Posted 02 October 2015 - 09:36 AM

Placing this into the support forums so that it can be found more easily ... updating OP



#20 Edahi

Edahi

    Prisoner

  • Members
  • 1 posts

Posted 12 October 2019 - 03:40 AM

Hello, I would like to rekindle this topic since even when I followed to the letter the guide, I am still getting the 256/256 instead of the 768/256.

 

I am clueless of what is happening and I can't narrow down the problem in my case... I checked the skse.log file and the config path is listed correctly:

D:\Users\Edahi\Documents\My Games\Skyrim\SKSE\skse.log

generated and modified when I started and was playing the game. The content is as follows, of particular interest the "config path" line, 4th:

SKSE runtime: initialize (version = 1.7.3 09200000 01D580D52E672970, os = 6.2 (9200))
imagebase = 00400000
runtime root = D:\Users\Edahi\Games\Skyrim\
config path = D:\Users\Edahi\Games\Skyrim\Data\SKSE\skse.ini
plugin directory = D:\Users\Edahi\Games\Skyrim\Data\SKSE\Plugins\
checking plugin D:\Users\Edahi\Games\Skyrim\Data\SKSE\Plugins\\MemoryBlocksLog.dll
plugin D:\Users\Edahi\Games\Skyrim\Data\SKSE\Plugins\\MemoryBlocksLog.dll (00000001 MemoryBlocksLog plugin 00000001) loaded correctly
dispatch message (0) to plugin listeners
no listeners registered
dispatch message (1) to plugin listeners
no listeners registered
init complete
hooked dinput
....

And the content and path of the skse.ini:

D:\Users\Edahi\Games\Skyrim\Data\SKSE\skse.ini
[General]
ClearInvalidRegistrations=1


[Memory]
DefaultHeapInitialAllocMB=768
ScrapHeapSizeMB=256


[Display]
iTintTextureResolution=2048

While being careful to encode in ANSI. And yet the memory still does not change. Do you guys have any clue of why,even when in theory is loading the correct config file it is not applying the expected changes?

 

Thank you very much!


  • 0

#21 Greg

Greg

    Dragon Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,038 posts

Posted 12 October 2019 - 08:49 AM

The usual culprits are covered in this thread and the most common one is naming the file skse.ini.txt instead of skse.ini. This one is really easy to do if you have file extensions hidden. You might also check D:\Users\Edahi\Documents\My Games\Skyrim\SKSE\skse_steam_loader.log since this one has some information on the heap settings read from the ini at the bottom of the log:
 

dll = C:\Program Files (x86)\Steam\steamapps\common\Skyrim\skse_1_9_32.dll
old winmain = 0069D1D0
runtime root = C:\Program Files (x86)\Steam\steamapps\common\Skyrim\
config path = C:\Program Files (x86)\Steam\steamapps\common\Skyrim\Data\SKSE\skse.ini
overriding memory pool sizes
default heap = 768MB (effective 512MB if not preloading animations)
scrap heap = 256MB
OnHook: thread = 21112
calling winmain

What you've posted here seems to indicate skse.ini is in the correct folder and the contents of the file look correct to me as well.





Also tagged with one or more of these keywords:

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users