Jump to content


Step 2.2.7 - Two years later ... feedback

  • Please log in to reply
No replies to this topic

#1 stepwanw



  • Members
  • 16 posts

Posted 25 October 2015 - 12:45 PM

Hello Step Community,


in fall 2013 I set up Step 2.2.7 with your dear support -


Today I finished the last  (non-radiant) vanilla quest I found with all official Dlc installed - (played it rather completionist.)


I think I have about 1500+ hours into the game and 2.2.7 was therefore thoroughly tested. It ran all the way VERY smoothly. The freezes and crashes were almost non-existent...

I briefly get back to you for potential input - long overdue - and perhaps superfluous with regard to the current versions of STEP. At the same time this is a possible intro for unexperienced players.


Biggest Issues with improved vanilla acc. to Step:


1. Quests


In 2.2.7 I recall you had one vanilla-quest changer - The Paarthunax-Dilemma - mod included. I came across several other instances where a vanilla quest changer mod seems appropriate and would rather enhance the vanilla experience than screwing it up. (The following titles are the mod names that bring about such change as they are found on the Nexus:)


Boethia for Good Guys       https://www.nexusmod...im/mods/22818/?


House of Horrors Alternate Ending       https://www.nexusmod...im/mods/21700/?


Namira for Good Guys         https://www.nexusmod...im/mods/24224/?


Alternative quest end Lights Out after first killing leader Broken Oar Grotto           https://www.nexusmod...im/mods/19614/?


- What's still missing is a change-mod for 'Feeding the Addiction' (Dragonborn-DLC)                  https://www.uesp.net...g_the_Addiction



(This list is not exhaustive but covers the major game-breaking quests for people that have not chosen a character for pitch-black roleplaying. - Dark Brotherhood is a different issue - 'solved' it as a full-upgraded werewolf _ supposedly deteriorating _  and after that freeing him from the curse.)


2 years ago I wondered whether together with the STep Setup one may install 'Interesting NPCs'. Briefly tried that mod but found it (despite lore-friendly and all) too big a step away from the Vanilla: reason - Skyrim becomes a much more talkative space with that mod - places where you normally experience more or less silence or just the vast landscape - and due to the extent of the mod it's the whole world in a way that's affected- become now rather inn-like. Fun for a second run - but not for a vanilla playthrough.



2. Technical


As I said, Step 2.2.7 ran smooth as  ... . And there's so for been only one location where I experience regular freezes: It's (or rather has become) Riften:

Entering the Thieves Guild from the Cemetery works but inside the TG main hall if I turn towards the exit to the pub and try to enter I get the 'eternal fog' loading screen. If I reload from within the Main Hall, all's fine.


--- And that's the ONLY regular and repeatable freeze I know of! ---



3. Immersion, Game-break general


Now, even if that's  not step-related there are two more things. - One is the 'Aiming System' - I always wondered how it works but often I find it stuck: For example, aiming at  a target I find it's bar + name shown on-screen but often, when I switch the target, I find that the previous target is still the target shown on-screen. That makes it difficult, for example, to check and switch through various enemies screening their status. (Yet one can live with it.) [Actually I'm not sure how the targeting works - whether it depends on the attacker rather than whom the PC attacks I'm not sure.]


The second and, mechanic-wise, perhaps MOST game-breaking issue playing via PC (and with mouse and board) is to not be able to control the movement sensitively as with a gamepad joystick. I find this makes a huge difference in role-playing. The hard switch from walking to running, even after 1000+ hs of  playing Skyrim I get never used to. (Is the new Steam-gamepad any good and can it first of all accomodate many more key functions that a normal one?)


(Another brief detail I discovered only after connecting a gamepad to the game some weeks ago for the very first time: that you can zoom-in and out of the models displayed on loading screens - and that they are actually 3-d-models which, even by using the mouse and keyboard, you can turn horizontally. This was a hilarious surprise for I had never tried it before.)





And that's it. In brief: STEP works. Thanks. And keep up the good work.

Edited by stepwanw, 31 October 2015 - 04:48 AM.

  • 0

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users