Jump to content


Photo

Blocky shadows even with .INI settings at 4096


Best Answer JawZ , 08 February 2016 - 02:58 PM

The larger the Shadow distance and game FOV, the more blocky the shadows will be. I run with 4096 shadow resolution, ShadowBlur at 3, FOV at 65 and a shadow distance of 8000. Looks ok, but it will never look great/good with Bethesda's Gamebryo engine.

Going above FOV at 65 with 1080p resolution will make your shadows blocky in certain viewing angles but a FOV at 80 or above will make them blocky no matter viewing angle.

 

These shadow questions have been aswered before, many times over both here on the STEP forum and around the net.

Go to the full post


  • Please log in to reply
10 replies to this topic

#1 C4RN1F3XX

C4RN1F3XX

    Citizen

  • Citizen
  • 12 posts

Posted 08 February 2016 - 02:16 AM

Hey guys, 

 
I've found this guide yesterday after deciding to play Skyrim again, so i started following the instructions to install STEP:core.
At last I installed the mods in the 'Conflicting Graphics' section.

Then, while quickly testing if everything is running well, I noticed that my shadows are very blocky ingame.

I followed each step in the guide so far, i even double checked the steps, so I can't really tell what makes my shadows blocky.
Of course I did the INI tweaks as the guide says first and I did them inside of MO, but there has to be a setting which still makes the shadows blocky, even on a 4096 shadow map resolution.
Also, following these instructions didn't have any effect on my ingame shadows AT ALL. Strange enough. :/
I'll post my .INI settings in spoilers down below. Can anyone help me with this, since I'm not that experienced in modding and tweaking Bethesda games? If you have any questions which I need to answer in terms of finding a solution, feel free to ask.
 
Greetz,
 
CarnifeX

 

 

SkyrimPrefs.INI

 

 

 

Skyrim.INI


Edited by C4RN1F3XX, 08 February 2016 - 02:42 AM.

  • 0

#2 DoubleYou

DoubleYou

    Wiki Stepper

  • Uber Moderator
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,738 posts

Posted 08 February 2016 - 02:49 AM

Could you post a screenshot of your blocky shadows?

#3 C4RN1F3XX

C4RN1F3XX

    Citizen

  • Citizen
  • 12 posts

Posted 08 February 2016 - 03:23 AM

Of course, just follow this link:
 
 
M00e6Eg.jpg


  • 0

#4 DoubleYou

DoubleYou

    Wiki Stepper

  • Uber Moderator
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,738 posts

Posted 08 February 2016 - 05:55 AM

OK. It looks like what you want is to increase iBlurDeferredShadowMask. Set it to 6 and see if you like the result.

#5 C4RN1F3XX

C4RN1F3XX

    Citizen

  • Citizen
  • 12 posts

Posted 08 February 2016 - 12:20 PM

Sadly not..

I forgot to say that this screenshot was taken with this value being 10. :/

 

I tried out this tweak right here:

 

https://www.overcloc...looking-shadows

 

There you can see what the result should look like, but mine still looks like that screenshot i posted :( I am doing something wrong but can't find the mistake

 

My prefs.INI as it is now, no changes afterwards, i highlighted every setting which is changed through the tweak following the link above. I didn't change shadow render distances though, but i don't think that this is the reason for my shadows being pixelated:

 

skyrimPrefs.ini

 

 

UPDATE: Oh dude how wrong i am.. Lowering shadow distance fixed it for me. man, skyrim shadows suck. xD


Edited by C4RN1F3XX, 08 February 2016 - 12:44 PM.

  • 0

#6 DoubleYou

DoubleYou

    Wiki Stepper

  • Uber Moderator
  • PipPipPipPipPipPipPipPipPipPipPip
  • 4,738 posts

Posted 08 February 2016 - 02:42 PM

Indeed. In my testing, setting it beyond 5000 is unnecessary.

#7 JawZ

JawZ

    Knight

  • Mod Author
  • Pip
  • 390 posts

Posted 08 February 2016 - 02:58 PM   Best Answer

The larger the Shadow distance and game FOV, the more blocky the shadows will be. I run with 4096 shadow resolution, ShadowBlur at 3, FOV at 65 and a shadow distance of 8000. Looks ok, but it will never look great/good with Bethesda's Gamebryo engine.

Going above FOV at 65 with 1080p resolution will make your shadows blocky in certain viewing angles but a FOV at 80 or above will make them blocky no matter viewing angle.

 

These shadow questions have been aswered before, many times over both here on the STEP forum and around the net.


  • 0

#8 Shadriss

Shadriss

    Jarl

  • Citizen
  • PipPipPip
  • 1,496 posts

Posted 08 February 2016 - 03:12 PM

Going above FOV at 65 with 1080p resolution will make your shadows blocky in certain viewing angles but a FOV at 80 or above will make them blocky no matter viewing angle.

Not true, in my experience. I use 1080p with an FOV of 81, and it's all smooth sailing for me. Mayhaps an ENB would mitigate the problem you speak of? I've not noticed any blockiness in quite a long time.


  • 0

#9 EssArrBee

EssArrBee

    Incompatibilism Manager

  • VIP-Supporter
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 7,461 posts

Posted 08 February 2016 - 03:40 PM

Are you changing the INIs through MO or from the files in your docs folder?
  • 0

#10 JawZ

JawZ

    Knight

  • Mod Author
  • Pip
  • 390 posts

Posted 08 February 2016 - 03:44 PM

It's true, I've tested it countless of times, and it's not as much "blockiness" as it is reduced quality.

 

An image comparison, granted it's Fallout 4 but same engine in the end.

22803073189_c3e7f99ef4_o.pngShadow FOV Normal

22776890897_864056a18f_o.pngShadow FOV Blurred, when changing viewing angle


  • 0

#11 C4RN1F3XX

C4RN1F3XX

    Citizen

  • Citizen
  • 12 posts

Posted 09 February 2016 - 05:04 PM

Are you changing the INIs through MO or from the files in your docs folder?

Inside MO of course, but I now understood how Skyrim shadows work and can adapt to it.

Before posting this thread I didn't know about the engine's own mechanic to balance shadow quality vs distance, now I do.. thanks guys. :)


  • 0


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users