Jump to content


Photo

Samsung SSD and Skyrim

ssd rapid mode skyrim

  • Please log in to reply
15 replies to this topic

#1 Rebel47

Rebel47

    Commander

  • Members
  • PipPipPipPip
  • 200 posts

Posted 10 February 2016 - 10:00 AM

Ok so I have an issue that I am having trouble resolving and would love to know what other peoples experiences are with this, I have a Samsung 840 Evo Pro 500GB and I turned on Rapid mode and since doing that I've noticed that my skyrim will stutter uncontrollably when turning even with the enb turned off, I'm not sure if it's related to Rapid mode or not but would love to see what other people's mileage with this is.


  • 0

#2 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 10 February 2016 - 10:01 AM

Do you used Intel Rapid Storage Technology? I don't think the two are compatible.

#3 Rebel47

Rebel47

    Commander

  • Members
  • PipPipPipPip
  • 200 posts

Posted 10 February 2016 - 10:48 AM

It's not on my list of installed programs no, to find out anything more I'd need to enter the bios and find out what is set there.


  • 0

#4 hishutup

hishutup

    Daedric Prince

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 2,585 posts

Posted 10 February 2016 - 01:21 PM

When I get my shipment of PC parts I'll see if I have an issue with a samsung 950 ssd

#5 Kelmych

Kelmych

    Dragon King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,825 posts

Posted 10 February 2016 - 02:01 PM

I don't use Rapid mode. I've never had any problems with my Samsung 840 EVO.



#6 Rebel47

Rebel47

    Commander

  • Members
  • PipPipPipPip
  • 200 posts

Posted 10 February 2016 - 03:55 PM

From my testing it seems that rapid mode is not all it's made out to be, I will be performing more tests though, but simply put when rapid mode is enabled it seems to apply a caching effect on the SSD which actually slows it down slightly, despite it appearing to run faster than initially thought.

I am seriously struggling to find anything on Rapid mode other than the arguements of it's good/it's bad, nothing concrete, If I find anything more out about it I'll post it here, since this could be useful information for gaming and/or general pc use.


  • 0

#7 TechAngel85

TechAngel85

    Akatosh

  • Administrators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 12,058 posts

Posted 10 February 2016 - 06:19 PM

Rapid mode caches data in RAM.

#8 Greg

Greg

    High King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,488 posts

Posted 10 February 2016 - 06:40 PM

It sounds as if Rapid mod is just a duplication of the Windows disk cache to me.



#9 GrantSP

GrantSP

    The antipodean

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 3,962 posts

Posted 10 February 2016 - 06:59 PM

Doing a Google search of "RAPID mode" and reading the first response provides me with the same feeling. Just a different implementation of Windows' disk cache.



#10 Rebel47

Rebel47

    Commander

  • Members
  • PipPipPipPip
  • 200 posts

Posted 10 February 2016 - 09:43 PM

Since caching on an SSD is not usually a good idea I think it's probably safer to disable it, since when I had it disabled I never had issues running Skyrim at all, I can't verify if turning on Rapid mode caused my issues but it certainly didn't help them.

 

I'll do this and test and report back with the results.

 

-Update-

 

Turned off rapid mode and restarted the pc, loaded up Skyrim and the stutter is still there, I get it while turning the camera, trying to move in any direction, I didn't have this issue yesterday I was playing fine (albeit with basic enb w/o preset and SweetFX) and I was dropping to low 30fps and running smooth, removed sweetfx, reinstalled enb and turned on rapid mode and 1 day later it all hits the fan, one note to make though, I did get a windows 10 update when I turned my pc off last night, (configuration anyway) I wonder if that could have done this.

 

It's not SKSE because throughout all that I hit my highest block 1 | block 2 was 328 | 252 respectively my ini files have remained the same (No changes were made from when the game worked perfectly) I'm actually dumbfounded by this at the moment.


Edited by Rebel47, 10 February 2016 - 10:31 PM.

  • 0

#11 darkside

darkside

    High King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,339 posts

Posted 10 February 2016 - 10:29 PM

RAPID mode uses 1GB+ of RAM for caching. If you have limited RAM, you may have a problem. 

 

I don't find it improved Skyrim performance after my testings.


Edited by darkside, 10 February 2016 - 10:32 PM.

  • 0

#12 Rebel47

Rebel47

    Commander

  • Members
  • PipPipPipPip
  • 200 posts

Posted 11 February 2016 - 09:35 AM

Well after disabling rapid mode and trying every fix under the sun but 2,I still had no luck, so I tried the 1st of the 2 fixes I had purposely left till last, kind of like a last resort, and the first one I tried was "EnableUnsafeMemoryHacks" in enblocal and would you believe it my fps was back to normal values, this got me to thinking, was there a mod that I updated or installed recently that would change it's file format and that's when it hit me, since I was 60fps plus I thought to try using Noble Skyrim Full pack instead of performance, I didn't notice any lag spikes until a day or so ago (strangely enough around the same time that Microsoft decided they wanted to update windows 10 yet again) and then turning my pc on the next day I was hit the huge fps drops and stuttering, I have yet to try if disabling vsync will solve it but if it does I can disable unsafe memory hacks and use a limiter with my card to keep it around 60fps.


Edited by Rebel47, 11 February 2016 - 09:38 AM.

  • 0

#13 Nebulous112

Nebulous112

    High King

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPip
  • 1,415 posts

Posted 11 February 2016 - 09:56 AM

I'm not sure if this is relevant, but try disabling the Steam beta, if you are signed up for it. See here: http://forum.step-pr...ates-overnight/

#14 Rebel47

Rebel47

    Commander

  • Members
  • PipPipPipPip
  • 200 posts

Posted 11 February 2016 - 10:52 AM

I'll give that a try, I have been in the Steam beta for quite some time now and never had any issues until now obviously, I would love it if that solved my issue as I hate running around with "EnableUnsafeMemoryHacks" on, makes me feel uneasy, I also enabled a osd to see my temps and usage and my cpu & gpu wasn't even hitting 50% usage even on the most strenuous parts of the game which was inside the Whiterun inn with iNPC's and Wenches of Skyrim so the inn was packed to the gills and still 50% usage was not hit and the highest temp was 70c that was my gpu

 

Just tested this out before posting and here's what I did in step by step order

 

  1. Re-enabled V-sync
  2. Disabled "EnableUnsafeMemoryHacks"
  3. Opted out of the Steam Beta
  4. Started the game and loaded a save in whiterun where I had massive slow down and lag to the nth degree

 

After doing all of that and upon loading my save I experienced my usual 0.5 seconds of initial lag as everything loads in but then rotating the view around with very quick mouse movements left me with no fps drop and no lag, so this leaves me to my final question, What in the world did steam do to so badly break skyrim like they have in the Beta ?


Edited by Rebel47, 11 February 2016 - 10:52 AM.

  • 0

#15 DoubleYou

DoubleYou

    Wiki Stepper

  • Super Moderators
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,471 posts

Posted 11 February 2016 - 10:56 AM

Perhaps disabling the Steam Overlay might fix it.

Note to self: Don't participate in the Steam beta.



Also tagged with one or more of these keywords: ssd, rapid mode, skyrim

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users