Jump to content


Photo

Error loading textures: Not a valid DDS texture

sse error dyndolod

  • Please log in to reply
25 replies to this topic

#1 Chef

Chef

    Prisoner

  • Members
  • 2 posts

Posted 15 July 2019 - 11:49 AM

I will try to provide complete information here.  The log file was shortened to just the last run.

 

I have run in order the 64bit LODgen, TexGen, and then DynDOLOD.  The first 2 completed without error, but DynDOLOD keeps erroring out at the same place.

 

The file TreePineForestSnow01_0005c072.dds is being provided by Indistinguishable VANILLA Medium.  Should I just be hiding this file in that mod?

 

I've been working on this for a bit and reading everything I can, so at this point it is quite likely that I have read the solution already, and just cant remember it.  I am assuming there is an error on my part somewhere though.  Any help would be welcome, and if I did not include all the information needed, I will gladly do so.

Attached Files


  • 0

#2 RealCakez

RealCakez

    Prisoner

  • Members
  • 2 posts

Posted 15 July 2019 - 01:22 PM

I've reran TexGen without any issues 3 times now and whenever i try to generate LOD i get the same errors. Does this have something to do with the textures generated by TexGen or is it some mod i am using that isn't compatible with DynDOLOD?

 

Part of the log that shows the error: https://pastebin.com/WUAGtN1m

Modlist: https://modwat.ch/u/RealCakez/modlist

 

The modding guide that i followed uses SSELODGen, however my game crashes when i have that LOD enabled (runs completely fine without it) - Mod load order was sorted using LOOT through MO2.

Attached Files


Edited by RealCakez, 15 July 2019 - 01:24 PM.

  • 0

#3 Chef

Chef

    Prisoner

  • Members
  • 2 posts

Posted 15 July 2019 - 01:28 PM

I managed to solve the problem.  I reinstalled Indistinguishable VANILLA Medium and DynDOLOD completed without any errors.

 

After rereading a bunch of stuff I came across something where Sheson suggested reinstalling the mod that was causing problems.  This seems to have solved it.

 

Thank you for this great tool by the way, I absolutely love the way Skyrim looks with DynDOLOD.


  • 0

#4 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,744 posts

Posted 15 July 2019 - 01:37 PM

The error message in the log:
Error creating textures for atlas: Error loading textures\lod\solitudearch03lod_n.dds: Not a valid DDS texture
Error creating textures for atlas: Error loading textures\lod\hhbuildingslod01_n.dds: Not a valid DDS texture
 

 

FAQ: DynDOLOD.exe: Error preparing textures for atlas: Error loading textures\*.dds: Not a valid DDS texture 

 
A: The mentioned texture is corrupted and needs to be fixed or replaced. This sometimes seems to happen with specific MO2 versions under Windows 10, the exact cause is currently unknown. 
 
A: Look up the texture path in MOs right window Data tab to find out which mod supplies it. Reinstall the textures from the mod, DynDOLOD Resources or TexGen output, whichever it is. 
 
 
A modding guide that uses use SSELODGen for object and tree LOD is not really a good guide :)
The crashes with LOD generated by SSELODGen most likely happened for the same reason as the error with the textures, corrupted files.
Can also happen when not setting a dedicated output folder with -o command line, something DynDOLOD takes care of automatically to make things easier.

Edited by sheson, 15 July 2019 - 01:47 PM.

  • 0

#5 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,744 posts

Posted 15 July 2019 - 01:38 PM

The error message in the log:

Error preparing textures for atlas: Error loading textures\terrain\lodgen\skyrim.esm\treepineforestsnow01_0005c072.dds: Not a valid DDS texture

 

 

FAQ: DynDOLOD.exe: Error preparing textures for atlas: Error loading textures\*.dds: Not a valid DDS texture 
 
A: The mentioned texture is corrupted and needs to be fixed or replaced. This sometimes seems to happen with specific MO2 versions under Windows 10, the exact cause is currently unknown. 
 
A: Look up the texture path in MOs right window Data tab to find out which mod supplies it. Reinstall the textures from the mod, DynDOLOD Resources or TexGen output, whichever it is. 
 
 
(This post is for future searches)

Edited by sheson, 15 July 2019 - 01:39 PM.

  • 0

#6 RealCakez

RealCakez

    Prisoner

  • Members
  • 2 posts

Posted 15 July 2019 - 02:02 PM

Reinstalled the textures and running DynDOLOD again, i'll update if it fixed or if there's another error.

 

The guide said either DynDOLOD or SSELODGen could be used, it just used the latter as an example.

 

Edit: Command prompt opened up and it's doing stuff

 

Edit: Completed succesfully - MO2 should give us a heads up for corrupted files tbf... But thanks for the help! (and the quick response)


Edited by RealCakez, 15 July 2019 - 02:14 PM.

  • 0

#7 paleocryosis

paleocryosis

    Prisoner

  • Members
  • 3 posts

Posted 19 July 2019 - 02:43 AM

Hi there. I made a post on Reddit and was directed to make a post here as well, so here I am. I hope I am in the right place.

DynDOLOD does not seem to like me, as I'm getting in-game errors as well as some during generation (here: https://imgur.com/MCWnHDE). I would upload the entire log but it's over 500KB and I can't find a text host site that will upload it. My apologies. Despite the above errors I can still save the .esp and .esm so I'm unsure of how much it matters.

Here's my plugin list at the moment: https://modwat.ch/u/...cryosis/plugins

Here's what my left pane in MO2 looks like: https://imgur.com/UKKA7qJ

Here's the Worlds error I'm getting upon loading the game: https://imgur.com/npuo3US

And in the MCM, DynDOLOD is not active: https://imgur.com/mDZ6JcN

 

In-game, I'm getting a LOT of tree pop-in as if they're not loading as far out (though I can see a quality difference, kind of...??) and my framerate has dropped, so I feel like it could be PARTIALLY working or I'm just silly. I run the TexGenx64.exe and DynDOLODx64.exe through MO2, both with the -sse argument added. I've tried running them both as an administrator and disabling my antivirus, but that doesn't work. My Steam, SSE install, MO2, etc etc are all installed outside of the Program Files folder so I do not think that is the issue.

 

I'm not sure how to fix these errors and make sure DynDOLOD is running properly; can I get some guidance on this?


  • 0

#8 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,744 posts

Posted 19 July 2019 - 03:13 AM

The LOD generation process stopped prematurely and most likely did not print 'DynDOLOD Worlds completed successfully' to the log as explained in the manual.

It doesn't really make sense to install an incomplete LOD patch and expect it to work.

 

There is a reason for the message that says to check the log lines above the error for hints or if problem persists to post an error report with entire contents (not just the last couple lines) of ..\DynDOLOD\bugreport.txt (if it exists) and ..DynDOLOD\Logs\DynDOLOD_SSE_log.txt

as there there most likely will be more informative log message above what is shown in the screenshot.

 

Truncate the log to the last generation only. Then upload to pastebin or  zip it before uploading to a file service.


Edited by sheson, 19 July 2019 - 03:15 AM.

  • 0

#9 paleocryosis

paleocryosis

    Prisoner

  • Members
  • 3 posts

Posted 19 July 2019 - 04:22 PM

Hi. After a night of sleep I've realized that I was an idiot about this... remind me not to post anything to the internet after 10pm, it's a lost cause. My apologies.

 

Here's the DynDOLOD_SSE_log.txt where it gave me the errors: https://pastebin.com/uVxz0m7T

Here's the bugreport.txt: https://pastebin.com/W2mUAjbz

And here's the TexGen_SSE_log.txt just in case that could be related, though running TexGen gave me no troubles at all: https://pastebin.com/mZZRvNmD

 

Sorry again. I'm not sure what to make of these but I hope they can be of more use.


  • 0

#10 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,744 posts

Posted 20 July 2019 - 01:19 AM

<Error creating textures for atlas: Error loading textures\lod\mtntrimslablod_n.dds: Not a valid DDS texture>

 

FAQ: DynDOLOD.exe: Error loading textures\*.dds: Not a valid DDS texture 

 
A: The mentioned texture is corrupted and needs to be fixed or replaced. This sometimes seems to happen with specific MO2 versions under Windows 10, the exact cause is currently unknown. 
 
A: Look up the texture path in MOs right window Data tab to find out which mod supplies it. Reinstall the textures from the mod, DynDOLOD Resources or TexGen output, whichever it is. 
 

 

Also double check this mesh (probably from Majestic Mountains):

<Warning: Error when loading "meshes\lod\mountains\mountaintrimslab_lod_0l.nif": Not a valid NIF file>

 

Relevant threads

https://forum.step-p...id-dds-texture/

https://forum.step-p...returned-error/


  • 0

#11 paleocryosis

paleocryosis

    Prisoner

  • Members
  • 3 posts

Posted 22 July 2019 - 02:51 AM

Hey! It took a couple reinstalls of mods (MM, you're a real pain...) but I finally got it to run right and it's all working. Thank you very much for your patience & response, I really appreciate it. Cheers.


  • 0

#12 Shivlxie

Shivlxie

    Prisoner

  • Members
  • 3 posts

Posted 23 July 2019 - 03:24 PM

I am using the x64 DynDoLod and I am getting an error that seems to relate to EVT

 

 

[00:02:36.714] Exception in unit userscript line 345: One or more errors occurred
[00:02:36.714]
[00:02:36.714] Check log lines above the exception for additional hints. Check the FAQ and search official forum http://forum.step-pr...ndolod-support/ for those errors.
[00:02:36.714]
[00:02:36.714] If problem persists, post error report with entire contents (not just the last couple lines) of ..\DynDOLOD\bugreport.txt and ..\DynDOLOD\logs\DynDOLOD_SSE_log.txt to official forum http://forum.step-pr...ndolod-support/
[00:02:36.715] Error: One or more errors occurred
[00:02:36.751] <Note: textures\terrain\lodgen\skyrim.esm\srg_treepineforestsnow04_0005c06f_n.dds normal map not found, using flat replacement>
[00:02:36.751] <Note: textures\terrain\lodgen\skyrim.esm\treepineforestsnow03_0005c070_n.dds normal map not found, using flat replacement>
[00:04:57.927] [05:15] Saving: DynDOLOD.esm
[00:04:57.972] [05:15] Saving: DynDOLOD.esp
[00:04:58.014] [05:15] Done saving.


I can not post the DynDoLod error log sadly because it's nearly 2MB in size...

Additionally, before this error appears DynDoLod throws up a window with a ticking clock saying "please wait."

Edited by Shivlxie, 23 July 2019 - 03:33 PM.

  • 0

#13 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,744 posts

Posted 24 July 2019 - 01:17 AM

[00:02:36.714] Check log lines above the exception for additional hints. Check the FAQ and search official forum
[00:02:36.714] If problem persists, post error report with entire contents (not just the last couple lines) of ..\DynDOLOD\bugreport.txt and ..\DynDOLOD\logs\DynDOLOD_SSE_log.txt to official forum http://forum.step-pr...ndolod-support/
 
If a log file is large, truncate it to the last generation with the error. Post logs to pastebin or zip them and use a file service.

  • 0

#14 Shivlxie

Shivlxie

    Prisoner

  • Members
  • 3 posts

Posted 24 July 2019 - 12:08 PM

https://pastebin.com/5iXnfhe4

 

 

Most I could do right now

 

Also, bugreport.txt: https://pastebin.com/KfAYGY88

 

 

https://imgur.com/a/FcnYwra

 

this image is the warning window that appears before this error.


Edited by Shivlxie, 24 July 2019 - 12:14 PM.

  • 0

#15 sheson

sheson

    Dragon King

  • Mod Authors
  • PipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPipPip
  • 4,744 posts

Posted 24 July 2019 - 12:49 PM

[00:02:34.180]    <Error preparing textures for atlas: Error loading textures\lod\mtnpeak02lod.dds: Not a valid DDS texture>

 

FAQ: DynDOLOD.exe: Error [preparing|creating] textures for atlas: Error loading textures\*.dds: Not a valid DDS texture 

 
A: The mentioned texture is corrupted and needs to be fixed or replaced. This sometimes seems to happen with specific MO2 versions under Windows 10, the exact cause is currently unknown. 
 
A: Look up the texture path in MOs right window Data tab to find out which mod supplies it. Reinstall the textures from the mod, DynDOLOD Resources or TexGen output, whichever it is. 
 

Relevant threads
 
Also pay attention to this warning, same problem.
 
[00:02:29.594]    <Warning: Error when loading "meshes\lod\mountains\mountainridge01_lod_0l.nif": Not a valid NIF file>

Edited by sheson, 24 July 2019 - 12:50 PM.

  • 0



Also tagged with one or more of these keywords: sse, error, dyndolod

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users